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1. Introduction to the Martus™ Software
1a. What is Martus™?
Named after the Greek word for witness, the Martus Project provides an efficient and secure way to store
and retrieve information about human rights abuses. Using the Martus application, you can create bulletins
that record human rights abuses, attach supporting documents, specify whether the information should be
public or private, and store the information on a secure server. Martus encrypts data directly on your
computer, and sends this data in an encrypted form to a secure server when you have an internet
connection. To learn more about the problems the Martus Project addresses, how Martus is being used
throughout the world to securely collect and store sensitive data, and future plans for the project, visit
https://www.martus.org.

1b. Why is security so important when using Martus?
The people who give you information about human rights abuses are concerned about security and
privacy—and you need to be just as concerned in order to protect them and yourself. It’s important that
only the designated people have access to the bulletins you’ve created, especially the information you deem
particularly sensitive (which you can maintain as private). It’s equally critical that no one else is able to
modify the data you submit, or to create false or inaccurate bulletins using your account.
There are steps you can take to prevent someone from using your Martus account to read the data you’ve
collected or to submit additional data, even if they steal your computer or otherwise gain access to it.

1c. How does Martus keep the data secure?
Every Martus account has a key which can only be accessed using the password for that account. When you
sign in to the Martus software, your password enables the application to open the key (associated with the
MartusKeyPair.dat file,) so that you can see the bulletins you’ve created and stored.
Your password is yours alone; without it, no one can open your private bulletins, the private data in the
public bulletins you’ve sent to the server, or any of the bulletins on your hard drive, whether they are in
draft or sealed status. However, if you’ve set up a Headquarters (HQ) account, the HQ account holder
(typically, your organization’s central office) will be able to see the private data that you sent to the server.
Because there are computer programs and keyboard alterations that can allow others to record the
characters you type on your keyboard, the Martus software includes an on-screen keyboard for you to use
when you enter your password. This makes it even harder for an intruder to discover your password.
Information secured with Martus is also protected from being modified by others and the software ensures
that no one can create false or inaccurate bulletins using your account. Even if your computer is lost,
seized, or stolen, Martus ensures that data entered into Martus bulletins cannot be read by those without
permission to access the data.

1d. What does an individual need to do to keep data secure?
Use a password that you’ll remember, but that no one else can guess. Pay special attention to the guidelines
in “2f. Choosing a password” in this user guide.
To keep your password secret, don’t write it down anywhere that it could be found and connected with the
Martus software. Don’t send it to anyone through e-mail or give it to anyone over the phone, as those
means of communications may not be secure.
In addition to your password, you need your key to access your account. Make backup copies of your key
and store them separately from your password. (For more information, see “9b. Backing up your key.”)
This is important because if you are unable to start your computer or it is stolen, you’ll need to install the
key on another computer to access the private data you have recorded, even if it’s stored on the Martus
server.
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For additional security options when running Martus, see the Tor option in “2h. Setting your preferences”
and see “11. Frequently Asked Questions” (FAQ) #53 and #54.

1e. What are the limitations to Martus security?
The Martus software uses very strong encryption technology to scramble your bulletins so that other people
cannot read them on your hard drive. However, since security involves people, and people are human,
Martus security has limitations. We want to make sure you understand these limitations, even though the
software is designed to be very secure. Here are some of the ways your private information may be
compromised:
 Somebody can find your password written down on a slip of paper
 Your password may be too simple, such as a word or a name or a simple phrase
 Somebody may watch you enter your password, or may install a new keyboard, a special connector or
special software to steal your password
 You may accidentally put something secret into the public section of a bulletin
 Someone you trusted with a headquarters key could violate your trust
 Anybody who knows your password or a headquarters password could disclose that password through
force, blackmail or even by accident
 Your password could be intercepted if you send it in an e-mail message, or say it on a tapped phone
line
 Someone could give you an altered copy of the Martus application, which could give others access to
your data
 The makers of Martus could have made a mistake in designing Martus, or a scientist might invent new
technology for breaking security, or enough time may pass that computers have more power to crack
the security.
Although Martus has been reviewed extensively for strength of security, and computer experts can review
its design to check for flaws at any time, it is likely that private information will be accessible to other
parties willing to invest the time and effort to read it at some point in the future.
Although these limitations may sound scary, Martus information is far more secure than information on
paper or in most existing computer programs (including those used by banks.) We explain these limitations
to make sure you understand them, and the importance of being security-conscious in your use of Martus.
Although we have built a very strong lock on your information, any lock can be unlocked by a key left out,
and even the strongest locks can be broken with enough effort.
Note: As described elsewhere in this User Guide, Martus allows you to attach files to bulletins. On most
operating systems, when attachments are opened they are automatically saved in a ‘temporary’ directory,
which is unencrypted. For information about the security precaution known as attachment ‘shredding,’
please see section “11. Frequently Asked Questions” (FAQ) #38.

1f. Why send bulletins to the server?
A Martus server is a computer server that accepts encrypted bulletins, securely backs them up, and
replicates them to multiple locations, safeguarding the information from loss. (Benetech provides the server
software to the organizations that host Martus servers, but it does not host Martus backup servers directly;
e-mail info@martus.org for a list of potential server hosts.) Any bulletins you haven’t sent to a server exist
only on your computer. If your computer is lost, stolen, or damaged, you could lose all of that data. The
server acts as a backup mechanism, so the data entered into Martus can be recovered if you lose access to
your computer. With your key and your username and password, you can install Martus on a different
computer and access all the public and private data in bulletins you sent to the server. And if you have set
up any Headquarters (HQ) accounts, sending bulletins to the server makes them available to those accounts
(both public and private data). See “9c. Restoring your key” and “9f. Sharing your private data with
colleagues.”
Additionally, public information in bulletins may be available to researchers, the press, and others
interested in human rights issues. If you store the bulletins on your computer, only you have access to the
information; if you send them to a server that is connected to the web-based Martus Search Engine, others
can learn about the public information in the cases you document.
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1g. Why is Martus an open source application?
Independent programmers can review the code in an open source application in a way that they cannot in
traditional applications. Benetech has developed Martus for use by human rights organizations, and it has
not included any hidden means of collecting information from Martus users, or of having the application
perform any hidden tasks. Because Martus is an open source application, you don’t have to take our word
for it. Any organization can have the code independently verified to see that it does what we say it will do.
To learn more about open source technology, visit the Open Source Initiative at
http://www.opensource.org.
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2. Getting Started
You can install and run Martus on any computer running Windows, Mac OS, or Linux that meets the
following requirements. For more information about the most current system recommendations, see the
software download page on www.martus.org.
We recommend running the current version of Martus on Windows XP/Vista/7 32-bit and Mac OSX if
possible, as it has not been as fully tested on other Windows/Mac operating system versions.
Windows
 Windows Me, Windows 2000, Windows XP, Windows Vista, Windows 7, or Windows 8. Please note
that if you are running Windows 7, you must use Martus 3.4 or later. Due to security issues discovered
in early versions of Windows and Java, Martus 4.0 will only run on versions of that are newer than
Windows 98/NT. If you have Windows98/NT or older, you need to use Martus 3.6.2 or earlier, but we
highly recommend that you try to upgrade to a more secure Windows version if possible.
 In Windows NT, Windows 2000, Windows XP Professional, Windows Vista, Windows 7 and
Windows 8, you must log in as an administrator before installing Martus.
 Pentium 233 MHz processor (300 MHz or faster recommended)
 128 MB hard disk space available ( 1 GB or more recommended)
 512 MB RAM (1 GB or more recommended)
 Internet connection, to back up data to the Martus server. If you do not have an internet connection,
see section “9g. Enabling other accounts to send your bulletins to a server.”
 To send bulletins to a Martus Server, your Martus software must not be blocked by a firewall. If you
have a software or hardware firewall, it must allow your computer to contact ports 987 and 988, or
ports 80 and 443, on the Internet. If these ports are blocked when you try to select the server, you will
see a message that the server is not responding.
 CD drive (for CD installation only)
 Screen resolution of 800x600 or greater
Note: To display your system specifications in Windows, go to Start > Programs > Accessories > System
Tools > System Information.
Mac OS
 Mac OS 9.2 or higher (10.6.4 or later recommended)
 Java Runtime Environment (JRE) version 1.6 (sometimes called Java6). Java6/version 1.6.0_30 or
later is best if possible, Java5/version 1.5.0_22(rev-b07) or a later 1.5 version if Java6 is not possible.
Note: Java 1.5 and Java 1.6 earlier than the specific versions mentioned above will not work with
Martus Language Pack (MLP) files and may cause other issues in the Martus user interface. You can
check which version of Java is running on your machine by opening a terminal window and typing
“java -version” (without the quotes) and hitting enter/return.
 75 MB hard disk space available (100 MB or more recommended)
 1GB RAM
 Internet connection, to back up data to the Martus server. If you do not have an internet connection,
see section “9g. Enabling other accounts to send your bulletins to a server.”
 To send bulletins to a Martus Server, your Martus software must not be blocked by a firewall. If you
have a software or hardware firewall, it must allow your computer to contact ports 987 and 988, or
ports 80 and 443, on the Internet. If these ports are blocked when you try to select the server, you will
see a message that the server is not responding.
 CD drive (for CD installation only)
 Screen resolution of 800x600 or greater
Note: To display your system specifications in Mac, go to the Apple menu > About this Mac > More
info… > System report… > Hardware (this is the Hardware Overview).
Note: If you have multiple versions of Java installed, you will need to launch the Java Preferences dialogue to
change the version of Java to be used. To locate it, hit Command-Space to bring up the "Spotlight" search,
and type Java Preferences. Once it is open, you will see two sets of configurations, one for Java applet plugins
and another for Java applications. If you wish to change the version of Java Martus uses by default, select the
Martus 4.3 User Guide

8

new version using the dialogue instructions, then close out of the Java Preferences screen. For additional
assistance, please email help@martus.org.
Linux
 Intel Pentium platform running Linux kernel v. 2.4 and glibc v. 2.2 or later
 Either the latest version of Oracle, Java Runtime Environment (JRE) 1.6. (sometimes called Java6),
update 25 or later; or OpenJDK JRE 6 or 7. You can check which version of Java is running on your
machine by opening a terminal window and typing “java -version” (without the quotes) and hitting
enter/return.
 75 MB hard disk space available (100 MB or more recommended)
 256 MB RAM (512 MB or more recommended)
 Internet connection, to back up data to the Martus server. If you do not have an internet connection,
see section “9g. Enabling other accounts to send your bulletins to a server.”
 To send bulletins to a Martus Server, your Martus software must not be blocked by a firewall. If you
have a software or hardware firewall, it must allow your computer to contact ports 987 and 988, or
ports 80 and 443, on the Internet. If these ports are blocked when you try to select the server, you will
see a message that the server is not responding.
 CD drive (for CD installation only)
 At least 16-bit color mode with the KDE or the Gnome desktop recommended

2a. Installing
Martus was written using the Java programming language, and it requires a Java environment to run. The
Martus installer for Windows installs both the Java runtime environment and the Martus application onto
your computer; it can also add a shortcut to the Martus application on your desktop or in the Start menu at
your request. If you are using Mac OS or Linux, you may already have the Java runtime environment
installed; if not, install it before installing Martus.
You can download the Martus program from https://www.martus.org. You can download the installer for
the platform you’re using (if available), or an ISO CD image that contains the program files for Windows,
Mac OS, and Linux. If you download the ISO CD image, you must copy it to a CD before installing
Martus. However you install Martus, you may want to visit https://www.martus.org/downloads to
download any language packs that have been added since the latest Martus release.
Note: As with most applications, you cannot successfully install Martus by copying Martus program files
you have backed up. Use the Martus installer to install the application.
To install Martus for Windows:
1. Insert the Martus CD into your CD-ROM drive or download the Martus installer from
https://www.martus.org and run it. The Martus installer opens.
Note: If the Martus installer does not open automatically when you insert the Martus CD, double-click My
Computer on your desktop, navigate to your CD-ROM drive, and double-click the MartusSetup.exe file.
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2.

Choose a setup language, and click OK.

3.

Click Next in the NSIS Install Wizard dialog box to install Martus.
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4.

Read the license agreement, and then click “I agree” to accept it. If you do not accept the license
agreement, the installer will not install Martus.

5.

If you accept the license agreement, you will see files being copied:
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6.

Decide whether you want to install a Martus shortcut in the Windows Start menu. Click Yes if you do,
and No if you don’t.

7.

Decide whether you want to install a Martus shortcut on the desktop. Click Yes if you do, and No if
you don't.

Note: It’s much easier for most users to run Martus if a shortcut is included in the Windows Start menu or
on the desktop. However, if you want the presence of the Martus software to be less obvious, don’t install a
shortcut in the Windows Start menu or on the desktop. Regardless of your choice, the Martus installer
always adds a Martus shortcut to the Martus directory.
8.

The installer reports its progress as it installs the Martus application and the Java files it requires.
When prompted, click Finish to complete the installation.

Note: Even if you already have Java installed, Martus installs its own Java runtime environment. The
Martus installation will not change existing versions of Java.
See “2c. Upgrading to a new version of Martus (Windows only)” for information about upgrading from an
old version of Martus to the current release.
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To install Martus for Mac OS:
There are two ways to install Martus on a Mac – either automatically by using a DMG file, or manually by
using a ZIP or ISO file. We strongly recommend using the DMG method, because it is much easier, and
it allows Martus to adopt a more standard Mac look and feel.
Note: These instructions may vary depending on which version of Mac OS X you are running. If these
instructions are not applicable to what you see on your computer, please email us at help@martus.org.
Automatic installation using a DMG file (either new or upgrade):
1. Note: Before you install: If an earlier, non-DMG, version of Martus has been installed on this
computer, you must first delete all of the Martus-related jar files from the /Library/Java/Extensions
folder. This is very important, and Martus may not work correctly if you skip this step. You may be
prompted to enter your computer administrator username/password to delete these files. The Martusrelated jars are: - InfiniteMonkey.jar, bc-jce.jar, bcprov-jdk14-135.jar, icu4j_3_2_calendar.jar, js.jar,
junit.jar, layouts.jar, persiancalendar.jar, velocity-1.4-rc1.jar, velocity-dep-1.4-rc1.jar, xmlrpc-1.2b1.jar. After deleting these files, the Extensions folder may be empty. We also recommend that you
delete any shortcuts you may have created to the old Martus version, to avoid confusion.
2. Obtain the Martus DMG file from the Martus website or CD, and double-click it as you would for any
DMG file.
3. If the Martus folder was not automatically opened, double-click on it to view the contents.
4. While you can copy the Martus application (Martus.app) to your Applications folder, please note that
if you do so, it will not be removed when you uninstall Martus, which may be a security concern.
5. The MartusDocumentation folder contains files with helpful information about Martus, including User
Guides, Quick Start Guides, and README files that describe the features in each version, all in
various languages. We also suggest that you copy this folder to your computer where you can have
easy access to it.
Note: If you are using a Martus Language Pack (e.g. Martus-en.mlp), please copy the mlp file to your
Martus data folder. For instructions on how to access your Martus data folder, see the section below
named "Viewing the Martus Data Folder".
Note: If needed, Burmese, Khmer, and Bangla/Bengali fonts are provided in the Fonts folder. If you
need any of these, you can install it by double-clicking on the .ttf file and choosing "Install". If you
have issues running or entering text in Burmese, Khmer, or Bangla/Bengali, please see FAQs 40 - 42
in this Martus User Guide, or email help@martus.org.
To run Martus installed from a DMG file, double-click the Martus icon/application (Martus.app file).
To display additional information as Martus runs that will be helpful in diagnosing any problems in Mac
OSX, you can run the "Console" application. Launch it in one of two ways:
a) Inside your Applications folder, find the Utilities folder, and double-click on Console.
b) Hit Command-Space to bring up the search, enter "console", and when it finds the Console app, launch
it. As long as the console is running, any troubleshooting or logging information from Martus will appear
there. You only have to run console once, and then you can run (and stop) Martus as many times as you
want. You can copy and paste the text from the Console app into an email to help@martus.org.
Note: To see only Martus info in the console and exclude any console info from other programs, type
“.Martus” (without the quotes) in the search box at the top right of the console screen.
Manual installation using a ZIP or ISO file:
1. Insert the Martus CD into your CD-ROM drive (or download the Martus compressed/zip file from
https://www.martus.org) and double-click it.
2. Create a Martus folder inside /Library/Java
3. Copy the Martus files from the zip or CD/ISO into the /Library/Java/Martus folder on your hard disk.
In addition to the program files, this will copy over the user documentation including the README
files that contain a list of changes between versions of Martus.
4. If you copied from CD/ISO, rename the LibExt folder to ThirdParty
5. If desired, create a Martus desktop icon, or alias using the following instructions.
6. Open Finder and select Applications from the left-hand options.
7. Search for the Automator application. Double-click on this application to run it.
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8.
9.

When the dialog opens, select Choose. This will take you to a dialog called Untitled.
On the left-hand side of the dialog, you will see a list called Library, under which should be several
items, such as Calendar, Contacts, etc. Double-click on the one that says Utilities.
10. This will open up the Utilities folder to the right of the Library column. Double-click on the item
called Run Shell Script.
11. This will open up a new sub-window called Run Shell Script - there should be a text box that has one
word, “cat”, in it.
12. Delete “cat” and type the following, with carriage returns (hit Enter) between lines:
cd /Library/Java/Martus
java -Xbootclasspath/p:ThirdParty/bc-jce.jar -jar martus.jar
13. Click the button called Run. This should launch Martus, which will confirm for you that you have done
the Automator step of the process correctly.
14. Before you exit the Automator, go to File > Save As. In the subsequent dialog, name the file Martus.
Under “Where”, select Desktop. Finally, under “File Format”, be sure to select Application. Do not
select Workflow. This will create an icon on your desktop called Martus which you can double-click to
run the program. Please email help@martus.org if you need help with any of these steps.
Note: In Mac OS, the Martus data folder is named .Martus and is located in your Home folder. This folder
contains your Martus account and bulletin info, as well as other files created while using Martus, such as
report/search templates, HQ information .mpi files, etc (though many of these can also be saved to other
folders if desired). The Martus data folder is also where you would place any language pack files. Normally
the Martus data folder is hidden, so is not viewable using the Finder application. In order to access these files,
you will need to set your computer preferences to "show" this hidden folder. To do so, follow these steps:
1. Go to Finder > Applications > Utilities, and open the Terminal application. (You can also hit
Command-Space to bring up the search, enter "terminal", and when it finds the Terminal app, launch
it.)
2. Type
defaults write com.apple.finder AppleShowAllFiles TRUE
and hit Enter/Return.
3. Restart the Finder by holding the Option key, and click and hold the Finder icon. When the context
menu shows, select Relaunch. (Alternately, you can type the following in the Terminal:
killall Finder
and hit Enter.)
4. When the Finder restarts, you will be able to view the ".Martus" folder within your home directory and
access files saved there.
Note: If you receive a warning when trying to run Martus on Mac 10.8 or later, please see section “11.
Frequently Asked Questions” (FAQ) #55 for a possible solution.
To install Martus for Linux:
The following instructions will install Martus within your user account only. No other Linux users on this
machine will have access to Martus. If you want to install Martus publicly, so that any user on this
computer can run it, please see section “11. Frequently Asked Questions” (FAQ) #30.
Most of the following must be done from a terminal command prompt.
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1.

See what version of Java you are currently running by typing:
java -version
Java must be installed and in your PATH for this to work.
You must have (or install) either Oracle’s official Java version 1.6.0 (sometimes called Java6), or
OpenJDK 6 or 7. If possible, we recommend using the standard software installation tools from your
operating system, such as yum/rpm or apt/deb. If you want to run Oracle's JRE but it is not available
that way, you can download it directly from
http://java.com/

Note: To run Martus, you only need to install the current version of Java Runtime Environment (JRE),
not the larger Java Developer’s Kit (JDK).
2.

Choose and create a directory to hold the Martus program files (i.e. a “Martus program directory”).
This may be the same as the Martus data directory (~/.Martus/) or may be different. For example, you
might install the Martus application within your Desktop directory, making it easy to find. Separating
the program from the data may increase security, but will make it harder to entirely erase Martus if you
needed to do so. You would make the directory by typing the following at the prompt in the location
you choose:
mkdir -p <Martus Program Directory>
For example, if you wanted to install the Martus 4.0 into its data directory, you would type:
mkdir -p ~/.Martus

3.

If installing from the CD/ISO:
a. Copy martus.jar from the root directory on the installation CD into the Martus program
directory.
b. Copy the LibExt directory from the CD into Martus program directory, and rename it as
ThirdParty.
c. If desired you can also copy the Documents directory which contains user documentation
including the README files that contain a list of changes between versions of Martus.
d. Change to the directory that contains the actual application, by typing the following:
cd <Martus Program Directory>
For example, if you installed Martus into its data directory, you would type:
cd ~/.Martus

4.

If installing from the zip file:
Change to the directory you created to install Martus into, extract the zip file contents there, and
change to the directory that contains the actual application, by typing the following:
cd <Martus Program Directory>
unzip <Path to Zip File>
cd <Martus Version Directory>
For example, if you wanted to install the Martus 4.0 into its data directory, and the zip file was in
~/Downloads and named MartusClient- 4.0.zip, you would type:
cd ~/.Martus
unzip ~/Downloads/MartusClient- 4.0.zip
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5.

Test the installation by running Martus, by typing:
If using Oracle’s Java:
If using OpenJDK:

java -Xbootclasspath/p:`pwd`/ThirdParty/bc-jce.jar -jar `pwd`/martus.jar
java -jar `pwd`/martus.jar

(You do not have to type out the name of the directory you are in, since `pwd` does that for you. )
6.

You can create a shortcut script as follows:
If using Oracle’s Java: echo java -Xbootclasspath/p:`pwd`/ThirdParty/bc-jce.jar -jar `pwd`/martus.jar >martus
chmod +x martus

If using OpenJDK: echo java -jar martus.jar >martus
chmod +x martus

7.

You can copy this script elsewhere, or you can set up a launcher or shortcut to it, to make it easy to
start Martus.

For additional assistance installing in Linux, please email help@martus.org.
Martus Documentation
When you install Martus, all the language versions of the user guide and quick start guide that are currently
available are installed in your Martus\Docs directory. If you used the Windows installer, links to these
documents are also available by going to Start > Programs > Martus. They are also available at
https://www.martus.org/downloads , and you can visit this site to see whether new language versions are
available.

2b. Uninstalling
To uninstall Martus in Windows without deleting your Martus bulletins or account data, choose Start >
Programs > Martus > Martus Uninstall (if you opted to add short-cuts to your Start menu), double-click the
uninst.exe file in the Martus\bin directory, or use the Add/Remove Programs control panel in Windows:
1. Choose Settings > Control Panel from the Start menu.
2. Double-click the Add/Remove Programs icon.
3. Select Martus from the list of applications.
4. Click Add/Remove, and then follow the on-screen instructions.
If you installed Martus with a DMG file on a Mac, you can uninstall Martus without deleting your Martus
bulletins or account data, by simply deleting the Martus application (Martus.app file).
Note: Please note that if you copied the Martus application (Martus.app) to your Applications folder or
your Desktop (or elsewhere on your computer), it will not be removed when you uninstall Martus, which
may be a security concern.
To uninstall Martus in Linux (or if you installed using a zip or ISO file in Mac OS) without deleting your
Martus bulletins or account data, delete the martus.jar and the ThirdParty directory.
If you want to delete bulletins and your key file, but keep the Martus application, choose Tools > Delete
My Data. For more information, see “7. Deleting Your Bulletins and Account Information.”
If you need to remove Martus bulletins and configuration data, as well as the Martus application, choose
Tools > Delete All Data and Remove Martus. This feature removes information for all accounts on the
computer, not just yours, and should only be used in emergency situations. For more information, see
“8. Deleting All Martus Data, Including the Application.”
When you remove Martus files using the Delete All Data and Remove Martus command, Martus deletes
the files in a way that makes them more difficult to recover than just deleting the files manually. However,
to verify that all Martus information has been removed, search for the Martus folder (C:\Martus in
Windows) and any folders and files you copied during installation (Mac OS or Linux). If any of these
folders or files remain, delete them, and then empty the trash or recycling bin.
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Note: Deleted user data can still be recovered by technicians who gain access to the computer’s hard drive;
however Martus deletes it in a way that makes it harder to recover. Additionally, because all bulletin data is
encrypted, it is secure as long as your password is strong and remains secret. There are disk utilities
available that will completely erase user data in ways that prevent the recovery of any information.

2c. Upgrading to a new version of Martus (Windows only)
Benetech continues to improve the Martus application, and Martus upgrades are periodically available from
the Martus web site at https://www.martus.org.
To upgrade the Martus software for Windows, do the following:
1. Download the new version (either upgrade or regular full release files) or obtain an installation CD.
2. Run the setup program: double-click the file you downloaded or insert the CD into your disc drive. The
installer notifies you that you have an older version of Martus installed.
3. Click Yes to upgrade. The new version of Martus is installed into the same directories as the older
version. All data files, including account information, passwords, and bulletins, remain intact.
Note: Martus version 4.0 for Windows must be installed with a full release instead of the upgrade install
without Java, because it requires a new version of Java than earlier releases of Martus.
To upgrade to a new version of Martus on the Macintosh or Linux platforms, follow the installation
instructions in “2a. Installing” to replace the existing Martus program with the new release.

2d. Updating the Martus program file
Benetech continues to improve the Martus application. Check https://www.martus.org for the latest version,
and follow the instructions on the web site to validate the downloaded software using the SHA-1 sum
program.
Most updates to Martus are done in the form of the installers described in section “2a. Installing”. While it
is not standard procedure, in the future, Benetech may choose to distribute just an updated version of the
martus.jar file. You should not trust the authenticity of any martus.jar file that is separately delivered to
you, until you have verified it using the procedure that follows. Do not trust any alternative verification
procedures provided to you by other means.
Use only the verification program found on an authentic Martus CD, and use the instructions in the
readme_verify.txt files found on the cd.

2e. Setting up your account
Before you can use Martus, you need to create an account for yourself and set up your contact information.
Multiple accounts can exist on a single computer. The first user's account is in the Martus directory;
additional accounts are in subdirectories in the Martus directory.
When you set up your account, you create a username and password. Use a password you can remember. If
you forget your username or password, you may not be able to access to any of your bulletins in Martus.
Additionally, take precautions to keep your password secret. Your password provides access to all of the
bulletins you create in Martus, and allows you to create new bulletins. Never send your password through
e-mail, or tell it to anyone over the phone, as these communication methods may not be secure.
1.

Start Martus. Click OK in the Martus Welcome dialog box. The Martus Sign-in dialog box opens.
 To start Martus in Windows, choose Start > Programs > Martus > Martus, or double-click the
Martus shortcut on the desktop or in the Martus directory, or choose Start > Run and then type the
following text:
C:\Martus\bin\javaw.exe -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar
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To start Martus in Mac OS,
 If you installed with a DMG (recommended), double-click the Martus application icon
(Martus.app file) from where you copied it (see Mac portion of section “2a. Installing”)
 If you installed from an ISO or zip file, open a Terminal window, go (cd) to the
/Library/Java/Martus folder and type:
Java -Xbootclasspath/p:ThirdParty/bc-jce.jar -jar martus.jar
To start Martus in Linux, run a script you’ve created or type:
java -Xbootclasspath/p:<Martus program directory>/ThirdParty/bc-jce.jar -jar <Martus program
directory>/martus.jar
See Linux portion of section “2a. Installing” for examples.

2.

3.
4.

5.

If other accounts already exist on your computer, click the New Account tab in the Signin dialog box,
and then click OK. If there are no existing accounts, Martus will prompt you to either create a new
account or restore an account from backup key files.
Choose a language from the dropdown menu in the Signin dialog box.
Type a username; it can contain letters, numbers, punctuation, and spaces. We recommend that you
create a username that has between 8 and 50 characters, and recommend against entering non-ascii
characters using the Alt + NumberPad method. Choose a username that will be easy for you to
remember, and remember how you capitalize it, as Martus usernames are case-sensitive.
Click characters on the on-screen keyboard to type a password that has between 8 and 50 characters.
(There is no cursor in the Password field, and you do not have to click in it.) Choose a password that
you can remember, but that would be difficult for someone else to guess. Use a combination of letters,
numbers, and punctuation to make the password more secure; Martus passwords are case-sensitive.
See “2f. Choosing a password” for guidelines for creating a secure, useful password. If you forget
your username or password, there is no way for you to access the bulletins you have created or
any of the data on your computer unless you have performed a multi-file key backup (or have a
Headquarters account that can retrieve your bulletins.) See “9b. Backing up your key” for more
information.

Note: If you prefer to type your password using the computer’s keyboard, click Switch To Using
Regular Keyboard. Your password may be less secure if you type it with the computer’s keyboard than
if you use the on-screen keyboard, as an unauthorized person could install a device or program that
could “sniff” your keyboard to record your keystrokes. If using the keyboard, we recommend against
entering non-ascii characters using the Alt + NumberPad method.
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6.
7.
8.

Click OK. The sign-in screen appears a second time.
Enter the same username and password to verify them, and then click OK.
If you want to provide contact information, enter it now. (It may take a few seconds for the Martus
Setup Contact Information dialog box to appear.) If you do not enter anything for Author or
Organization, Martus will prompt you for the information every time you start the application.

The Author and Organization information appear automatically in every bulletin you create, though
you can edit them if desired. Public bulletin data (that is, data that has not specifically been labeled
private) may be available to researchers, the press, and the public through the Martus Search Engine.
This contact information provides a way for someone to follow up with you or your organization for
more information about your bulletins. (If you do not want to make your bulletin data available
publicly, you can choose to make all of your data private.)
For Author, enter your name or your organization’s name as the source of the information in the
bulletins you submit. Type your organization’s name, and the e-mail address, Web page address,
phone number, and mailing address people should use to contact you or your organization. Any
contact information you enter may become public, if you choose to send it to a server. All the fields are
optional, or you may use a pseudonym or provide only your organization’s information if you do not
want your name to be publicly available. Click OK.
Martus prompts you to send the contact information to the Martus server. Contact information sent to
the server will be available to anyone with server administrative access (e.g. in case they need to
contact users about server maintenance), and contact information for public bulletins sent to a Martus
server is also published on the Martus Search Engine, which is publicly accessible. If you want to send
your contact information to the Martus server, where it will be available to anyone with server
administrative access or who has access to the Martus Search Engine, click Yes. If you want to keep
your contact information confidential, click No.
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If you leave Author and Organization blank, the Contact Information dialog box will appear each time
you start Martus. If you need to change the contact information later, choose Options > Contact
Information.
Note: When you close Martus after creating an account, you'll be prompted to back up your key file. If
your computer malfunctions or is stolen, you'll need your key file to access your private bulletin data
from Martus Servers on another computer. Martus will prompt you to back up your key file every time
you start the application until you do so. For more information, see "9b. Backing up your key."

2f. Choosing a password
To keep your data secure, you need to use a password that cannot be easily discovered or guessed. Use the
following guidelines to develop a password that you can use confidently, and that you can remember. You
are the only one who knows your password; if you forget your password, you may not be able to access
your Martus data (unless you have done a multi-file backup of your account information, see "9b. Backing
up your key", or have a Headquarters account that can retrieve your bulletins.)












Do not use your username.
Do not use a single dictionary word.
We recommend that you use at least 15 characters.
Use a combination of alphabet characters, numbers, and special characters (such as !@#$%^&*).
Use a combination of uppercase (capital) and lowercase characters if you use a case-sensitive
language.
If you must write down your password, keep it in a secure location separate from your Martus
installation.
Create a reminder statement for yourself, and keep it somewhere secure. (Remember that if your
reminder statement jogs your memory, it could also provide a clue to someone attempting to discover
your password.)
Use a password that can be remembered (use characters that are meaningful to you).
Develop a simple method for choosing new passwords.
Change your password if you feel that your account has been compromised. See “9h. Changing your
user name or password” for information.
If you forget your username or password, there is no way for you to access the bulletins you have
created or any of the data on your computer unless you have performed a multi-file key backup (or
have a Headquarters account that can retrieve your bulletins.)

2g. Setting up a server connection
To ensure you’ll have access to your bulletins in case of computer loss or theft, send them to a Martus
backup server. A Martus server is a computer server that accepts encrypted bulletins, securely backs them
up, and replicates them to multiple locations, safeguarding the information from loss. Martus servers are
operated by non-profit organizations (Benetech does not operate Martus servers directly). If your
organization does not have a relationship with an organization that hosts a Martus server, visit
https://www.martus.org to see the list of server hosts.
Sending bulletins to a server also lets you share them with others to whom you have given access, such as
your organization’s Headquarters. The press and other members of the public may have access to your
public bulletins through the Martus Search Engine.
If you’re connected to a server, Martus automatically backs up draft bulletins to the server when you save
them. However, draft bulletins are treated as private data, and are only available to you and your
Headquarters, if you’ve given permission to users of a Headquarters (HQ) account.
When you complete a bulletin and save it to the server, it is sealed, so that it can never be edited again
(though you can create a new version of the bulletin if you need to update any information). The public
data in the bulletin is available to anyone who has access to the server; private data is available only to you
and your Headquarters, if you’ve given permission to users of a Headquarters account.
Before you can send bulletins to or retrieve them from a server, you need to identify the server in Martus.
You’ll need to know the server’s IP address, the server’s public identification code, and the magic word.
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Usually, you’ll receive this information directly from Benetech (email info@martus.org), or from the
organization that operates the server.
To configure the server:
1. Choose Server > Select Martus Server.
2. Enter your username and password when prompted.
3. Enter the IP address for the server.
4. Enter the server’s public identification code, and click OK.

5.

A server compliance message appears. Click Accept if the server compliance statement meets your
needs. If the server doesn’t meet your needs, click Reject and then select a different server.

Note: Server compliance guidelines are available at https://www.martus.org/, in the “Download Martus
Server” section. Compliant servers are expected to be secure; servers that deviate from the server
compliance guidelines may be less secure. If you have questions about whether a server meets your needs,
ask the person who determines policies for using Martus in your organization—or send a message to
info@martus.org.
6.

If prompted, type the magic word to gain permission to send bulletins to the server, and then click OK.
You will not be prompted for the magic word if you are using an account that has accessed this server
before.

Note: The magic word is not case-sensitive, and ignores spaces. So if you were given “Magic word” to
use, you could also type “magic word” or “MagicWord”.
7.

Click OK in the dialog box that confirms your connection to the server.

Martus stores the server information, so you don’t need to enter it again unless you reinstall the application
(e.g., on a different computer), or need to configure Martus to send bulletins to a different server.
To change the server settings, choose Server > Select Martus Server, and then enter the information for the
new server. To remove your connection to a Martus server without connecting to a different server, choose
Server > Remove Martus Server.
Note: Once you’ve selected a server, Martus will attempt to access the server each time you run the
software. The server may return news about the status of your account or other important information.

2h. Setting your preferences
You can customize Martus for your preferred language and date format. You can also ensure that every
bulletin you create remains private.
To change the language used in the Martus user interface, choose Options > Preferences. Then choose a
language from the drop-down menu and click OK. Martus has been translated into several languages. Visit
https://www.martus.org to see if there is a newer version of Martus available with additional languages, or
for information about translating the user interface into a different language. Additionally, a language pack
may be available on the Martus website (at https://www.martus.org/downloads); a language pack can
contain updated versions of the Martus Client user interface translation, the User Guide, the Quick Start
Guide, the Readme file, and in-program help in a particular language.
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To change the date format used in lists of bulletins and in bulletins you create, choose Options >
Preferences. Then choose the format you prefer from the Date Format dropdown menu and click OK.
To change the calendar type, choose Options > Preferences. Then choose the calendar type you prefer (e.g.,
Gregorian, Thai or Afghan/Persian) from the Calendar Type dropdown menu and click OK. If you had
entered bulletins before this option was available, Martus can also automatically convert dates in those old
bulletins to display in Thai or Afghan/Persian date format using the respective checkboxes in the
Preferences screen.
If you are running Martus in a language other than Burmese and want to type or view Burmese data in your
bulletin fields, choose Options > Preferences, and check “Use Zawgyi font for Burmese display and input”.
If you are running Martus in Burmese, it assumes you will be entering bulletin data/text using the Zawgyi
font, and the “Use Zawgyi font for Burmese display and input” option should automatically be checked (if
you uncheck it, the user interface will not display correctly in Burmese). For more on display of Burmese,
please see section “11. Frequently Asked Questions” (FAQ) # 40.
If you never want to make bulletin data public, choose Options > Preferences. Then, check Prevent
Creating Public Bulletins, and click OK. Until you uncheck this option, every bulletin you create in Martus
is private, and you will not be able to uncheck the Keep ALL Information Private option in new bulletins.
If you are a Headquarters account and want to be notified if there are field bulletins to retrieve, go to
Options > Preferences, and select "Automatically check for new Field Desk bulletins." Approximately
hourly, a message will appear in the status bar (lower left corner of the screen) saying that Martus is
checking for new field desk bulletins. The status bar will display another message if there are field
bulletins to be retrieved, at which point you can go to the Server menu to load the Retrieve screen (see “6i.
Retrieving bulletins created by field desks.”) Please note that selecting this option can cause slower server
performance, especially if you have a slow internet connection, so it should only be selected if your field
desk accounts are actively creating bulletins.
To run Martus using Tor, which can improve security of your Martus data when it is being sent to the
servers, go to Options > Preferences, and select "Use embedded Tor". For more information about Tor, go
to https://www.torproject.org/ or see “11. Frequently Asked Questions” (FAQ) #53.
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Please see the section “11. Frequently Asked Questions” (FAQ) for other settings for running Martus (e.g.
the number of minutes before Martus times out for security) that are not available in the Preferences screen.
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3. The Martus Workspace
When you’ve logged in, the Martus workspace opens. It displays the folders and bulletins stored on your
computer, and previews the selected bulletin.

On the left, Martus lists folders in which bulletins are organized. By default, there are two folders, but
additional folders are created when you perform certain tasks, and you can create your own folders, as well.
A single computer may have multiple Martus accounts. When Martus has been inactive for a period of
time, it requires you to log in again for security purposes.
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4. Creating a Bulletin
To create a new bulletin, click Create or choose File > Create New Bulletin. The Create Bulletin dialog box
opens. Enter information in the bulletin fields.
Click the Bulletin Details button to see the Bulletin ID (a unique ID number used by Martus, and by
technical support and server administrators), the bulletin's version history, as well as the author's Public
Code and the Public Codes of any Headquarters accounts given access to this bulletin.

4a. Completing fields in a bulletin
You can type data directly into the fields, or you can copy and paste information from existing bulletins or
other documents into the fields. To copy and paste, use the standard operating system keyboard shortcuts:
Ctrl+C to copy in Windows or Linux, Command+C to copy in Mac OS; Ctrl+V to paste in Windows or
Linux, and Command+V to paste in Mac OS. The Command key in Mac OS is sometimes also referred to
as the Apple key. Or you can right-click the field in Windows or Linux, or Ctrl-click it in Mac OS, and
then choose Copy or Paste from the context menu.

Bulletin Details - See “6j. Viewing earlier versions of a bulletin” for information about viewing the
bulletin’s version history.
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Keep ALL Information Private - Check this option to make the entire bulletin private.
Note: If you want to ensure that every bulletin you create remains private, choose Options > Preferences,
and check Prevent Creating Public Bulletins. When this option is checked, the Keep ALL Information
Private option cannot be unchecked in new bulletins.
Uncheck the Keep ALL Information Private option to make most of the information public (information in
the Private section remains private regardless). When the entire bulletin is private, the padlock icon is
closed and the words “Private Information” appear; when the bulletin is public, the padlock icon is open
and the words “Public Information” appear. Private areas have a red border. If you wish the information in
this bulletin to be publicly accessible through the Martus Search Engine, you should not check this option.
Checking this option affects only the information in this bulletin; if you have sent your contact information
to the server with another bulletin, your contact information may still be publicly available through the
Martus Search Engine.
Note: Once you save a sealed bulletin to the server, any public information in the bulletin may be made
available to anyone who requests it in the future, including researchers or the press.
Language - Choose the language you’re using to describe the event. If you are using a language that isn’t
included in the list, choose Other.
Note: You can type your bulletin in any language, regardless of the language selected for the user interface.
The user interface language determines which language is used for dialog boxes, menus, and messages in
the Martus software; the bulletin language is the language used to communicate the bulletin’s contents.
Note: If you would like to use a shorter list of languages specific to your project, you can create a custom
field drop-down list to do so. See “10b. Customizing bulletin fields” for more information.
Author - The Author name from your contact information appears here, but you can change it.
Organization – The Organization name from your contact information appears here, but you can change it.
Title - Type a title for the bulletin. The title should make it easy for people browsing the list of bulletins to
identify the nature of the event, but it should be short enough to fit on a single line.
Location - Type the location of the event. Depending on the scope of the event, you may enter a country,
region, city, or other location. If it doesn’t make sense to enter a location, leave the field blank.
Keywords - Type words that are synonyms for acts you described in the bulletin, other related words, and
alternative location names, if appropriate. This is especially helpful for searching.
Date of Event - Enter the date of the event you’re reporting. By default, Martus displays the year as
“Unknown.” You can leave the date unknown if you are uncertain when the event occurred. If the event
occurred over a period of time, or if you don't know the exact day the event occurred, click Date Range,
and then enter the earliest and latest dates for the event. You can choose any year up to the current year,
which Martus reads from your operating system.

Date Created - Verify that this is set to the current date. Martus reads the current date from the computer’s
operating system. If your operating system is set to the wrong date, the Date Created field is also incorrect.
You cannot edit this field.
Summary - Type a summary of the event.
Details - Type any additional details related to the event.
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Attachments - To attach a photo or other file to the bulletin, click Add Attachment, and then select the file
you want to attach; or drag the file from a folder on your computer into the Attachments field. Attachments
added in the Public Information section of the bulletin will be available to anyone who has access to public
data on the server. (Bulletins with large attachments will take longer to save as a draft, send to the server,
retrieve from the server, or move to or from the desktop.) To view an attachment, someone reading the
bulletin must have software installed that supports the format of the attachment file.

Tip: If you want to attach a file that will only be seen by those who have access to private information,
click Add Attachment in the Private Information area or drag a file into the Attachments field in the Private
Information area.
Note: You can use the “View” button to display the attachment. If the attachment is an image (e.g. photo
or scanned document) of certain file types (i.e. jpg, png, gif), the image will be displayed inline inside the
bulletin (see image below). Other types of files will be loaded outside of Martus into whatever program
you have set on your computer to load that type of file.
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Private - Type any additional information that you want to include in the report, but which should never be
public. Data in the Private section of the bulletin remains private, even if the bulletin itself is public. Private
areas have a red border. To attach a file that will only be seen by those who have access to private
information, click Add Attachment in the Private Information area, or drag a file into the Attachments field
in the Private Information area.

Note: In Linux, you may not be able to drag attachment files into Martus.
Headquarters – Select any Headquarters account(s) that will be able to access this bulletin’s private (and
public) information. For more information on configuring Headquarters accounts, see section “9f. Sharing
your private data with colleagues.”

4b. Customizing your bulletins
There are several ways you can customize your bulletins in Martus.
If you often use similar types of information in the Details section of all your bulletins, you can create a
template to save the time you spend entering or formatting the data each time. See “10a. Using a template
in the Details field” for more information on this feature.
Most Martus users find that the standard bulletin fields meet their needs. However, if you need to create
fields beyond the standard Martus fields, you can also create custom fields of various types. If you have
certain types of data that you want to enter in every bulletin, this allows you to structure your data
differently than including it in the standard Summary or Details text fields. See “10b. Customizing bulletin
fields” and “10c. Using Customization Templates” for more information on this feature.
If you’d like to customize how bulletins are displayed in Martus (either while editing or in preview mode),
there are various options (e.g. hiding/un-hiding long fields) that are described further in section “
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10d. Customizing your bulletin display.”
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4c. Checking the spelling of text in your bulletins
Martus will automatically check the spelling of words in text fields while you are editing/entering data in
bulletins, and you can see which words are spelled incorrectly by the red lines underneath them. If you
right-click on the misspelled word, the spell-check menu window will appear and display suggestions for
correctly spelled words that may have been intended instead of the current spelling. The spell-check menu
window also has the option to “Add to User Dictionary” (we suggest you do this for any valid projectspecific words that are likely to show up in many bulletins, for example names of locations or
organizations). Each Martus account has a dictionary on their computer that they can update as they use
Martus.

Notes:
1. The spell-checker will ignore words that are all capital letters or contain numbers.
2. In this version, the spell-checker does not check any fields outside of bulletins (e.g. contact info, HQ
labels, folder names).
3. The spell-checker only displays mis-spellings in bulletin fields when in Edit mode (they are not
displayed in View mode).
4. In this version, for words that are mis-spelled inside of Grid text fields, you have to left-click on the
cell first (as if you were editing it) before right-clicking to bring up the menu to see suggestions or add
to the user dictionary.
5. In this version, spell-checking is only available for English (determined by the standard language field
set for your bulletin).
You can also view, and add words to, the spell-check dictionary under the Options > Spell Checking menu.
If you unintentionally added words to the dictionary (when checking spelling in bulletins) that you want to
remove, you can do so here.

Note: When you hit OK, the words will be saved in alphabetical order.
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5. Saving and Modifying Bulletins
When you create a bulletin, you can seal it or save a draft. Once you’ve saved a sealed document to the
Martus server the only way to modify it is to create a new version of the bulletin. Martus automatically
saves backup copies of draft bulletins to the Martus server, but you can continue to modify a draft bulletin
until you save it as a sealed document. In general, drafts are less secure than sealed bulletins because
unlike sealed bulletins, they can be deleted from the server. Additionally, if someone gains access to your
account, they can remove or change previously entered bulletin text.

5a. Saving a sealed bulletin
If the bulletin is complete and you do not want to edit it further at this time, save the sealed bulletin. Once
you’ve clicked Save Sealed, the bulletin is sealed and no one – neither you nor anyone who gains access to
your account—can make any changes to it. The only way to modify the information in a sealed bulletin is
to create a new version of the bulletin. If you are connected to the Internet and have configured a server,
Martus automatically sends the sealed bulletin to it. The Confirm Save Bulletin dialog box appears,
warning you that the bulletin will be permanently sealed. Click Yes to save the bulletin.
Note: If you save a sealed bulletin with public data, and have sent your contact information to the Martus
server, your contact information will also be published on the Martus Search Engine, which is publicly
accessible. For more on this see section “2e. Setting up your account.”
The bulletin appears in the Saved Bulletins folder with the status of Sealed. When it has been successfully
sent to the server, the word "Yes" appears in the Sent column.
Note: When you connect to a server, there may be a delay before the Sent column is populated.
If you do not have an Internet connection, or if your computer cannot connect to your designated server, the
bulletin remains unsent, and the Sent column will display No until you connect to a server. If you have not
yet configured a server, the Sent column will be blank. As soon as you connect to the Internet, and a valid
Martus server is configured, Martus sends all waiting bulletins to the server. If there are bulletins waiting to
be sent when you end a session in Martus, Martus will alert you to their status and remind you that they
have not been sent to a server.
See “9g. Enabling other accounts to send your bulletins to a server” for information on options if you do
not have an internet connection.
Note: When you view a bulletin authored by someone else, the Sent column will be blank, unless you are a
Headquarters account who has retrieved a Field Office bulletin from the server.

5b. Saving a draft
Save a draft of the bulletin if you want to continue to add information to it in the short term, or need to
verify information before sealing it.
To save a draft of the bulletin, click Save Draft. The bulletin moves to your Saved Bulletins folder with the
status of Draft. To modify the bulletin later, open the Saved Bulletins folder and double-click the bulletin
you want to revise. There is no way to restore older drafts of a bulletin; when you save a modified draft
bulletin, it replaces the original.
Martus sends a copy of each saved draft bulletin to the server, to act as a backup copy in case the draft
bulletin on your computer becomes damaged or is deleted. (If you do not have an internet connection, see
section “9g. Enabling other accounts to send your bulletins to a server.”) When you make changes to the
draft bulletin later, and then save it, Martus deletes the earlier draft from the server and replaces it with the
current draft. Draft bulletins are always treated as private information, whether the information is marked
private or not.
If you have set up your account on multiple computers, you can’t access your drafts from a different
computer unless they were saved to the server; and if you overwrite a draft on the server from one
computer, the draft on the server will not match the draft on the other computer because the server saves
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the latest draft. To update an older draft with a newer draft from the server, you must delete the draft from
the computer and retrieve it from the server. If you want to keep a backup copy of the older draft, you can
drag the bulletin to your desktop before deleting it.
If you decide not to complete a bulletin, so it has never been sealed, you can delete the draft bulletin from
the server. First, delete the draft bulletin from your computer, and then choose Server > Delete My Drafts
From Server. Check the draft bulletin you want to delete and click Delete. (You must delete the copy on
your computer first, as you cannot delete bulletins from the server that remain on your computer.)
Note: For security reasons, we recommend that all users save their bulletins as Sealed instead of Draft,
unless you are going to add new data within a few hours of saving it. Draft bulletins can be deleted from
the server either unintentionally or maliciously (if someone gets your username and password and account
key file), and data on your computer can be removed or changed in a Draft bulletin. However if you save
your bulletins as Sealed, nobody (including yourself, or someone who got your username/password/key)
can delete them from the server, and while new versions of a bulletin can be created, the old versions can
never be changed or deleted from the server.

5c. Creating a new version of a sealed bulletin
Once you’ve sealed a bulletin, no one can make changes to it. However, you can modify a copy of the
bulletin to provide corrections or additional information, and then save that modified copy as a later version
to the server. The original sealed bulletin remains unchanged on the server; neither you nor anyone else can
delete it. New versions of each bulletin are connected, so creating a new version of a bulletin saves a new
copy but does not change the total number of bulletins (e.g., in searches).
To create a new version of a sealed bulletin, select the bulletin you want to modify and either click Modify
or choose Edit > Modify Bulletin. Click Yes to confirm that you want to create a new version of the sealed
bulletin. When you’ve made the changes you want to make, click Save Sealed, or click Save Draft if you
want to make further changes before sealing it.
Though you may have a bulletin copied into several different Martus folders, each listing is a reference to a
single file. Therefore, when you create a new version of the bulletin, that change is reflected for the bulletin
in every Martus folder on your computer. Likewise, the new version is uploaded if you are connected to the
server; all previous versions remain on the server.
Tip: Consider changing the title of the modified version of the bulletin in a way that makes it clear that it
contains corrected or additional information. For example, if the original sealed bulletin is titled “Political
leaders jailed,” you might title the modified version “Political leaders jailed – updated.”

5d. Modifying a draft
You can make changes to draft bulletins until you seal them. To modify a draft bulletin, double-click the
bulletin, and then make changes or add information. (You can also select the bulletin’s title and then click
Modify or choose Edit > Modify Bulletin.) You can save the modified bulletin as a draft again or save it as
a sealed bulletin. If you click Cancel, new information will be lost and the bulletin will revert to the way it
appeared when you last saved it. Each time you save a draft bulletin, Martus updates the backup copy of the
draft bulletin on the server. When you save the final draft bulletin to the server, Martus deletes the backup
copy of the draft bulletin from the server.
If you have set up your account on multiple computers, you can’t access your drafts from a different
computer unless they were saved to the server; and if you overwrite a draft on the server from one
computer, the version on the server will not match the version on the other computer because the server
saves the last version of the draft. To update an older version of a draft with a newer version from the
server, you must delete the draft from the computer and retrieve it from the server. If you want to keep a
backup copy of the original draft, you can drag the bulletin to your desktop before deleting it.

5e. Discarding a draft
To discard the information you’ve entered, click Cancel. Martus alerts you that you’ll be deleting any
unsaved information in the bulletin, which has not been sent yet. Click Yes to discard the unsaved
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information permanently. (If you click Cancel when you’re modifying a draft bulletin, the bulletin will
revert to the state it was in when you opened it.)
To delete draft bulletins from the server, first delete them on your computer. Then, choose Server > Delete
My Drafts From Server. Check the draft bulletins you want to delete from the server and then click Delete.
(You cannot delete draft bulletins from the server if they remain on your computer.)
If you have set up your account on multiple computers, and delete a draft from one computer and from the
server, it will still be on the other computer. On that other computer, if you modify the draft, it will re-send
it to the server, but if you never modify the draft, it will never get re-sent.
For more information, see "6d. Discarding and deleting bulletins."

5f. Discarding a sealed bulletin
You can discard a bulletin from a folder, which moves it to the Discarded Bulletins folder. To permanently
delete a bulletin from the hard drive, delete it from the Discarded Bulletins folder. If a sealed bulletin has
been sent to the server, you can retrieve it again.
To remove a bulletin from a folder, select it and choose Edit > Discard Bulletin(s). The bulletin appears in
the Discarded Bulletins folder. To delete a bulletin from your hard drive, select it in the Discarded Bulletins
folder and choose Edit > Delete Bulletin(s). For more information, see "6d. Discarding and deleting
bulletins."

5g. Sealing a group of draft bulletins at once
You can seal a group of draft bulletins at once, instead of having to do so one-by-one. You can do this
“bulk” or “batch” sealing of multiple drafts by selecting the desired bulletins and going to Edit > Seal
bulletin(s). As stated in section “5b. Saving a draft”, we recommend that users that have a large number of
drafts seal those draft bulletins for increased security.
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6. Managing Bulletins
Folders help you manage the bulletins you’ve created or retrieved from the server. Martus includes two
default folders and automatically creates others for specific purposes; you can create additional folders to
organize bulletins further. When you select a folder, its contents are listed to the right. For each bulletin,
Martus lists the bulletin's status, whether it was sent to the server, the date of event, the bulletin title, the
bulletin's author, and when it was last saved. Martus displays the selected bulletin.
Note: The Sent field is blank for bulletins authored by someone else, or if you are not connected to a
server.
To view the Bulletin ID, the bulletin's version history, and the author's Public Code, click the Bulletin
Details button.

6a. Default folders
Martus automatically includes two permanent folders: Saved Bulletins and Discarded Bulletins.
These default folders are different from some earlier versions of Martus. If you upgrade from a version
earlier than Martus 2.0, your old folders will automatically be migrated to this new folder structure, so your
bulletins will not be lost.
Saved Bulletins
The Saved Bulletins folder contains all bulletins that you have saved, whether they are sealed bulletins or
draft bulletins, and whether they have been sent to the server or not. The status of each bulletin is listed
next to it, as well as whether it has been sent to the server, and when it was last saved. You can modify
draft bulletins, and you can create new versions of sealed bulletins.
If you are working offline when you click Save Sealed or Save Draft, Martus cannot send the bulletin to the
server until you have an Internet connection. Additionally, a bulletin that includes one or more attachments
may not have Yes in the Sent column for several minutes or possibly as long as an hour while Martus sends
it to the server, especially if you have a slow Internet connection. If there are unsent bulletins when you exit
the application, Martus will remind you that you have bulletins that have not been sent.
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Discarded Bulletins
When you discard a bulletin from another folder, it moves to the Discarded Bulletins folder. You can still
work with the bulletin when it is in the Discarded Bulletins folder; if it has Draft status, you can modify it;
if it has Sealed status, you can create a new version that will be saved to the Saved Bulletins folder. To
completely remove a discarded bulletin from your computer, select its title in the Discarded Bulletins folder
and choose Edit > Delete Bulletin(s). Or, you can right-click (Windows) or Ctrl-click (Mac OS) its title in
the Discarded Bulletins folder and choose Delete Bulletin(s). This removes all information about the
bulletin from your computer, but it remains on the server (if it was sent to a server before the deletion). If
the bulletin has Draft status, you can delete it from the server by choosing Server > Delete My Drafts From
Server; if it has Sealed status, you cannot remove it from the server.
Until you delete a bulletin from the Discarded Bulletins folder, you can move the bulletin back into any
other folder. However, once you delete a bulletin from the Discarded Bulletins folder, you cannot retrieve it
unless it is stored on the server.

6b. Other folders created by Martus
Martus creates the Search Results, Retrieved Bulletins, Retrieved Draft Bulletins, Field Desk Bulletins,
Field Desk Draft Bulletins, Recovered Bulletins, and Damaged Bulletins folders as needed. You can
rename or delete each of these folders.
Search Results
When you search the bulletins on your computer, Martus displays the results in the Search Results folder.
The contents of this folder are overwritten the next time you search. If you want to save your search results,
rename this folder; Martus will create a new Search Results folder the next time you search. To rename the
Search Results folder, right-click the folder and choose Rename Search Results folder. Alternatively, you
can select the folder, and then choose Folders > Rename Folder or click the folder name, and type in the
desired new folder name. You cannot use punctuation in a folder name, but you can include spaces.
Retrieved Bulletins
This folder contains sealed bulletins you’ve retrieved from the server. These bulletins are included in
searches and you can copy or move them into different folders. Bulletins in this folder are sealed, so you
cannot modify them, except by creating a new version of the bulletin.
Retrieved Draft Bulletins
This folder contains draft bulletins you’ve retrieved from the server. These bulletins are included in
searches and you can copy or move them into different folders. Bulletins in this folder remain in Draft
status, so their data is treated as private and you can modify them.
Field Desk Bulletins
Headquarters account users can download bulletins that their field desks have sent to a server. The Field
Desk Bulletins folder contains any sealed field desk bulletins that you've retrieved from the server. These
bulletins are included in searches and you can copy or move them into different folders. Bulletins in this
folder are sealed, so you cannot modify them. You can create a new copy of a field desk bulletin, but the
original remains unchanged and retains the field desk as its author.
Field Desk Draft Bulletins
The Field Desk Draft Bulletins folder contains any draft field desk bulletins that you've retrieved from the
server. These bulletins are included in searches and you can copy or move them into different folders.
Bulletins in this folder remain in Draft status, so their data is treated as private. You can create a new copy
of a field desk bulletin, but the original remains unchanged and retains the field desk as its author.
Recovered Bulletins
Under normal circumstances, all bulletins are associated with folders, but power failures, hardware failures,
or obscure software issues might cause bulletins to lose their association with a folder. When you start
Martus, it checks for such bulletins. If Martus finds any, it alerts you and then creates a Recovered
Bulletins folder for them. You can leave the bulletins there, move them into a different folder, or discard
them.
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Damaged Bulletins
If data in a bulletin is garbled or missing, Martus creates a Damaged Bulletins folder and places the bulletin
in it. You may still be able to read some of the information in a damaged bulletin.

6c. Creating folders
Create additional folders to categorize bulletins according to your interests or current projects. You can
rename the Search Results folder to save your search results for later use; Martus will create a new Search
Results folder the next time you search.
Note: You cannot use punctuation in a folder name, but you can include spaces. You can also use
characters from non-Latin alphabets, such as Thai or Russian.
To create an empty folder, choose Folders > Create New Folder, or right-click in the folders area and
choose Create New Folder. Then, type a name for the folder.
To rename a user-created folder, right-click on the folder and choose Rename Folder. Alternatively, you
can select the folder, and then choose Folders > Rename Folder or click on the folder name, and type in the
desired new folder name. You can’t rename system folders such as Saved Bulletins or Discarded Bulletins.
Note: To change the order of the folders on the screen, choose Folders > Organize Folders, then move
folders up or down to their desired positions.

6d. Discarding and deleting bulletins
You can discard a bulletin from a folder, which moves it to the Discarded Bulletins folder. To permanently
delete all versions of a bulletin from the hard drive, delete the bulletin from the Discarded Bulletins folder.
If a sealed bulletin has been sent to the server, or a draft bulletin has been backed up to the server, you can
retrieve it again. (Martus automatically backs up bulletins to the server when you save them, provided you
have an active Internet connection.)
To remove a bulletin from a folder, select it and choose Edit > Discard Bulletin(s). The bulletin appears in
the Discarded Bulletins folder. (You can also drag the bulletin to the Discarded Bulletins folder, or rightclick the bulletin and choose Discard Bulletin(s).)
To delete a bulletin from your hard drive, select it in the Discarded Bulletins folder and choose Edit >
Delete Bulletin(s), or right-click it and then choose Delete Bulletin(s). Martus will alert you that you are
permanently deleting the bulletin from your computer, and inform you if a copy of that bulletin exists in
any other folder. Click Yes to delete the bulletin.
Note: If the bulletin is also listed in another folder, it will remain on your hard drive, even when you delete
it from the Discarded Bulletins folder. To remove all copies of a bulletin from your computer, you must
move each of them to the Discarded Bulletins folder and then delete them.

Martus 4.3 User Guide

36

You do not need to do anything further to ensure that deleted bulletins are removed from your hard drive.
Unlike most computer data, Martus bulletins are encrypted files on your hard drive—including sealed
bulletins with public data, bulletins created by other people, and deleted bulletins. Therefore, unless
someone gains access to your Martus account, they cannot read the bulletins you store in your folders or the
bulletins you’ve deleted.
If you want to delete an entire folder and its contents, right-click on the folder and choose Delete Folder.
Alternatively, you can select the folder, and then choose Folders > Delete Folder. Any bulletins in the
folder will be moved to the Discarded Bulletins folder. You can’t delete system folders such as Saved
Bulletins or Discarded Bulletins.

6e. Organizing bulletins
You can list bulletins in multiple folders, but only one copy resides on your hard drive. Each listing
references the copy on your hard drive. A bulletin cannot be listed twice in a single folder.
To move a bulletin from one folder to another, drag it. Or select the bulletin and choose Edit > Cut
Bulletin(s), and then select the new folder and choose Edit > Paste Bulletin(s). You can also right-click the
bulletin or folder and choose Cut Bulletin(s) or Paste Bulletin(s) from the context menu. (When you use the
Cut Bulletin(s) command, the bulletin appears in the Discarded Bulletins folder.)
To select all the bulletins in a folder, select the folder and choose Edit > Select All Bulletins (or right-click
the bulletin and choose Select All Bulletins.).
If you want a bulletin to appear in multiple folders, select the bulletin and choose Edit > Copy Bulletin(s);
then select the new folder and choose Edit > Paste Bulletin(s). (Or right-click the bulletin and choose Copy
Bulletin(s) from the context menu; then right-click the folder and choose Paste Bulletin(s) from the context
menu.)
You can rearrange bulletins within a folder, to list them by status, date of event, title, date the bulletin was
last saved, or author. Just click the column heading to sort by that field. Click the column heading again to
reverse the sort (for example, to reverse the order of the dates from newest to oldest or vice versa). The
bulletins will be displayed in that order until you click a different column heading.

6f. Placing bulletins on the desktop
You can drag (or copy/paste) a bulletin to the desktop (or other location on your computer), or drag a
bulletin from the desktop back into Martus. Dragging a bulletin to the desktop enables you to keep a
backup copy of a bulletin you’re working on outside of Martus (especially useful for saving intermediate
versions of drafts). Martus names exported bulletins with the extension .mba (for Martus Bulletin Archive).
These files contain only the latest version of each bulletin.
You can e-mail .mba files to other people, or copy them to a floppy disk. Draft bulletins remain fully
encrypted, including the parts labeled public, so they cannot be viewed by any other user except a
designated Headquarters account. When you e-mail or copy sealed bulletins, anyone may read the public
parts of the bulletin using Martus software, but the private sections remain encrypted. Because you cannot
view another user’s private or draft data unless your account is one of their Headquarters accounts, their
imported bulletins are labeled with a warning message saying “The author has not given you permission to
view the private portions of this bulletin.” Data in .mba files can only be viewed in Martus; you cannot
open them in applications such as Microsoft Word. To use the data in applications other than Martus,
export bulletins as XML files (see “6p. Creating bulletin charts
You can create customized charts from information in the bulletins on your computer, and then print those
reports to a printer or to a JPEG image file (which can be opened in various applications such as image
display tools, or a word processor for further editing/formatting if desired.)
To create a chart:
1. Choose File > Charts.
2. Select click Bar Chart, 3D Bar Chart, or Pie Chart from the “Type of Chart” dropdown list. A Bar or
3D Bar Chart shows counts of bulletins for each value of the field you select, while a Pie Chart shows
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both the counts of bulletins and the % (percentage) of total bulletins that match your defined search
criteria (chosen when you create the chart). See examples below for each type of chart.

Note: You will see a warning message that any data in charts will not be encrypted, so anyone who
sees the chart (in printed or electronic form) will be able to read all the data.
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3.

Click on the Choose Field button to select the field you want to include in the chart, pick a field from
the list (which will include all the standard or custom fields that are in any of the bulletins on your
computer), and then click OK.

4.

If desired, enter text that will be displayed beneath the title of the report in the Subtitle field (e.g.
“Human Rights Organization data collection monthly status report”).
Hit the OK button.
In the Search dialog box, enter the criteria for bulletins you want to include in your chart. To use
search criteria you’ve previously saved, click Load Previous Search. When you’ve entered the search
criteria, click Search. For more information on searching, see “6m. Searching for specific bulletins.”

5.
6.

Note: Martus will remember the immediately previous search criteria without you needing to load it.
7.

Martus displays a preview of the chart. Click Print to Printer to print the report to your printer (Martus
will automatically scale the printout to fit the page width, based on your printer preferences). Click
Print to File to save the report on your computer as a JPEG image file that you can open in the image
display program of your choice, or copy/insert into a word-processing application. If you want to make
changes to the report before printing, click Cancel, choose File > Charts, and create a new chart.

Note: Martus only displays data from the latest version of each bulletin on your computer in the chart.
See examples of charts below.
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Bar Chart:

3D Bar Chart:
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Pie Chart:

Important Note:
1. Martus charts are intended to give you information about the status/progress of data that has been
gathered and entered in Martus, but not to analyze “what happened” from the data that has been
entered. So for example we can count the number of bulletins that came from a particular
timeframe or region (if your project is collection that information), but not how many killings
there were in a particular region.
2. Martus charts are also meant to focus on fields in which the information is distinct for a bulletin or
source document. For example, you can design reports to search for all bulletins entered by a
certain user, or given by individuals of a given ethnicity (if your project is collecting that
information).
3. Martus charts do not correct for the following:
a. Sampling bias (e.g. all bulletins entered being more from one particular region than any
others, even if the project is covering incidents that happened across all of them).
b. Duplicate reporting (i.e. more than one bulletin may exist about the same incident, or the
same person may be mentioned using different names, or there may be multiple people with
the same name).
c. Data quality issues (e.g. typos that might lead to a search not finding bulletins, fields being
left blank where values were expected). Some of these issues can be addressed in a project
customization, by requiring certain fields to be entered before a bulletin or grid row can be
saved, or using dropdown fields to avoid typos and guarantee consistency in searching.
d. Possible inconsistency in how data is entered in Martus by different people. For more on this
topic, see “Controlled Vocabulary” and the “Inter-rater Reliability” section on
https://hrdag.martus.org/resources/core_concepts.shtml.
4. Martus charts especially should not attempt to count the number of violations, victims or
perpetrators, beyond counting the number of bulletins that match search criteria. Before counting
violations or victims/perpetrators, important data processing needs to take place before such
counting can be considered scientifically defensible. This includes addressing the possibility of
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duplicate reporting (more than one bulletin may exist about the same incident); representing the
complexity of human rights violations (an individual who was the victim of a given act may later
become the perpetrator of a different act, or vice versa); and maintaining consistency in meaning
and counting (ensuring, for example, making sure that all the data entered in bulletins used
consistent definitions for violations.)
5. If you would like to perform descriptive or qualitative analysis of the information entered into
Martus, Benetech can help you to use a tool to export and summarize data for your project. The
exported data may be able to be reviewed using analytical tools, but please keep in mind that
quantitative or inferential statistical analysis cannot be performed until additional steps have been
taken in processing the data, and without enough volume and different sources of data, statistical
analysis may not give meaningful or reliable results.
6q. Exporting bulletin data”), or create an html report file (see “6n. Printing bulletins ”).
Note: Because e-mail is not secure, anything you e-mail may be intercepted by someone else.
Note: In Linux, you may not be able to drag bulletins between Martus and your desktop. See section “11.
Frequently Asked Questions” (FAQ) #35 (“Is there another way to get encrypted bulletin files out of
Martus than dragging to the Desktop?)” for instructions on how to do this in Linux.

6g. Retrieving sealed bulletins
Occasionally, you may need to download bulletins that you have sent to the server. You can download any
bulletin you have sent that is not currently on your computer. (Martus does not permit you to retrieve
bulletins that you already have.) You can choose to retrieve only the latest version of a bulletin or all
versions. Users with small disk drives or slow internet connections may choose to retrieve only the most
recent version, especially for large bulletins.
1.

Choose Server > Retrieve My Sealed Bulletins.

Note: The dialog box may not appear immediately, depending on the speed of your Internet connection.
Tip: You can sort the bulletins in the Retrieve screen by clicking on the column headers to help you find
the bulletins you need (especially useful if you have a long list.) For example, you can sort by date (to find
most recent bulletins) or by size (if you want to wait to retrieve a very large bulletin at a later time.) The
sort functionality is ascending only.
2.

In the Retrieve Bulletins dialog box, check the boxes next to the bulletins you want to retrieve. To
select all the bulletins, click Check All; to deselect all the bulletins, click Uncheck All.

Note: By default, the Retrieve Bulletins dialog box displays only bulletins that are not currently on your
computer. Check “Show all bulletins on this server and on this computer” to see all your sealed bulletins
that have been backed up to this server; you cannot retrieve bulletins that are currently on your computer.
3.
4.
5.

Select “Retrieve all bulletin versions” to retrieve all versions of a bulletin; select “Retrieve latest
bulletin version only” to retrieve only the current version of the bulletin.
You can select a bulletin row with the mouse, and click Preview to see subset of the contents of the
selected bulletin before you download it.
Click Retrieve. The bulletins appear in the Retrieved Bulletins folder.

Note: Martus retrieves bulletins in the background, so that you can continue to work in Martus. When
Martus has retrieved the bulletins, it displays them in the Retrieved Bulletins folder. To cancel the bulletin
retrieval, open the Retrieve My Sealed Bulletins dialog box again.
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6h. Retrieving draft bulletins
Draft bulletins are copied to the server in case the originals on your computer are damaged or accidentally
deleted, or you lose access to your computer. You can download your draft bulletins from the server if the
bulletins are not currently on your computer. (As with sealed bulletins, Martus does not permit you to
retrieve bulletins that you already have.)
1.

Choose Server > Retrieve My Draft Bulletins.

Note: The dialog box may not appear immediately, depending on the speed of your Internet connection.
Tip: You can sort the bulletins in the Retrieve screen by clicking on the column headers to help you find
the bulletins you need (especially useful if you have a long list.) For example, you can sort by date (to find
most recent bulletins) or by size (if you want to wait to retrieve a very large bulletin at a later time.) The
sort functionality is ascending only.
2.

In the Retrieve Draft Bulletins dialog box, check the boxes next to the bulletins you want to retrieve.
To select all the bulletins, click Check All; to deselect all the bulletins, click Uncheck All.

Note: By default, the Retrieve Draft Bulletins dialog box displays only bulletins that are not currently on
your computer. Check “Show all bulletins on this server and on this computer” to see all your draft
bulletins that have been backed up to this server; you cannot retrieve bulletins that are currently on your
computer.
3.

4.
5.

Select “Retrieve all bulletin versions” to retrieve all versions of a bulletin; select “Retrieve latest
bulletin version only” to retrieve only the current version of the bulletin (if you have a small disk drive
or slow internet connection you may want to retrieve only the most recent version, especially for large
bulletins).
You can select a bulletin row with the mouse, and click Preview to see a subset of the contents of the
selected bulletin before you download it.
Click Retrieve. The bulletins appear in the Retrieved Draft Bulletins folder.
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Note: Martus retrieves bulletins in the background, so that you can continue to work in Martus. When
Martus has retrieved the bulletins, it displays them in the Retrieved Draft Bulletins folder. To cancel the
bulletin retrieval, open the Retrieve My Draft Bulletins dialog box again.
Note: To update an older version of a draft with a newer version from the server, you must delete the draft
from the computer and retrieve it from the server. If you want to keep a backup copy of the original draft,
you can drag the bulletin to your desktop before deleting it.

6i. Retrieving bulletins created by field desks
If you are using a Headquarters account, you can retrieve draft or sealed bulletins created by Field Desk
accounts who have given your account permission to access their data. (See “9f. Sharing your private data
with colleagues.”) To download those bulletins, choose Server > Retrieve Field Desk Sealed Bulletins or
Server > Retrieve Field Desk Draft Bulletins.
Tip: You can sort the bulletins in the Retrieve screen by clicking on the column headers to help you find
the bulletins you need (especially useful if you have a long list.) For example, you can sort by author (if
you only want to retrieve the bulletins from a particular field office, by date (to find most recent bulletins)
or by size (if you want to wait to retrieve a very large bulletin at a later time.) The sort functionality is
ascending only.
When you view a field desk bulletin from someone you know, a bright green and black “Field Desk
Bulletin” label appears at the top of the bulletin.
We recommend that, when possible, Headquarters accounts “verify” their Field Desk accounts to ensure
that the data is being sent from someone they know. This is especially important when opening
attachments inside bulletins to avoid malware or other potentially dangerous content.
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When a Headquarters account views a bulletin from a Field Desk that has not yet been verified, Martus will
show the following warning:

For instructions on verifying your Field Desk accounts, see “9f. Sharing your private data with colleagues.”
If you would like to be notified if there are field bulletins to retrieve, go to Options > Preferences, and
select "Automatically check for new Field Desk bulletins." Approximately hourly, a message will appear in
the status bar (lower left corner of the screen) saying that Martus is checking for new field desk bulletins.
The status bar will display another message if there are field bulletins to be retrieved, at which point you
can go to the Server menu to load the Retrieve screen as described above.
If you would like to create a new bulletin based on a Field Desk bulletin you have retrieved, you can do so
following the instructions in section "5c. Creating a new version of a sealed bulletin".

6j. Viewing earlier versions of a bulletin
You can view any version of a sealed bulletin on your computer. However, you can only make changes to a
new version.
To view an earlier version of the bulletin, select the bulletin and click Bulletin Details. Then, select a
version from the History list, and click View Selected Version. You cannot make changes to the content of
the bulletin, but you can copy text to the clipboard and paste it into a text file or new bulletin (including the
most recent version of this bulletin). When you have finished viewing the bulletin version, click OK.
Note: If you are a Headquarters account, and you didn’t have access to an earlier version of a field bulletin,
Martus will list the earlier version in the bulletin details, but it won’t retrieve that version of the bulletin to
your computer.

If a Headquarters account creates a new version of a field desk bulletin they can see the public code(s) of
the previous author(s) and the bulletin id(s) of the previous author’s versions of the bulletins, in the
“Extended history” section below the current user’s version information.
Note: When viewing Extended History for a bulletin, the earliest author is displayed at the top of the
Extended History section, and the most recent (before the current author) is at the bottom. Within each
author’s section, if an author created multiple versions of the bulletin, the earliest/oldest version’s bulletin
id is at the top of the list, and the latest/newest is at the bottom.

6k. Viewing and saving attachments
If you are using Windows, you can view an attachment without saving it to your hard drive: click View
Attachment. The application associated with the attachment’s file type opens the attachment. (You can
change the file type’s association in Windows Explorer.)
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If you are using Mac OS or Linux, or if you want to save the attachment to your hard drive, drag the
attachment to the desktop or a folder on your computer. Or click Save Attachment, and save the file to any
location on your computer. Then open the file in an application that can read the file’s format. For example,
if a .doc file is attached, open the file in Microsoft Word. If a .pdf file is attached, open the file in Adobe
Acrobat Reader.
Note: To view the attachment, you must have an application installed that supports the file format of the
attachment. Attachments are not encrypted when you save them onto your hard drive.

6l. Viewing damaged bulletins
Occasionally, data may be lost or garbled in a bulletin stored on your computer. If Martus detects missing
data, it displays a yellow warning at the top of the bulletin that reads: “Warning: Portions may be missing
or damaged.” Often, you can still read some information in the bulletin. If the bulletin is also stored on the
server, you may be able to retrieve the entire bulletin successfully: drag a backup copy of the bulletin to
your desktop, delete the bulletin from Martus, and then try retrieving it from the server. You may also see
this message when viewing the bulletins of another user because you cannot view their private data or
drafts unless you are one of their Headquarters accounts.

6m. Searching for specific bulletins
You can search for bulletins on your computer that contain specific words or phrases, or that contain
specified dates. You can also choose to search all fields, limit your search to certain fields, or search for
different words or phrases in different fields. You can search both standard and custom fields. Note that
searching any field includes attachment filenames, but not the content of attachments. Martus searches all
versions of every bulletin (both public and private, sealed and draft) in every folder, unless the bulletin only
exists in the Discarded Bulletins folder.
1.
2.

Click Search.
In the Search dialog box, select the field to search, indicate how the bulletin field should compare to
the search terms, and enter the word(s) or date(s) you are searching for. You can search for words in
any language. If you are searching for terms in a table/grid, select which column in the grid to search.
When selecting text fields, you can ask Martus to scan and load all the values that have been entered
for those fields in your bulletins on the local computer by selecting the “Load all possible values for
selected field” checkbox in the field selection screen. For other field types the checkbox will be
“grayed out” (i.e. not selectable).
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There is also a “Load all possible values for selected field” button in the main Search screen, if users
want to load field values without going into the field selection screen (for example, after loading a
previously saved search, or if they did not select the checkbox in the field selection screen). For “datadriven dropdown” (dropdown lists created by data entered in bulletin grids), the values that were
entered in bulletins are automatically loaded when the field is chosen in the Search screen. See section
“10b. Customizing bulletin fields” for more about data-driven dropdown fields.

Note: If multiple fields have the same label in the field selection screen, click the plus sign next to the label
name to choose the appropriate field. Martus displays the tag name and field type (e.g., “text”) for each
field with that label. If you have multiple dropdown fields with the same label, Martus will merge all the
values into one list in the Search screen. Any customized field labels that contain only spaces will be
replaced with that field's tag in the search field list.
3.
4.

If you would like to add additional search constraints, press Enter or click Insert Row to create a new
search row. You can search another field or limit your search to a certain date or date range.
If you would like to delete a search constraint, select that row and click Delete Selected Row.

Note: There are several ways bulletin fields can compare to search terms.
contains : Any bulletins in which the specified field contains the search terms
= : Only the bulletins in which the specified field exactly matches the search terms
!= : Bulletins in which the specified field does not match the search terms
> : Bulletins in which the field’s value is greater than the search value
>= : Bulletins in which the field’s value is greater than or equal to the search value
< : Bulletins in which the field’s value is less than the search value
<= : Bulletins in which the field’s value is less than or equal to the search value
5.
6.
7.

Click Search. A dialog box will display the search progress, and allow you to cancel the search at any
time if you wish.
When the search is complete, the Search Results dialog box reports how many bulletins were found
that matched your criteria. Click OK.
The Search Results folder lists the bulletins found in your search. (The folder contains copies of the
bulletins; the originals remain in their original folders.) If your search resulted in no bulletins, the
Search Results folder will still contain the bulletins from the previous search.

Note: By default, Martus searches all versions of every bulletin. If you do not see your search terms/dates
in the final version of the bulletin displayed in the Search Results folder, your criteria may have been
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matched in an earlier version of the bulletin. You can access previous versions by clicking the “Bulletin
Details…” button at the top of the bulletin. For more information, see “6j. Viewing earlier versions of a
bulletin.” To search only the most recent versions of bulletins, select Only Search Most Recent Versions of
Bulletins in the Search dialog box. The Search dialog box will remember this selection the next time you
run a search.
Note: By default, Martus searches all rows of any grid (table) fields for your criteria and doesn’t require
that the terms are all on the same row. See section “10b. Customizing bulletin fields” for more information
about grid fields. If you want to specify that all grid column specifications in the Search screen be matched
to a single row of bulletin grid data, check the “Match grid column specifications” checkbox in the Search
screen. For example, if you want to search for a specific victim name in a single grid row in your bulletins
created after a certain date, select the checkbox and enter the following fields in the Search screen: "Victim
Information: First Name" = x and "Victim Information: Last Name" = y and "Date Created" >= YYYYMon-DD. If you do not select the "Match grid column specifications" checkbox, Martus will find bulletins
created after your specified date where any row has the first name you specified and any other row has the
last name specified, but not necessarily in the same bulletin row (you could have a row with "First Name" =
x and "Last Name" = b, and a different row with "First Name" = a and "Last Name" = y, and Martus will
find that bulletin as matching the search because you did not specify that it had to match in a single row).
Note: Because Martus searches all rows of any grid (table) fields for your criteria, it may find bulletins
where one grid row matches your criteria but other rows do not. For example you could have a bulletin
with a grid that has a location field in it and you have multiple rows of data in the grid with locations A, B,
and C. If you search for bulletins where location != C (does not equal C), Martus will find that bulletin
because there are 2 rows in the bulletin grid where the location is not C, even though there is one row
where the locations IS C.
Note: In this release, if you are searching on a multi-level dropdown, all searches are exact matches, not
partial or “starts with” matches. This means that you have to pick the exact level at which you want to be
searching. For example, an “Event Location” field that has three levels (State/City/Neighborhood) will
have three entries in the search field list: Event Location: State, Event Location: City, and Event Location:
Neighborhood. So if you want to find any bulletins that have an Event Location anywhere in California
(regardless of the City), you have to pick the “Event Location: State” field to search on and pick California
off the dropdown list choices. If you pick Event Location: City to search on and then pick California but
leave the City level blank , Martus will only find entries where there was no City data entered (City was
blank), as opposed to ANY location with California regardless of what data was entered at the City level.
Note: If you have fields in your bulletins with the same tag but different labels and/or field types, Martus
may use the tag and field type to try and determine when different fields were meant to be the same when it
searches. So we encourage you to make your field tags and labels in a customization clearly related to each
other to avoid any confusion. See section “10b. Customizing bulletin fields” for more information about
configuring custom fields.
For some additional help with searching, see section “11. Frequently Asked Questions” (FAQ), #46 and
#47, or email help@martus.org.
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To save your search criteria, click Save This Search in the Search dialog box. Then, give the search criteria
a name you’ll recognize later. Martus saves it with the .mss (Martus Search Specification) extension in the
folder you choose. To use search criteria you’ve saved, click Load Previous Search in the Search dialog
box, and then navigate to the .mss file you want to use.

Note: Martus will remember the immediately previous search criteria without you needing to load it.
Search tips
1. To search for an exact phrase, type it with quotation marks around the phrase (e.g., "Witness
Testimony"). If you do not put quotation marks around the phrase, Martus will search for the words
individually.
2. Martus will find the text you enter whether it’s a complete word or part of a larger word. For example,
if you search for the word prison, you’ll see bulletins that include the words prison, imprison, and
imprisonment. Likewise, if you search for the word prison, Martus will find bulletins that include
attachments with names such as photos-prison.jpg and prisoners-report.doc.
3. You can search for words in any language. Martus searches are not case-sensitive in English and other
purely Latin character languages, so it doesn’t matter whether a word is capitalized or not.
4. Use the word “or” to broaden your search, or the word “and” to narrow it. You can use the and / or
dropdowns to specify different fields you want search across (e.g., you want to search for bulletins that
have "Last Saved Date" in the last week and have a certain author). If you want to search on multiple
text values within a single bulletin field, you can use or or and in-between words in the "Search For..."
entry box. For example, if you search "Any Field" for prison or jail you’ll see a list of bulletins that
contain either word anywhere in the bulletin. If you search for prison and assault you’ll see a list of
bulletins that contain both words. The keyword "and" is implied, so if you search for prison assault
Martus will find the same bulletins as if you searched for prison and assault.
5. When you use both "and" and "or" , your search terms are grouped from the beginning of your list
(either across bulletin fields or within a particular field). For example, if you enter prison or jail and
trial in the "Search For..." entry box, Martus will search for any bulletins that contain either of the
words prison or jail, and also contain the word trial. But if you enter prison and jail or trial Martus will
search for any bulletins that contain both the words prison and jail, or contain the word trial.
6. If you are using a language other than English, you can use the translation of the words "or" or "and" in
that language or you can use the English words "or" and "and" to search. For example, if you are using
Martus in Spanish, use the word "o," "y," "or," or "and" when searching.
7. For languages that do not use spaces to separate words, you need to put spaces before and after any
“or” / “and” keywords you use in your search.
To save your search results, right-click the Search Results folder and choose Rename Search Results
Folder; then enter a new name for the folder. Alternatively, you can select the folder, and then choose
Folders > Rename Folder or click on the folder name again, and type a new folder name. The next time you
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search, Martus will create a new Search Results folder. If you do not rename the Search Results folder, the
contents will be overwritten the next time you search.
To print the results of your search, see “6n. Printing bulletins .”

6n. Printing bulletins
Martus allows you to print one or more bulletins at a time. To print:
1. Select the bulletin(s) you would like to print and click Print (or choose File > Print Bulletin(s).)
2. The Print Options dialog box appears. You have the option of including or excluding the bulletin’s
private information, and printing to a printer or sending the output to an html report file on your
computer.
3. Click Continue.

4.
5.

If you have chosen to send html formatted output to a report file, the Print To Which File dialog box
appears. Name the file and select a destination for it (or select an existing file) and click Save.
If you have chosen to print the bulletin contents to a printer, the standard Print dialog box opens with
options available for your printer.

Martus prints a list of attachments, but not the contents of the attachments. To print an attached file, click
Save Attachment, save it to a folder on your hard drive, and then open it and print it in an appropriate
application, such as an image-editing or word-processing application. In Windows, you can simply click
View Attachment, and then print the attachment from the application that opens it; you needn’t save it to
your hard drive first.
Note: Martus prints only the latest version of each bulletin on your computer.
To print a set of bulletins that match a set of filter criteria, you can run a search, and print all the bulletins
that are displayed in the Search Results folder. For more information on searching, see “6m. Searching for
specific bulletins.”

6o. Creating bulletin reports
You can create customized reports from information in the bulletins on your computer, and then print those
reports to a printer or to an HTML file (which can be opened in a browser, or other application such as
word processor or spreadsheet for further editing/formatting if desired.)
To create a report:
1. Choose File > Reports.
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2.

To create a new report format, click Create New Tabular Report or Create New Page Report. A tabular
report lists bulletin fields as columns in a table, with each bulletin as one row in the table. A page
report lists the selected subset of fields from each bulletin separately, and is formatted as bulletins
appear when printed individually.

If you want to use a report format you’ve previously saved, click Use Existing Report Format, open the
saved .mrf (Martus Report Format) file and skip to step 5.

3.

In the Create Report dialog box, select the fields you want to include in the report, and then click OK.
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If you’re creating a tabular report, click Add in the Organize Report Fields dialog box to open the
Create Report dialog box, select the fields you wish to include and hit OK. You can then change the
order of fields on the report by selecting a field and clicking Move Up or Move Down. Click OK when
you’ve arranged the fields the way you want them.

4.

In the Save Report Format As dialog box, enter a name for the format you’ve created, and then click
Save. Martus saves the report format with an .mrf extension in the directory you choose (it will put it
in your Martus account directory by default).
Note: If you Cancel out of the Save Report Format As dialog box, your report format will be lost. You
must save each report format you create in order to run the report.

5.

In the Search dialog box, enter the criteria for bulletins you want to include in your report. To use
search criteria you’ve previously saved, click Load Previous Search. When you’ve entered the search
criteria, click Search. For more information on searching, see “6m. Searching for specific bulletins.”
Note: Martus will remember the immediately previous search criteria without you needing to load it.

6.

Specify the bulletins’ order in the report. You can select up to three fields by which to sort. Martus
sorts the bulletins by the first field you choose, and if multiple bulletins have the same information in
the first field, it then sorts by the second field, and finally by the third field. For each field, click
Choose Field, select the field you want Martus to sort by, and click OK.
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Note: Martus will remember the immediately previous sort selection until you exit Martus.
7.

Choose whether to print only the bulletin information, only summary counts, or both. If you include
summary counts, the report contains total counts of bulletins grouped by the fields you’ve chosen to
sort the bulletins on. For example, if you’re sorting by author and you choose to print the bulletin
information and summary counts, the report will include the bulletin data and a summary of how many
bulletins were created by each author. Choose whether to print only public data or both public and
private data in the report.

8. Martus displays a preview of the report that will print. Click Print to Printer to print the report to your
printer. Click Print to File to save the report as an HTML file that you can open in a web browser or
word-processing/spreadsheet application. If you want to make changes to the report before printing,
click Cancel, choose File > Reports, and create a new report format.
Note: You can copy and paste text from the preview screen directly into other applications, e.g., wordprocessors or spreadsheets.
Note: Martus only displays data from the latest version of each bulletin on your computer in the report.
See examples of reports below:
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Tabular report with summary counts:
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Page report without summary counts:

Important Note:
1. Martus reports are intended to give you information about the status/progress of data that has been
gathered and entered in Martus, but not to analyze “what happened” from the data that has been
entered. So for example we can count the number of bulletins that came from a particular
timeframe or region (if your project is collection that information), but not how many killings
there were in a particular region.
2. Martus reports are also meant to focus on fields in which the information is distinct for a bulletin
or source document. For example, you can design reports to search for all bulletins entered by a
certain user, or given by individuals of a given ethnicity (if your project is collecting that
information).
3. Martus reports do not correct for the following:
a. Sampling bias (e.g. all bulletins entered being more from one particular region than any
others, even if the project is covering incidents that happened across all of them).
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b.

4.

5.

Duplicate reporting (i.e. more than one bulletin may exist about the same incident, or the
same person may be mentioned using different names, or there may be multiple people with
the same name).
c. Data quality issues (e.g. typos that might lead to a search not finding bulletins, fields being
left blank where values were expected). Some of these issues can be addressed in a project
customization, by requiring certain fields to be entered before a bulletin or grid row can be
saved, or using dropdown fields to avoid typos and guarantee consistency in searching.
d. Possible inconsistency in how data is entered in Martus by different people. For more on this
topic, see “Controlled Vocabulary” and the “Inter-rater Reliability” section on
https://hrdag.martus.org/resources/core_concepts.shtml.
Martus reports especially should not attempt to count the number of violations, victims or
perpetrators, beyond counting the number of bulletins that match search criteria. Before counting
violations or victims/perpetrators, important data processing needs to take place before such
counting can be considered scientifically defensible. This includes addressing the possibility of
duplicate reporting (more than one bulletin may exist about the same incident); representing the
complexity of human rights violations (an individual who was the victim of a given act may later
become the perpetrator of a different act, or vice versa); and maintaining consistency in meaning
and counting (ensuring, for example, making sure that all the data entered in bulletins used
consistent definitions for violations.)
If you would like to perform descriptive or qualitative analysis of the information entered into
Martus, Benetech can help you to use a tool to export and summarize data for your project. The
exported data may be able to be reviewed using analytical tools, but please keep in mind that
quantitative or inferential statistical analysis cannot be performed until additional steps have been
taken in processing the data, and without enough volume and different sources of data, statistical
analysis may not give meaningful or reliable results.

6p. Creating bulletin charts
You can create customized charts from information in the bulletins on your computer, and then print those
reports to a printer or to a JPEG image file (which can be opened in various applications such as image
display tools, or a word processor for further editing/formatting if desired.)
To create a chart:
8. Choose File > Charts.
9. Select click Bar Chart, 3D Bar Chart, or Pie Chart from the “Type of Chart” dropdown list. A Bar or
3D Bar Chart shows counts of bulletins for each value of the field you select, while a Pie Chart shows
both the counts of bulletins and the % (percentage) of total bulletins that match your defined search
criteria (chosen when you create the chart). See examples below for each type of chart.

Note: You will see a warning message that any data in charts will not be encrypted, so anyone who
sees the chart (in printed or electronic form) will be able to read all the data.
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10. Click on the Choose Field button to select the field you want to include in the chart, pick a field from
the list (which will include all the standard or custom fields that are in any of the bulletins on your
computer), and then click OK.

11. If desired, enter text that will be displayed beneath the title of the report in the Subtitle field (e.g.
“Human Rights Organization data collection monthly status report”).
12. Hit the OK button.
13. In the Search dialog box, enter the criteria for bulletins you want to include in your chart. To use
search criteria you’ve previously saved, click Load Previous Search. When you’ve entered the search
criteria, click Search. For more information on searching, see “6m. Searching for specific bulletins.”
Note: Martus will remember the immediately previous search criteria without you needing to load it.
14. Martus displays a preview of the chart. Click Print to Printer to print the report to your printer (Martus
will automatically scale the printout to fit the page width, based on your printer preferences). Click
Print to File to save the report on your computer as a JPEG image file that you can open in the image
display program of your choice, or copy/insert into a word-processing application. If you want to make
changes to the report before printing, click Cancel, choose File > Charts, and create a new chart.
Note: Martus only displays data from the latest version of each bulletin on your computer in the chart.
See examples of charts below.
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Bar Chart:

3D Bar Chart:
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Pie Chart:

Important Note:
6. Martus charts are intended to give you information about the status/progress of data that has been
gathered and entered in Martus, but not to analyze “what happened” from the data that has been
entered. So for example we can count the number of bulletins that came from a particular
timeframe or region (if your project is collection that information), but not how many killings
there were in a particular region.
7. Martus charts are also meant to focus on fields in which the information is distinct for a bulletin or
source document. For example, you can design reports to search for all bulletins entered by a
certain user, or given by individuals of a given ethnicity (if your project is collecting that
information).
8. Martus charts do not correct for the following:
a. Sampling bias (e.g. all bulletins entered being more from one particular region than any
others, even if the project is covering incidents that happened across all of them).
b. Duplicate reporting (i.e. more than one bulletin may exist about the same incident, or the
same person may be mentioned using different names, or there may be multiple people with
the same name).
c. Data quality issues (e.g. typos that might lead to a search not finding bulletins, fields being
left blank where values were expected). Some of these issues can be addressed in a project
customization, by requiring certain fields to be entered before a bulletin or grid row can be
saved, or using dropdown fields to avoid typos and guarantee consistency in searching.
d. Possible inconsistency in how data is entered in Martus by different people. For more on this
topic, see “Controlled Vocabulary” and the “Inter-rater Reliability” section on
https://hrdag.martus.org/resources/core_concepts.shtml.
9. Martus charts especially should not attempt to count the number of violations, victims or
perpetrators, beyond counting the number of bulletins that match search criteria. Before counting
violations or victims/perpetrators, important data processing needs to take place before such
counting can be considered scientifically defensible. This includes addressing the possibility of
Martus 4.3 User Guide

59

duplicate reporting (more than one bulletin may exist about the same incident); representing the
complexity of human rights violations (an individual who was the victim of a given act may later
become the perpetrator of a different act, or vice versa); and maintaining consistency in meaning
and counting (ensuring, for example, making sure that all the data entered in bulletins used
consistent definitions for violations.)
10. If you would like to perform descriptive or qualitative analysis of the information entered into
Martus, Benetech can help you to use a tool to export and summarize data for your project. The
exported data may be able to be reviewed using analytical tools, but please keep in mind that
quantitative or inferential statistical analysis cannot be performed until additional steps have been
taken in processing the data, and without enough volume and different sources of data, statistical
analysis may not give meaningful or reliable results.

6q. Exporting bulletin data
You can export the data in a bulletin to an XML file, which you can open in any application that supports
XML (Extensible Markup Language). XML documents include tags that define the structure of the
document, and the role of each document component in that structure. Martus exports only the latest
version of each bulletin on your computer, but shows any previous version bulletin ids and public keys for
previous authors in an “Extended History” section of the exported file, for those who need it.
To export bulletins to XML:
1. Select the bulletins you want to export, and choose File > Export Bulletins. Or, to export all the
bulletins in a folder, choose File > Export Folder.
2. By default, only public data is included in the XML file. If you want to include private data, select
“Include private data in export”.
3. If you want to export the bulletin attachment files, select “Include attachments in export”.
4. Click Continue.
5. Name the XML file and specify a destination for it. All the selected bulletins are included in a single
XML file.
6. Click Save.
7. Click OK when Martus confirms that it has finished exporting the bulletins.
Note: If you specify that only public data should be exported, any bulletins whose data are all private will
be skipped in the export file.
Note: When viewing Extended History in an exported XML file for a bulletin, the earliest author is
displayed at the top of the Extended History section, and the most recent (before the current author) is at
the bottom. Within each author’s section, if an author created multiple versions of the bulletin, the
earliest/oldest version’s bulletin id is at the top of the list, and the latest/newest is at the bottom.
Note: If you want to export more than the final versions of your bulletins, see section “11. Frequently
Asked Questions” (FAQ) number 50 (Is it possible to export more than the final version of my bulletins to
XML?).

6r. Importing bulletin(s)
You can import bulletins from files that are formatted in XML, including bulletins that have been exported
from Martus. You can also import attachments such as pictures, word-processing documents, or
spreadsheets. Attachments do not have to be in XML format to be imported.
To import bulletins:
1. Choose File > Import Bulletins.
2. Navigate to the XML file for the bulletins you want to import, and click Continue.
3. Enter the name of the folder you want Martus to add the bulletins to, and click Continue
Martus reports its progress as it imports the bulletins. When it has finished, it either confirms that it was
successful or reports any problems.
Note: In this version, bulletins will be imported as drafts.
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To find out more about creating Martus XML import files from your electronic data (for example,
spreadsheets or other databases), please see examples in the Martus source-code (available on the Martus
CD or at https://sourceforge.net/projects/martus,) and email help@martus.org if you need additional
assistance.
If you have a very large file to import, or your import has a lot of special characters in it (e.g. < > ' " ) you
may receive import errors. If the size of the file is the issue, you can try splitting into smaller files. Please
contact help@martus.org if you need help with any import issues.
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7. Deleting Your Bulletins and Account Information
You can delete your key file, all of the bulletins you have stored on your hard drive, and all other
information for your account without removing the Martus application itself.
Note: If you have not sent bulletins to the server or otherwise backed them up, the data will be permanently
lost after you delete it from the computer.
To delete your account information and all your bulletins from your computer:
1. Close all other applications on your computer.
Note: You can delete bulletins and Martus folders while other applications are open, but Martus may not be
able to remove all Martus folders if other applications are open during the process.
2.
3.
4.

Choose Tools > Delete My Data.
Enter your username and password.
If there are files that have not been sent to a server yet, Martus will prompt you to confirm deletion.
Click Yes to move to a confirmation dialog box; click No to retain bulletin files and stop the deletion
process.

Note: Before you delete your Martus account information, make sure you have backed up your key file and
will be able to restore it. If you delete your key without backing it up, you will lose access to all private
data you’ve sent to the server; such data would be available only to Headquarters accounts that were
created before the bulletins were saved and sent to a server. When you delete your key, the following will
also be deleted: server settings, Headquarters account, default details values, custom fields, user-created
folders in Martus, and interface preferences (e.g., date format, column widths).
5.
6.

Click Yes to confirm that you want to delete all your bulletins and your account information, including
your key file, from your computer. If you do not wish to continue, click Cancel.
Martus automatically closes.

Note: Martus cannot delete any bulletins or account files that you have copied or moved to folders outside
the Martus folder, such as the desktop. Such files will remain on your computer until you manually delete
them. Additionally, Martus cannot delete bulletins or your information from any other computers where
you set up your account, and it will not delete bulletins from the Martus Server.
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8. Deleting All Martus Data, Including the Application
In emergency situations, you may wish to remove all trace of Martus and its data from your computer. You
can delete all bulletins and information for all accounts on the computer, as well as uninstalling Martus.
Martus deletes bulletin and account information in a way that makes it more difficult for intruders to
recover than if you delete the files manually.
Warning: Do not use this procedure unless it is absolutely necessary that you remove all Martus data from
the computer. By following this procedure, you will irrevocably remove all account information and all
bulletins—for all Martus users—from the computer.
Before you use this option, ensure that all account users have backed up their key files, and that all users'
bulletins have been backed up to the server or to another secure location. Without the key files, private data
created by that account may be inaccessible; such data would be available only to Headquarters accounts
that were created before the bulletins were saved and sent to a server.
To delete the Martus program and all users' account information, bulletins and folders, from your computer:
1. Close all other applications on your computer.
Note: You can delete Martus data while other applications are open, but Martus may not be able to remove
all folders if other applications are open during the process.
2. Choose Tools > Delete All Data and Remove Martus.
3. Enter your username and password.
4. If there are files that have not been sent to a server yet, Martus will prompt you to confirm deletion.
Click Yes to continue; click No to retain bulletin files and stop the deletion process.
Note: Before you delete your Martus account information, make sure you and all other users have backed
up all key files and will be able to restore them. If you delete the keys without backing them up, you and
others users will lose access to all private data each of you have sent to the server. When you delete the
keys, the following will also be deleted: server settings, Headquarters account, default details values,
custom fields, user-created folders in Martus, and interface preferences (e.g., date format, column widths).
5. If you are absolutely certain that you want to delete the Martus application, all account information, and
all bulletins from the hard drive, click OK. If you do not wish to continue, click Cancel.
6. If you click OK to continue the deletion, Martus automatically closes.
Note: Martus cannot delete any program, bulletins or account files that you have copied or moved to
folders outside the Martus folder, such as the desktop, or the Mac Applications folder. Such files will
remain on your computer until you manually delete them. Additionally, Martus cannot delete bulletins or
your information from other computers where you've set up your account, and it will not delete bulletins
from the Martus Server.
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9. Keeping Your Data Secure
Martus has been designed with security in mind. Understanding how its security features work can help you
keep your bulletins secure, while ensuring that you can continue to access them.

9a. How Martus security works
Every Martus account has a key which can only be accessed using the password for that account. When you
sign in to Martus, your password enables the application to open the key, so that you can create new
bulletins or see the bulletins you’ve created and stored.
Your key is yours alone; if you lose it due to hard drive failure or accidental erasure, no one will be able to
open your private bulletins, the private data in the public bulletins you’ve sent to the server, or any of the
bulletins on your hard drive, whether they are in draft or sealed status. However, if you’ve set up a
Headquarters (HQ) account, the HQ accountholder (typically, your organization’s main office) will still be
able to see the private data that you sent to the server. Additionally, if you have done a multi-file backup of
your account information (see "9b. Backing up your key",) you will be able to access your account.

9b. Backing up your key
To ensure that you’ll always have access to your data, it is extremely important to keep a backup of your
key. Martus offers two methods for backing up your key, either of which may be used, but we strongly
recommend using both backup methods. The first method creates a single, password encrypted key
backup file onto removable media (e.g., floppy disk, CD, USB storage) or a network drive; the second
method backs up the key in five separate pieces (not encrypted with your password) onto multiple floppy
disks or other removable media. When you back up your key in Martus, you will be led through both
methods.
Your first opportunity will be to save your key, encrypted using your login name and your password, onto a
single floppy disk, other removable media, or a network drive, which you should keep handy in case your
computer is damaged or unavailable. When you back up your single key file to removable media or a
network drive, the file contains everything you need to restore your account, as long as you know your
username and password. Be sure to store the backup file in a secure location, and label it in a way that lets
you identify its contents but is not obvious to others. To restore this password-protected key in the future,
select “Restore Account” and “Restore account from backup key file” when signing into Martus.
The second backup opportunity requires five removable disks (e.g., floppy disks, CDs, USB storage),
which you distribute to trusted friends and colleagues. This method breaks up your key into five pieces,
any two of which will be required to reconstruct the key without requiring a password. If you forget your
login name or your password, this method is the only way you can restore your key. Once the five files
have been written to removable media disks, you should distribute them to five different people whom you
will remember, but none of them should know who you have given the other files to. Do not store any of
the disks together. Anyone can use two of these disks to access your account, even without knowing your
username and password. To restore this key, first retrieve any two of the original five disks, and then select
“Restore Account” and “Restore account from multiple disks” when signing into Martus.
To back up your single password-encrypted key file onto removable media or a network drive:
1. Insert a blank disk into your floppy (or other removable media) drive.
2. Choose Tools > Backup My Key.
3. Read the informational dialog boxes.
4. In the Back Up Key File dialog box, navigate to your floppy drive, another removable media device
(e.g., USB or CD), or your network drive.
5. Give the backup key file a unique name, especially if more than one account is used on the computer.
By default, Martus names the file MartusKeyPair.dat. You may choose to add a number or code word
to the file, such as MartusKeyPair222.dat.
6. Click Save. Martus copies the backup key file to the location you specified.
7. Click OK in the Finished dialog box.
8. Store your backup disk or other removable media in a secure place where it is unlikely to be damaged
by weather, insects, or other factors. Do not write your password on the disk or store it on the disk
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9.

electronically. No one can use the key you back up to a single file without your username and
password.
If you do not want to back up your key file to multiple disks, click No in the dialog box that appears.
We recommend backing up your key file to multiple disks. To do so, follow the instructions below.

Note: Create a new single password-encrypted key backup whenever you change your username or
password. See “9h. Changing your user name or password” for more information.
Next, to back up your key file to five separate floppy disks or other removable media (two of which will be
required to restore the key file):
1. Click Yes to create an additional set of backup files on five separate removable disks.
2. Read the informational screen and click Continue.
3. Name the file and click OK.
Tip: Give the file a unique name that you will remember later, and that can be distinguished from other
accounts’ backup files. Each of the five files will have the same name, with a sequence number appended.
For example, if you name the file kpbackup, the files will be saved as kpbackup-1.dat, kpbackup-2.dat, and
so on.
4.

Navigate to your floppy disk (or other removable media) drive in the Saving Backup Disk dialog box,
and click Save. You must use a removable media drive (e.g., floppy, CD, USB storage) instead of
your hard drive, because the program will not save two of your backup files to the same place.

Note: If Martus gives you an error when using a USB drive, see section “11. Frequently Asked Questions”
(FAQ) #27 (“When I back up or restore my key using USB drives, Martus doesn’t recognize them as
different disks. What’s going on?”).
5.
6.
7.
8.
9.

Insert disks or other removable media as prompted, clicking OK each time to proceed to the next disk.
To ensure that the data has been written properly, click Yes in the Verify Disks dialog box.
Insert disks or other removable media as prompted, clicking OK each time to proceed to the next disk.
If Martus was able to verify the data on all the disks, click OK in the Verification Succeeded dialog
box. If there were problems with one or more disks, repeat the backup process with different disks.
Read the information in the Backup Complete dialog box, and click OK.

9c. Restoring your key
If you have lost your computer, had a hard drive failure, or lost your key for some other reason, restore
your key using your backup copy. If you know your username and password and have a single file key
backup, we recommend you use that file as it is more secure. However if you have forgotten your
password, you will need to restore your key from multiple disks.
To restore your key:
1. Install Martus, if it isn’t currently installed.
2. Click the Restore Account tab in the Martus Signin dialog box.
3. Select an option to restore your account: from a single backup key file or from multiple diskettes.
4. Read the informational dialog box, and click OK.
5. If you’re using a single backup key file, find the file on your hard-disk/network-drive or insert the
floppy disk (or other removable media) that contains the file and navigate to it, and click OK.
If you’re using two disks from a five-disk set, insert the first disk and navigate to the file it contains;
click OK; and then insert the second disk and click OK. Make sure to redistribute the key backup
disks after restoring your key.
6. If you are restoring from the single encrypted key file, log into Martus using the username and
password that were associated with the key at the time you created the backup file.
If you are restoring from the multiple backup disks, you can either use your old username and
password or create a new username and password for your account.
7. You will then be asked to create a password encrypted backup file of your key with this username and
password. See "9b. Backing up your key" for more details.
8. After the restoration is complete, be sure to re-distribute the key backup disks. Any time two of those
disks are in the same place, anyone could use them to access your account, even without knowing your
username or password.
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Note: If Martus gives you an error when using a USB drive, see section “11. Frequently Asked
Questions” (FAQ) #27 (“When I back up or restore my key using USB drives, Martus doesn’t
recognize them as different disks. What’s going on?”).

9d. Using your password wisely
It is critical that your password remain secret. Do not share your password with anyone, and do not use a
password that someone could easily guess.
Each time you change your password, back up your key and delete all previous single file backups (you do
not need to, and should not, delete any multiple file backups you created since they are not encrypted with
your password). Your new backup key file is encoded using your new password. See “9h. Changing your
user name or password” for more information.
When Martus is running, it will prompt you to re-enter your username and password after ten minutes of
inactivity. This is to minimize the chance that other people will be able to access your private data if you
leave Martus open while you are away from your computer. If Martus prompts you for your username and
password while you are editing a bulletin, and you click Cancel, changes you've made to the bulletin are
lost and it reverts to its last-saved state. If you haven’t ever saved that bulletin, the entire bulletin is lost.
We suggest you save any bulletins you’re working on and then exit Martus before you leave your system
unattended.

9e. Using safe computing practices
If you are concerned about the security and reliability of Martus, you also need to be vigilant about
protecting all other software that runs on your computer, including your operating system (such as
Microsoft Windows, Mac, Linux). If attackers are able to find any security holes in your operating system,
they may be able to view your private data, or to create bulletins that will appear to have been written by
you.
It can require a lot of effort to thoroughly protect a computer that is connected to the Internet. But even a
small amount of effort can preserve the integrity of your computer against many of the most common
intrusions.
 Install virus protection software and subscribe to a virus definitions update service to protect your
system from viruses and worms. McAfee (http://www.mcafee.com/) and Symantec
(http://www.symantec.com/) are two of the companies offering virus scanning software and update
services.
 If running under Windows, regularly check for and install critical product updates from Microsoft at
http://windowsupdate.microsoft.com to preserve the integrity of your operating system.
 To see more extensive suggestions for protecting your computer, visit http://www.trendmicro.com/pccillin/vinfo/safe_computing/ and http://www.staysafeonline.info/sectips.adp/. Consider implementing
as many of these suggestions as are practical for your organization.
 We also recommend that you install and regularly update spyware (also known as "malware" or
"adware") protection software.
To increase the security of Martus on your computer (in case your computer falls into the wrong hands),
there is an extra precaution you can take if you are running Windows. The feature erases the Windows
virtual-memory swap-file (also known as a pagefile) when you shut down your computer. This file
contains temporary snapshots of certain portions of data that were used by any programs while you were
working. Enable this feature, and your pagefile will be erased when you shut down your computer. It may
add a little time to the shutdown process.
 The instructions for enabling this feature in Windows 2000 or Windows XP Professional are: Go to Start/Control Panel/Administrative Tools/Local Security Policy/Local Policy/Security Options, then
scroll down the right-hand panel until you find "Shutdown: Clear virtual memory pagefile" or "Clear
virtual memory pagefile when system shuts down".
 For other versions of Windows (such as ME or XP Home), there may be registry settings or other
methods to accomplish the same goal. If you are interested in these, check with your system
administrator, or search the web for the registry key called “ClearPageFileAtShutdown".
Note: As described elsewhere in this User Guide, Martus allows you to attach files to bulletins. On most
operating systems, when attachments are opened they are automatically saved in a ‘temporary’ directory,
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which is unencrypted. For information about the security precaution known as attachment ‘shredding,’
please see section “11. Frequently Asked Questions” (FAQ) #38.
For additional security options when running Martus, see “11. Frequently Asked Questions” (FAQ) #53
and #54.

9f. Sharing your private data with colleagues
Your organization’s headquarters may want to access the bulletins you create, and the bulletins created by
other members of your organization. Your organization’s headquarters—or anyone else you want to share
your data with (e.g. an editor who wants to review the work of a journalist, or even a colleague in your
same office) —can create a Headquarters (HQ) account, which will permit them to view your bulletins,
including the private data in them, only if you give them permission. They will not be able to create
bulletins using your account. This access can provide several advantages: it gives the headquarters accounts
more information, and it ensures that someone will be able to access your private bulletin data even if you
lose your key file or forget your password. You can create multiple HQ accounts, which can be useful if
you would like to send different bulletins to different HQ accounts, or if there are additional people inside
or outside your organization who you want to review your bulletins.
In Martus, we call the account receiving someone else’s bulletin data the “Headquarters” or “HQ” account.
And the account that is sending or sharing the bulletin data to the HQ is called a “Field Desk” account
(since many Martus users are sending data from the field to a more centrally located person). However,
there are many different possible configurations that may fit needs of your organization. See some
examples below:
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All the private (and public) data in each bulletin that you save will be viewable by any HQ accounts you
have selected under the bulletin’s “Headquarters” section. This allows you to designate which HQ
accounts are allowed to view each bulletin.
As soon as a bulletin has been saved with an HQ account, the information in that bulletin will be available
to that HQ. Removing that HQ later will not prevent that HQ from viewing the private data that was saved
when they were configured as your HQ, but it will prevent them from viewing any the data in any bulletins
you create after they were removed.
To access your bulletins, your Headquarters account must first export their public account ID and give it to
you, along with their public code. Then, you import the Headquarters public account ID and enter their
public code.
Note: Only bulletins saved after you import the public account information will be available to your
Headquarters account. If you created a bulletin without a particular HQ account configured and/or selected,
you can create a new version of the bulletin with the HQ account selected so they can view the content.
We recommend that, when possible, Headquarters accounts also “verify” their Field Desk accounts to
ensure that the data is being sent from someone they know. This is especially important when opening
attachments inside bulletins to avoid malware or other potentially dangerous content. When a Headquarters
account views a bulletin from a Field Desk that has not yet been verified, Martus will show the following
warning:

To verify a Field Desk account, the Field Desk account must export their public account ID and give it to
their Headquarters account, along with the Field Desk account public code. Then, the Headquarters account
imports the Field Desk public account ID and enters their public code.
Instructions for giving your account information to another Martus account
To share your public account ID and public code with other Martus accounts (e.g. a Headquarters account
who wants to receive bulletins from people in the field, or a Field Desk account that wants to be verified by
their Headquarters account):
1. Create a Martus account. (See “2e. Setting up your account.”)
2. In Martus, choose Tools > Export My Public Account ID, and name the file. Martus saves the file with
a .mpi (Martus Public Information) extension in your account directory in the Martus folder on your
hard drive by default (though you can also save it elsewhere on your computer if desired), and
confirms that it has been saved.
3. Give the .mpi file to the person using the other Martus account (either Headquarters or Field Desk). If
you can’t find your .mpi file on a Mac, see FAQ #48 (“Why can’t I find my Martus files on my
Mac?”).
4. Choose Help > View My Account Details.
5. Write down the public code.
6. Through a different, secure communications channel, give the same people the public code from your
account. It is important that the public code be communicated in a way that it cannot be altered, but it
need not be secret.
Note: For information on accessing field desk bulletins, see “6i. Retrieving bulletins created by field desks”
Instructions for Field Desk users who want to provide access to their bulletins to Headquarters (HQ)
users
Import the HQ public account ID and public code:
1. In Martus, choose Tools > Configure Headquarters.
2. Enter your username and password in the Martus Signin dialog box.
3. Click Add.
4. Select the .mpi file your Headquarters account gave you.
5. Enter the public code your Headquarters account gave you. Before continuing, confirm with your
Headquarters account that this really is the correct public code.
6. Click Yes to confirm that you want to grant this HQ account access to your public and private data.
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7.

8.

9.

Enter a label for the HQ account. Use a label that is meaningful to you, as you may not always
remember the account's public code. The HQ label might be the name of the person or organization, or
the name of a city or region, for example. You can change the label later if you want to. Only you will
see the label you assign; others who view the bulletin will not see the label, for security reasons.
Check the default box if you would like to share all new bulletins (and new versions of bulletins) with
this account by default. You can still deny access to individual bulletins as you create them (see
“Headquarters” section of “4a. Completing fields in a bulletin” for more information).
Click Save.

Note: For extra security and confirmation, you can also view a longer account identifier for your
Headquarters Accounts by selecting a Headquarters row, hitting the “View” button, and confirming
that the value you see in the “Public Account Id” field matches the value that your Headquarters
account sees for “Public Account Id” when they go to Help > View My Account Details.
Instructions for Field Desk users who want to update a group of bulletins to have a new
Headquarters account
If you have a new Headquarters account that does not have access to some of your old bulletins, you can
give them access to a group of your bulletins at once, instead of having to do so one-by-one. You can do
this “bulk” or “batch” Headquarters access update for multiple bulletins by selecting the desired bulletins,
and going to Edit > Update headquarters access. This option will be grayed out unless at least one bulletin
is selected and at least one HQ is configured. Martus will display a progress bar during the update and
allow you to cancel if desired. Draft bulletins will be updated to reflect the new HQ information. For sealed
bulletins, Martus will automatically generate a new sealed version of each bulletin.
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Instructions for Field Desk users who want to deny all future access to their bulletins to
Headquarters (HQ) users
Users of the Headquarters account will continue to have access to any bulletins you saved while permission
was given to their account. However, they will not have permission to view any future bulletins you save
once you deny them access.
To prevent access to all new bulletins, you can remove a HQ account from your configuration:
1. Choose Tools > Configure Headquarters.
2. Enter your username and password in the Martus Signin dialog box.
3. Select the HQ account you want to remove.
4. Click Remove.
5. Click Yes in the Confirm Removal of Headquarters dialog box.
Note: You can allow or deny access to individual bulletins without removing the Headquarters account
from your configuration (see “Headquarters” section of “4a. Completing fields in a bulletin” for more
information). We recommend using the steps above only when you want to permanently deny a
Headquarters account access to all future bulletins.
Removing the HQ account from your configuration will only prevent access to new bulletins (or new
versions of sealed bulletins). Old versions of previously saved sealed or draft bulletins will still be
accessible by HQ accounts configured when the bulletin was created. To revoke permission to view your
existing draft bulletins, resave the draft bulletins after you remove the Headquarters account.
Instructions for Headquarters (HQ) users who want to verify their Field Desk accounts
Import the Field Desk public account ID and public code:
1. In Martus, choose Tools > Configure Field Desks.
2. Enter your username and password in the Martus Signin dialog box.
3. Click Add.
4. Select the .mpi file your Field Desk account gave you.
5. Enter the public code your Field Desk account gave you. Before continuing, confirm with your Field
Desk account that this really is the correct public code.
6. Click Yes to confirm that you want to trust the content of bulletins that come from this Field Desk
account.
7. Enter a label for the Field Desk account. Use a label that is meaningful to you, as you may not always
remember the account's public code. The Field Desk account label might be the name of the person or
organization, or the name of a city or region, for example. You can change the label later if you want
to. Only you will see the label you assign; others who view the bulletin will not see the label, for
security reasons.
8. Click Save.

Note: For extra security and confirmation, you can also view a longer account identifier for your Field
Desk Accounts by selecting a Field Desk row, hitting the “View” button, and confirming that the value you
see in the “Public Account Id” field matches the value that your Field Desk account sees for “Public
Account Id” when they go to Help > View My Account Details.
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9g. Enabling other accounts to send your bulletins to a server
If you do not have the ability to connect to a server, you should have another account send your bulletins to
a server for you to safeguard the information in the bulletins. If you cannot backup your bulletins to a
server from your account, you will not be able to recover them if your computer is damaged or stolen. See
“1f. Why send bulletins to the server?” for more information.
When you set up a Headquarters account they can send bulletins to a server for you. That is, if a field desk
account does not have Internet access, its user can create bulletins in Martus and save them to a disk, and
then the Headquarters users can copy the files into their Martus Client and choose Server > Resend
Bulletins to send the selected bulletins to the server on behalf of the field desk. The field desk will still be
listed as the bulletin's author, and the Headquarters user cannot modify the bulletin.
Note: We recommend that Headquarters users create a separate folder for bulletins they send to the server
on behalf of their field desks or other Martus users.

9h. Changing your user name or password
You should change your password for security purposes if you feel your account has been compromised,
and can also change your username if you wish to.
1.
2.
3.

4.
5.

To change either your user name or password, choose Options > Change User Name or Password.
Enter your current user name and password on the Validate User screen.
Enter your new name and password on the next screen. You can change either or both fields. See “2e.
Setting up your account” for guidelines on user name and password creation. Hit OK to accept, or
Cancel to keep old username and password.
Repeat the new user name and password entry on the Confirm Password screen
You will then be prompted to back up your key with the new username and password. For more
information on backing up your key, see “9b. Backing up your key.”

See “9d. Using your password wisely” for additional information.
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10. Customizing Martus
You can customize certain aspects of your bulletins to save time, provide consistency, and ensure that
specific questions are addressed in every bulletin. You can customize the Details field, and you can create
additional bulletin fields. The customized fields appear in every new bulletin you create; they have no
effect on existing bulletins.

10a. Using a template in the Details field
If you frequently enter the same type of information in the Details field (such as number of victims or
government response), set up a template to appear in each bulletin you create:
1.
2.
3.

Choose Options > Default Details Field Content.
Type the text that should appear in the Details field by default.
Click OK.

When you create any new bulletins, the text you entered in the Default Details Field Content dialog box
appears in the Details section of the new bulletins. If you do not need the text in the bulletin you are
creating, you can delete it, as you would any other text. To remove the default content, click Reset Content
in the Details Field Default Content dialog box.
If you want to give default content for the Details field to other users or when setting up a new account
without needing to type it into Martus, you can also put the desired text in a file called DefaultDetails.txt,
and put it in the Martus account directory you want to use it.

10b. Customizing bulletin fields
Most Martus users find that the default bulletin fields meet their needs. However, some groups find it
useful to customize their bulletins to capture specific information such as the source of the bulletin data, the
names of witnesses, the country in which the incident occurred, or a table of information about victims.
Additionally, you may find it easier to import custom fields into other applications for reporting and
analysis. You can customize the bulletins you create by rearranging the fields, adding fields, or removing
fields you don’t need. You can customize the fields in the upper section of the bulletin (which can be either
public or private) and the lower section of the bulletin (which is always private.) You can create several
kinds of custom fields, including Yes/No, date, date range, drop-down lists, grid (table), language,
messages (notes), single line text, and multi-line text fields.
After you customize bulletin fields, the new field arrangement will appear in every new bulletin you create;
customizing fields has no effect on your existing bulletins or on bulletins you download from the server.
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Custom fields may be displayed in the Martus Search Engine so if your custom fields contain confidential
information, make sure your bulletin is set to have all data private.
You can either create your own customization format, or use a template created previously (by you or one
of your Headquarters accounts). See section “10c. Using Customization Templates” for directions on
importing or exporting customization templates.
To create or update a customization format:
1. Choose Options > Customize Fields.
2. Read the informational dialog box. If you want to proceed, click Yes.
3. Rearrange, add, or remove field tags in the Customize Fields dialog box.
The layout of the fields in a bulletin is dictated by an XML document. The document must begin with
<CustomFields> and end with </CustomFields>. When you open the Customize Fields dialog box,
these tags are already in place. By default, the standard bulletin fields occur at the top of the Custom
Field declaration, but you can move them if you wish. However, you cannot remove the 'author',
'entrydate', 'language', and 'title' fields.
a) To re-order fields, cut and paste them into the order you want them to appear.
b) To add a field, click an insertion point where you want the field to appear. Enter the type of field
you want to use: BOOLEAN, DATE, DATERANGE, DROPDOWN, GRID, LANGUAGE,
MESSAGE, MULTILINE, SECTION or STRING. Each field must have a unique tag, which can
be any single word except those already used by the system, in any language, and cannot contain
spaces, special characters, or punctuation. For example, you could use 'VictimsName' or
'EyeColorChoice'. Each field should be given a label, which is what will appear next to the field
in the bulletin; it can contain any characters in any language except certain special characters (e.g.,
< and > which are used by the system). For example, you might use 'Name of 1st Witness.' See
the examples below.
c) To remove a field, delete the field definition text (type, tag, label) for the field you want to
remove. You cannot remove certain required fields, including the author, title, language, and entry
date.
d) You can create sections (which you can hide/unhide) in your bulletins using a SECTION field
type. Sections can include as many individual fields as you like.
e) You can put multiple fields on a single row in your bulletin by using <KeepWithPrevious/> in the
field definition.
f) You can require certain fields or grid columns to be entered before saving a bulletin by using
<RequiredField/> in the field definition.
g) You can restrict date fields, date grid columns, date range fields, and date range grid columns by
using <MinimumDate> and/or <MaximumDate> tags with a date in YYYY-MM-DD format. A
blank date (shown as <MaximumDate></MaximumDate> or <MaximumDate/>) means 'today',
although it may allow one day earlier or later, due to time zone issues. Please note that you can
require date validation of standard fields as well as custom fields. Date field Year dropdown
choices will reflect the hard-coded date ranges specified in the customization. Note: The year
format in the customization must always be a 'Gregorian' year like 2009, even if Martus is
configured to use Thai or Persian dates.
h) You can populate drop-down lists (either inside or outside of a grid) in 3 ways - 1) by entering a
list of <Choices> values in the field definition, 2) with values that have been entered in a grid
elsewhere in your bulletin by using <DataSource> (sometimes called “data-driven dropdowns”),
and 3) by creating lists of "Reusable Choices" that can be referred to by more than one field. See
examples below for the correct XML definition syntax to use. Please note that in this release,
Martus will not include data-driven dropdown fields in the Search screen.
i) You can set a default value for text and dropdown list fields by using
<DefaultValue>ddd</DefaultValue>, where “ddd” is the value you choose. For dropdowns, you
must use a value already in the list of choices you defined. For Reusable Choices dropdowns it can
be a partial or complete code, with each level separated by dots (for a location dropdown that has
both Region and City levels, you could pick the default to be at either level, e.g. either R1 or
R1.C1, see example below). Default values can be set for both standard and custom fields, but are
NOT allowed for BOOLEAN, DATE, DATERANGE, GRID, LANGUAGE, MESSAGE, and
SECTION field types, and are not allowed for dropdowns where the values in the list are based on
data entered in another field (i.e. data-driven dropdowns).
4. Click OK.
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Keep the following in mind when you're customizing fields:
1. XML is case-sensitive. (For example, "Witness" is not the same as "witness.")
2. You can use either single or double quotes around the field type name, as long as they match. (e.g.
'STRING" is not valid. It needs to be 'STRING' or "STRING")
3. A BOOLEAN field will appear as a checkbox when you are editing a bulletin, and will be displayed as
Yes/No in bulletin previews and when printed.
4. Both STRING and MULTILINE fields are text fields. STRING fields will expand to fit the size of the
text you enter, while MULTILINE fields have a scrollbar so that the field doesn’t exceed its original
height.
5. Use MESSAGE fields to give guidance on how to enter data, and to create comments/notes that will be
displayed in every bulletin.
6. When you're entering data into a grid, press Enter to create a new line, press Tab to advance to the next
cell, and double-click to copy and paste text.
7. A GRID can contain columns of various types: BOOLEAN, DATE, DATERANGE, DROPDOWN,
and STRING.
8. You may need to provide guidance to other users by giving them a customization template. To
minimize the need for further instruction, use labels that clearly identify the content (such as "Name of
Victim"). For more information on exporting customization templates, see section “10c. Using
Customization Templates.”
9. Please make sure to change your field tags if you change the field label or field type when you edit
your customizations, because using the same tag for different labels can cause confusion when
searching or reporting on those fields. The only case in which you can keep the same tag when
changing a label is if you really want the different labels to be counted as exactly the same (e.g. you
are just fixing typos in the labels).
10. Please note that default values are only applied when a new bulletin is created, not when a new version
of a bulletin is created, so that the value of the field in the previous version is not overwritten. This
means that default values entered in a bulletin using an earlier customization will be kept even if you
create a new version of the bulletin with an updated customization that has a new default value.
Special Notes on “Reusable Choices” (multi-level, nested) dropdown lists
11. Dropdowns using a "Reusable Choices" list can have multiple levels (e.g. for locations that might have
Region and City), different fields can use one or more of the levels (e.g. if you have defined Region
and City levels, you could have a field that just uses the Region level, and another field that uses both
levels), and you do not need to define all levels for all entries (e.g. you could have defined
Neighborhood values as a lower level for some larger Cities, but not all Cities need to have
Neighborhoods defined). The number of levels is not limited by Martus, but please note that if you
have large amounts of data in your definitions lists, or a large number of levels, performance of certain
Martus bulletin operations may be affected.
12. In this release, we recommend that if you want to change the number of levels in a “Reusable Choices”
dropdown field when updating a customization, you also change the field tag and/or label so that they
are more easily distinguished from each other in searching and reporting. If you do not, the
search/report results may be confusing since fields with the same label/tag will be treated differently
due to them having a different number of levels.
13. “Reusable Choices” codes have the same restrictions that field tags do; they can be in any language,
but cannot contain spaces, special characters, or punctuation.
14. Please make sure to not use the same codes in “Reusable Choices” lists if you edit your customizations
unless you are just fixing typos in the labels, because using the same code for different labels can cause
confusion when searching or reporting on those fields. Ideally you should use codes that are not
numeric, but are letters that are a meaningful abbreviation of the label so there is no confusion over
what they stand for if you update the customization at a later date (e.g. use 2 or 3 letter abbreviations
for locations instead of numbers). See section “11. Frequently Asked Questions” (FAQ), #46 for more
information about how code and label choices can affect searching on these fields.
15. You cannot use a multiple level / “Reusable Choices” dropdown as a data source for another dropdown
inside or outside of grids. If you try to do this you will see an error message.
16. Please note that when you save customization XML with a “Reusable Choices” list for dropdown
fields, Martus will move those choice definitions to the bottom of the XML when you reload it.
17. Martus doesn't automatically insert a blank entry for Reusable Choices dropdown lists the way it does
for other dropdowns. If you want to be able to select “blank” for the top level of a Reusable Choices
dropdown (or a single level Reusable dropdown), you need to explicitly add a blank entry in your
customization XML (by adding “<Choice code='' label=''></Choice>” to the top level ONLY of the
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Reusable Choices list). If you do not do this, and have not specified a default value (which will mean
you will never see blank as an option), the dropdown list will start with the blank entry, but once you
pick another value, you will not be able to go back to the blank option.
Here are some examples; these fields would look like the ones in the figure that follows:
<Field type='SECTION'>
<Tag>SourceSection</Tag>
<Label>Source Section</Label>
</Field>
<Field type='STRING'>
<Tag>office</Tag>
<Label>Regional office collecting the data</Label>
<DefaultValue>Region 3 field office</DefaultValue>
</Field>
<Field type='DROPDOWN'>
<Tag>BulletinSource</Tag>
<Label>Source of bulletin information</Label>
<RequiredField/>
<Choices>
<Choice>Media/Press</Choice>
<Choice>Legal Report</Choice>
<Choice>Personal Interview</Choice>
<Choice>Other</Choice>
</Choices>
<DefaultValue>Media/Press</DefaultValue>
</Field>
<Field type='STRING'>
<Tag>SpecifyOther</Tag>
<Label>If Source = "Other", please specify</Label>
</Field>
<Field type='STRING'>
<Tag>IntervieweeName</Tag>
<Label>Interviewee Name</Label>
</Field>
<Field type='LANGUAGE'>
<Tag>IntervieweeLanguage</Tag>
<Label>Interviewee Speaks</Label>
</Field>
<Field type='DATERANGE'>
<Tag>InterviewDates</Tag>
<Label>Date(s) of interview(s)</Label>
</Field>
<Field type='BOOLEAN'>
<Tag>Anonymous</Tag>
<Label>Does interviewee wish to remain anonymous?</Label>
</Field>
<Field type='BOOLEAN'>
<Tag>AdditionalInfo</Tag>
<Label>Is interviewee willing to give additional information if needed?</Label>
<KeepWithPrevious/>
</Field>
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<Field type='BOOLEAN'>
<Tag>Testify</Tag>
<Label>Is interviewee willing to testify?</Label>
<KeepWithPrevious/>
</Field>
<Field type='DROPDOWN'>
<Tag>EventLocation</Tag>
<Label>Event Location</Label>
<UseReusableChoices code='RegionChoices'></UseReusableChoices>
<UseReusableChoices code='CityChoices'></UseReusableChoices>
<DefaultValue>R1</DefaultValue>
</Field>
<Field type='SECTION'>
<Tag>PeopleSection</Tag>
<Label>People Section</Label>
</Field>
<Field type='GRID'>
<Tag>VictimInformationGrid</Tag>
<Label>Victim Information</Label>
<GridSpecDetails>
<Column type='STRING'><Tag></Tag><Label>First Name</Label></Column>
<Column type='STRING'><Tag></Tag><Label>Last Name</Label></Column>
<Column type='BOOLEAN'><Tag></Tag><Label>Is Identified?</Label></Column>
<Column type='DATE'><Tag></Tag><Label>Date of Birth</Label>
<MinimumDate>1910-01-01</MinimumDate><MaximumDate/></Column>
<Column type='DROPDOWN'><Tag></Tag><Label>Sex</Label>
<RequiredField/>
<Choices>
<Choice>Male</Choice>
<Choice>Female</Choice>
<Choice>Unknown</Choice>
</Choices>
</Column>
<Column type='DROPDOWN'><Tag></Tag><Label>Region of Birth</Label>
<UseReusableChoices code='RegionChoices'></UseReusableChoices></Column>
<Column type='STRING'><Tag></Tag><Label>Ethnicity</Label></Column>
</GridSpecDetails>
</Field>
<Field type='MESSAGE'>
<Tag>MessageProfession</Tag>
<Label>Profession History Table Note</Label>
<Message>If you have information about a person who has had different professions over time, enter
multiple rows with the same First and Last Names and show the date ranges for each profession on a
separate row.</Message>
</Field>
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<Field type='GRID'>
<Tag>ProfessionHistoryGrid</Tag>
<Label>Profession History</Label>
<GridSpecDetails>
<Column type='DROPDOWN'><Tag></Tag><Label>First Name</Label>
<DataSource>
<GridFieldTag>VictimInformationGrid</GridFieldTag>
<GridColumnLabel>First Name</GridColumnLabel>
</DataSource>
</Column>
<Column type='DROPDOWN'><Tag></Tag><Label>Last Name</Label>
<DataSource>
<GridFieldTag>VictimInformationGrid</GridFieldTag>
<GridColumnLabel>Last Name</GridColumnLabel>
</DataSource>
</Column>
<Column type='STRING'><Tag></Tag><Label>Profession</Label></Column>
<Column type='DATERANGE'><Tag></Tag><Label>Dates of
Profession</Label><MaximumDate/></Column>
</GridSpecDetails>
</Field>
<Field type='MULTILINE'>
<Tag>narrative</Tag>
<Label>Narrative description of events</Label>
<DefaultValue>What happened in detail is as follows:</DefaultValue>
</Field>
<ReusableChoices code='RegionChoices' label='Region'>
<Choice code='R1' label='Region 1'></Choice>
<Choice code='R2' label='Region 2'></Choice>
<Choice code='R3' label='Region 3'></Choice>
</ReusableChoices>
<ReusableChoices code='CityChoices' label='City'>
<Choice code='R1.C1' label='City 1'></Choice>
<Choice code='R1.C2' label='City 2'></Choice>
<Choice code='R2.C3' label='City 3'></Choice>
<Choice code='R2.C4' label='City 4'></Choice>
<Choice code='R3.C5' label='City 5'></Choice>
<Choice code='R3.C6' label='City 6'></Choice>
</ReusableChoices>
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Note: If you receive an error after you click OK, you must correct the problem before you can proceed. The
error message should identify the problem, but if you are not sure what caused the error check the
following:
- Ensure that the author, language, entrydate, and title fields are present.
- Remove any labels you created for standard field tags.
- Remove any tags that are repeated.
- Ensure that each custom field you created has a corresponding label.
- Make sure that all text in brackets and quotes has both a start and end bracket/quote.
- Ensure that the top and bottom panes in the customization screen both start with <CustomFields>
and end with </CustomFields>.
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Note: You can update your customization if the information you are collecting over time changes, for
example by adding new fields. If you are changing fields in a customization, you should think about how
you will want to search/report on bulletins created with the old customization as well as new bulletins you
create with the new customization, and try to make the changes so that you can search/report on all
bulletins at the same time. Changing field types may cause your searching/reporting to be more complex,
so we always recommend that you test out creating bulletins with a new customization and
searching/reporting on both old and new bulletins before officially updating the customization for your
project. For more details on this, see section “11. Frequently Asked Questions” (FAQ) #36.
To restore the default/standard bulletin fields:
1. Choose Options > Customize Fields.
2. Click OK in the informational dialog box.
3. Click Restore Defaults.
4. Click Yes to verify that you want to restore the default fields.
5. Click OK to close the Customize Fields dialog box.

10c. Using Customization Templates
Martus provides the ability for a Headquarters account to export customization templates to give to field
users, or users to export their own templates. Users can then import customization settings from a choice
of templates. This allows users to use different custom bulletin formats for different types of data sets.
Note: Customization templates exported by a Martus account may only be used by that account, or shared
with field accounts that have the exporting account configured as a Headquarters account.
Instructions for exporting customization templates
1. Choose Options > Customize Fields.
2. Click OK in the informational dialog box.
3. Enter the XML representation for the layout of the template (see “10b. Customizing bulletin fields” for
more information).
4. Click Export Template.
5. Enter a name for the template file. Martus saves the file with a .mct (Martus Customization Template)
extension in your account directory in the Martus folder on your hard drive, and confirms that it has
been saved. You can also save the file to another location if desired.
Note: If you are using multiple templates, we recommend choosing descriptive filenames for each
template.
6.

If you want to share the customization template with field users who have you configured as a
Headquarters account, give them your .mct file.

Instructions for field users who want to access (import) customization templates
1. Choose Options > Customize Fields.
2. Click OK in the informational dialog box.
3. Click Import Template.
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4.

Select the file exported by you or your Headquarters account.

Note: If you try to import a template created by an account that is not one of your Headquarters accounts
(or your current account), Martus will not allow you to load the template.
5.
6.

Click OK in the confirmation dialog box.
After you import a customization template, the new field format will appear in every new bulletin you
create. See “10b. Customizing bulletin fields” for information on restoring the default/standard Martus
field format.
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10d. Customizing your bulletin display
There are various alternate display options for bulletins (see examples in screenshot below):
- To hide fields to save space (e.g. for long text fields, or Message fields) while editing or viewing a
bulletin: click on the - button next to the field label. To unhide the field again to see its contents,
click on the + button next to the field label. Martus will display all bulletins with matching fields
the same way, until you exit Martus.
- To hide entire sections while editing or viewing a bulletin: click on the - button next to the
section label. To unhide the section again to see its contents, click on the + button next to the
section label. Martus will display all bulletins with matching sections the same way, until you exit
Martus.
- You can choose whether to display or edit Grid fields in the standard table view, or “expanded
view” (useful if you have very wide columns or a large number of columns, that would cause you
to have to scroll back and forth in the regular Grid view.) You can add “rows” to the bottom of
your grid in expanded view by hitting the “Append Row” button. Martus will display all bulletins
with matching grid fields the same way, until you exit Martus.

Note: If you have a lot of your bulletin data in grids, and especially if you have a lot of bulletins, doing
data entry and viewing/displaying the bulletin grids in expanded view (instead of grid/table view) can make
Martus perform more slowly. If you are noticing slowness, try setting any grids in expanded view back to
grid view.
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11. Frequently Asked Questions
1. I’ve saved a bulletin, but the word "Yes" hasn't appeared in the Sent column.
Ensure you have an active Internet connection, and that you’ve set up a server. Bulletins are not listed as
sent until they have been successfully sent to the server. Bulletins may also take up to an hour to send if
you are sending a large attachment, or if the connection is slow. While Martus is sending the bulletin, it
displays a progress meter in the status bar at the bottom of the screen. Additionally, when you connect to a
server, there may be a delay before the Sent column is populated.
2. Martus won’t accept my password.
Make sure you’re entering the correct user name and password, especially if you changed the password
recently. Your user name and password are case-sensitive. Make sure you’re entering capital letters, as well
as spaces and punctuation, exactly as you entered them when you created the username and password. Each
time you enter an incorrect username or password, the system delays for a longer period before displaying
the Martus Signin dialog box again. Since Martus does not store your password anywhere, and it uses
strong encryption, there is no way to get access to your account without your username and password
unless you have performed a multi-file key backup (see “9b. Backing up your key” for more information).
3. I want to use Martus on a co-worker’s computer, but it won’t accept my username/password.
You can access Martus only on a computer that contains your key file. Your username and password
activate your key, which may not be present on your co-worker’s computer. Using Martus 1.5 and later,
there can be multiple accounts on a single computer, but your key must be available on that computer for
you to access it. To access your account on your co-worker’s computer, click the Restore Account tab in
the Martus Signin dialog box, and then use your backup key file to create the account. And, though you can
install your key on more than one computer at a time, remember that you need to update each key if you
change your password, and that your data is only as secure as the least secure computer on which you have
your account.
4. The bulletins in my account on a co-worker’s computer do not match those on my computer.
If you have set up your account on multiple computers, you can’t access your draft or sealed bulletins from
a different computer unless they were saved to the server and retrieved to the current computer. If you
overwrite a draft on the server from one computer, the version on the server will not match the version on
the other computer because the server saves the last version of the draft. To retrieve the most recent draft
from the backup server, you will need to delete any older drafts from your computer. If you want to keep a
backup copy of the older draft, you can drag the bulletin to your desktop before deleting it. If you delete a
draft from one computer and from the server, it will still be on the other computer. On that other computer,
if you modify the draft, it will re-send it to the server, but if you never modify the draft, it will never get resent.
5. There are multiple Martus accounts on my computer. How can I tell which account folder is
mine?
Log in to Martus using your username and password. Then choose Help > View My Account Details. The
folder Martus uses to store the information for your account is listed below your public code. The first
user's account is in the Martus folder; additional accounts are in subfolders in the Martus folder.
6. I’ve saved a sealed bulletin, but I need to make a few changes to it.
Once you’ve sealed a bulletin—whether or not you've sent it to the server, neither you nor anyone else can
ever edit the original bulletin again. However, if you have information to add to a sealed bulletin, or need to
make an important correction, you can create a new version of the bulletin (see "5c. Creating a new version
of a sealed bulletin") and send it to a server. Both the original version and the new version will then be
available on your computer and the server.
7. When I try to retrieve bulletins from the server, the ones I want are not listed.
By default, the Retrieve Bulletins dialog box does not list bulletins that are already present on your
computer, because you cannot download those bulletins. To see all your bulletins on the server, whether
they’re on your computer or not, check “Show all bulletins on this server and on this computer.” You may
also want to search the bulletins on your computer; it’s possible that the bulletin you’re looking for hasn’t
been sent to the server.
Martus 4.3 User Guide

82

8. How can I open an attachment?
If you are using Windows, you can view an attachment without saving it to your hard drive: click View
Attachment. Depending on the file type, the attachment will either be displayed inside Martus, or the
application associated with the attachment’s file type opens the attachment. (You can change the file type’s
association in Windows Explorer.)
If you are using Mac OS or Linux, or if you want to save the attachment to your hard drive in Windows,
click Save. Save the file to any location on your computer, and then open the file in an application that can
read the file’s format. For example, if a .doc file is attached, open the file in Microsoft Word. If a .pdf file
is attached, open the file in Adobe Acrobat Reader.
9. I deleted a bulletin from the Discarded Bulletins folder, but it still appears in another folder.
Discard the bulletin from all folders before you delete it from the Discarded Bulletins folder.
10. Can I back up my Martus data onto a floppy disk or tape drive?
Yes, if you have a backup device large enough to hold all your data. Copy the entire Martus folder onto
your backup media. This folder contains the Martus application, the Java runtime environment, encrypted
key files, configuration data, and bulletins for all Martus accounts on the computer. For a minimal backup,
copy only the MartusKeyPair.dat file and the Packets and Accounts folders from your account directory.
11. Why are there more languages available when creating bulletins than in the Signin screen or
Options dialog box?
The Options dialog box lets you choose a language for the Martus software user interface. Martus has been
translated into several languages. Visit https://www.martus.org to see which languages are currently
available, including any language packs that have been added since the latest Martus release. If you are
interested in translating Martus into another language, please contact us at info@martus.org.
As you noticed, there are several languages available in the Language drop-down list when you create a
bulletin. That option specifies the language you use to enter the data into your bulletin. You do not need to
type the bulletin in the same language used in your user interface.
12. Why does Martus seem slow when I’m doing some tasks?
In early versions of the application, we focused on adding features and security. In recent versions, we have
added some performance improvement for very large accounts (with over 1000 bulletins.) We will
continue to work on performance improvements in future versions.
Some suggestions for dealing with slow performance are below:
a)

Martus will manipulate bulletins (e.g., sorting, copying/pasting) more efficiently if they are not all in
one folder. Consider using separate folders for bulletins from different weeks, by different authors, or
related to different topics. Additionally, select a folder with few bulletins before exiting Martus.
When you start Martus, it opens the last folder you viewed; if there are fewer bulletins in that folder,
Martus will start more quickly.

b) If you have a lot of your bulletin data in grids, and especially if you have a lot of bulletins, doing data
entry and viewing/displaying the bulletin grids in expanded view (instead of grid/table view) can make
Martus perform more slowly. If you are noticing slowness, try setting any grids in expanded view
back to grid view.
c)

Martus may also seem slow (especially when retrieving bulletins, or performing other complex tasks)
if your computer doesn't have enough memory allocated to Martus. If memory is the issue, the console
log (see section “11. Frequently Asked Questions” (FAQ) #17) typically returns the error “Out of
Memory.”
To resolve memory issues in Windows, change the command line in the desktop shortcut (right-click,
and choose Properties) to the following:

C:\Martus\bin\java.exe -Xms512m -Xmx1024m -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar
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Save by hitting OK, and then double-click the updated shortcut to start Martus.
To resolve memory issues in Mac (if installed with a DMG), do the following:
 Right-click on the Martus icon (.app file), pick “Show Package Contents”, and double-click
on Contents folder
 Right click on info.plist and pick Open With. If you see TextEdit on the list, pick it;
otherwise select “Other” and the Applications folder will open and you can scroll down to
select TextEdit. Hit Open.
 Towards the bottom, you should see something that looks like this:
<key>VMOptions</key>
<string>-Xms256m –Xmx512m -Xbootclasspath/p:Contents/Resources/Java/ThirdParty/bcjce.jar</string>
 Change “ -Xms256m -Xmx512m” to “-Xms512m -Xmx1024m” so that the whole thing
now looks like this:
<key>VMOptions</key>
<string>-Xms512m -Xmx1024m -Xbootclasspath/p:Contents/Resources/Java/ThirdParty/bcjce.jar</string>
 Close the file, saving the changes if asked. And Close the Contents folder.
 Make sure the console is running still, and then double-click on the Martus icon (.app file) to
run Martus.
This will allow Martus to get more memory than it does by default when installed, and will also turn
on logging so that if there is a problem we can tell what it might be. The values of the memory
switches (512 and 1024) are suggestions, but the best value is dependent on your computer's setup, so
you may be able to optimize this setting. For a more specific recommendation, send information about
your computer (how much memory or RAM is installed, how much swap or page file space is
available, etc.) to help@martus.org. In Windows, you can find this information by choosing Start >
Programs > Accessories > System Tools > System Information. In Mac, go to the Apple menu >
About this Mac > More info… > System report… > Hardware (this is the Hardware Overview). If the
pagefile is small, you may want to try to increase it.
d) There is an additional way to speed up Martus loading and navigation when an account has a large
number of bulletins. You can tell Martus not to sort the bulletins in your folders in Martus when you
initially load them (since sorting can take time with a lot of bulletins.) You can always click on a
column header in the bulletin preview list to sort the folder if desired, but including this option will
save time on startup and on entering new folders in Martus. To set Martus to run with this option in
Windows, change the command line in the desktop shortcut (right-click, and choose Properties) to the
following:
C:\Martus\bin\java.exe -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar --folders-unsorted

Save by hitting OK, and then double-click the updated shortcut to start Martus.
To start Martus with unsorted folders in Mac (if installed with a DMG), do the following:
 Right-click on the Martus icon (.app file), pick “Show Package Contents”, and double-click
on Contents folder
 Right click on info.plist and pick Open With. If you see TextEdit on the list, pick it;
otherwise select “Other” and the Applications folder will open and you can scroll down to
select TextEdit. Hit Open.
 Towards the bottom, you should see something that looks like this:
<key>Arguments</key>
<string> </string>
 Add “--folders-unsorted” so that it looks like
<key>Arguments</key>
<string>--folders-unsorted</string>
 Close the file, saving the changes if asked. And Close the Contents folder.
 Make sure the console is running still, and then double-click on the Martus icon (.app file) to
run Martus.
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Note: You can combine the memory and unsorted folders options in b) and c) above for even faster
loading if desired. If you want to do this in Windows, the Martus command in your Desktop Shortcut
would look like this:
C:\Martus\bin\java.exe -Xms512m -Xmx1024m -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar --foldersunsorted

13. I don’t have a Martus shortcut on my desktop or in my Start menu. How can I start Martus?
Martus always installs a shortcut in your Martus directory, which you can use to start Martus. Or, use one
of the following methods, depending on your operating system:
In Windows, open a DOS prompt, change to the Martus directory, and type
C:\Martus\bin\javaw.exe -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar
to start Martus.
In Mac OS,
a) If you installed with a DMG (recommended) and it is still loaded/extracted on your machine, click on
it (may show up under “Devices” in Finder), and then double-click on the Martus icon (,app) file. If the
DMG isn’t loaded, double-click on the DMG file, then follow the step above.
b) If you installed from a zip or CD/ISO File, open a Terminal window, go to the /Library/Java/Martus
folder, and start Martus from the command line by typing:
Java -Xbootclasspath/p:ThirdParty/bc-jce.jar -jar martus.jar
In Linux, start Martus from the command-shell line, by typing
java -Xbootclasspath/p:<Martus program directory>/ThirdParty/bc-jce.jar -jar <Martus program
directory>/martus.jar
See Linux portion of section “2a. Installing” for examples.
14. The Martus Welcome dialog box is slow to appear.
Depending on your computer system, there may be a delay of several seconds between the time you
double-click the Martus icon and the time the Martus logo splash screen and Welcome dialog box appear.
Exactly how long it takes depends on the speed of your computer.
15. Can I customize my screen by changing the colors or saving changes to the screen layout?
In this version of Martus, you cannot save all changes to the screen layout though Martus does remember
certain settings on a particular computer (such as bulletin preview list column sorting). However, if you’re
using Windows or Mac, Martus uses your system colors. If you select a different color scheme for your
operating system, it will affect Martus, too. To change the system colors in Windows, right-click your
Windows desktop, choose Properties, and select the Appearance tab. Then select the color scheme you
want to use.
You can customize the fields in bulletins you create, as well. See “10b. Customizing bulletin fields” for
more information.
16. When I start Martus, the screens are all gray with no text visible.
This may indicate a problem with your video driver. Try installing an updated video driver, which may be
available from the manufacturer’s website. If you cannot get access to an updated driver or you still see this
problem, try setting Martus properties to use 256 color (instead of 16 or 32 bit color) in Windows XP, or
using 256 color under Control Panel Display Settings for Windows operating systems older than Windows
XP. Alternatively, you may be able to fix the problem by reducing the graphics acceleration setting in your
video driver. For additional assistance, email help@martus.org .
17. I’m seeing unexpected behavior in Martus. How can I find out what’s going on?
Below are instructions to open a "console log" that displays additional information as Martus runs. This
information is helpful to us in diagnosing problems.
In Windows, to always run with the console log, right-click on the Martus icon on your desktop, select
Properties, select the Shortcut tab, delete the "w" from “javaw.exe” in the Target command line, and click
OK. You can also create a copy of the default Martus desktop shortcut and make that change so the
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console will run when clicking on it, but please note that if you do this, the copied shortcut will not be
removed when uninstalling Martus, which may be a security concern.
Another option is, instead of starting Martus by double-clicking the Martus icon on your desktop, choose
Run from the Start menu and type the following text to launch Martus:
C:\Martus\bin\java.exe -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar
Save by hitting OK, and then double-click the updated shortcut to start Martus.
Note the console log messages you receive as you work in Martus, and e-mail those to help@martus.org.
To copy and paste the console messages into an email, please do the following:
 Right-click in the blue window title at the top of the console log window. From the menu which
appears, select "Edit." (The "Edit" option is listed just below "Close" in the menu, so be careful not to
accidentally close the console log window which will also cause Martus to exit.)
 From the subsequent menu, choose "Select all" - this will highlight all of the console log text in white.
 Then, hit "Enter" on the keyboard. This will copy the console log contents to the 'clipboard' of your
computer.
 Paste this, using Ctrl-V or right-clicking and choosing "Paste", either directly into an email or into a
file using a text editor that you attach to an email to help@martus.org.
In Mac, with a DMG install, to display additional information as Martus runs that will be helpful in
diagnosing any problems, you can run the "Console" application. Launch it in one of two ways:
a) Inside your Applications folder, find the Utilities folder, and double-click on Console.
b) Hit Command-Space to bring up the search, enter "console", and when it finds the Console app, launch
it.
As long as the console is running, any troubleshooting or logging information from Martus will appear
there. You only have to run console once, and then you can run (and stop) Martus as many times as you
want. You can copy and paste the text from the Console app into an email to help@martus.org.
Note: To see only Martus info in the console and exclude any console info from other programs, type
“.Martus” (without the quotes) in the search box at the top right of the console screen.
In you are running in Mac, but not from a DMG install, open a Terminal application window, go to the
/Library/Java/Martus folder, and start Martus from the command line by typing: Java Xbootclasspath/p:/Library/Java/ThirdParty/bc-jce.jar -jar martus.jar
Then note the error messages you receive as you work in Martus, and e-mail those to help@martus.org. To
copy and paste the messages into an email please do the following:
 Use the mouse to highlight all the text in the Terminal window.
 Either right-click and select "Copy", hit Command+C (also known as Apple key+C) or go to the
Terminal menu bar and select Edit > Copy
 Paste this, either by right-clicking and choosing "Paste", hit Command+V (also known as Apple
key+V) or go to the Terminal menu bar and select Edit > Paste. You can paste either directly into an
email or into a file using a text editor that you attach to an email to help@martus.org.
In Linux, start Martus from the command-shell line, by typing
java -Xbootclasspath/p:<Martus program directory>/ThirdParty/bc-jce.jar -jar <Martus program directory>/martus.jar

See Linux portion of section “2a. Installing” for examples.
Then note the error messages you receive as you work in Martus, and e-mail those to help@martus.org.
If the log doesn’t help us identify the problem, the issue may be caused by damaged fonts. Damaged fonts
may prevent Martus from starting. To determine whether a damaged font is causing the problem, run
Martus with the console log (see above), and check to see whether the word "font" appears in the console
messages at all. If so, it is likely that damaged fonts are causing the problem. To fix this problem in
Windows, copy all of the contents of C:\Windows\Fonts to a temporary location, then delete all of the
contents from C:\Windows\Fonts. Then, copy all of the contents back into that folder from the temporary
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location. This process will reinstall all of the fonts and, in the process, detect any corrupt/damaged fonts.
Once the damaged fonts have been identified, manually delete them from C:\Windows\Fonts.
For additional assistance, email help@martus.org
18. Is there any limit to the size of bulletins or attachments I can send to the server, or to the number
of bulletins I can store there?
No, currently there are no limits for the amount of data, the number of bulletins, or the size of attachments
you can send to a Martus Server. However, it's possible that there may be limits on certain servers in the
future. If you send very large attachments (e.g. video) to the server just be aware that it will take longer
than sending smaller amounts of data.
19. Can I share my private data with a colleague?
Yes, you can share private data using a Headquarters account. Any account can serve as a Headquarters
account, and two accounts can serve as Headquarters accounts for each other if they want to access each
other's data. To set up a Headquarters account, follow the instructions in "9f. Sharing your private data with
colleagues"
20. Can I get the Martus User Guide in a different language?
Yes. In fact, you probably already have multiple versions on your computer. When you install Martus, all
the language versions of the user guide and quick start guide that are currently available are installed in
your Martus\Docs directory. They are also available at https://www.martus.org/downloads, and you can
visit this site to see whether new language versions are available. Additionally, there may be language
packs available at that same page on Martus web site. A language pack can contain updated versions of the
Martus Client user interface translation, the User Guide, the Quick Start Guide, the Readme file, and inprogram help in a particular language.
21. I can't see all the text in drop-down lists in the Arabic version of Martus. How can I fix this?
When you run the Arabic version of Martus in Windows XP, text in drop-down lists may not align
correctly. To see the text as expected, set Windows to display user interface elements in "Windows classic
style." From the Start menu, choose Settings > Control Panel. Then, double-click Display. In the Display
Properties dialog box, click the Appearance tab, and choose Windows Classic Style from the Windows And
Buttons menu.
22. How can I make accents appear correctly when I open a Martus bulletin or report in another
application?
Web browsers or word-processing applications may not display accents correctly in bulletins or report files
that you save from Martus. To ensure that accents appear, specify UTF-8 (Unicode) font/character
encoding. If you do not know how to do this in the application, please email help@martus.org for
assistance.
23. I’m having problems connecting to the server. What should I do?
If Martus reports that the server isn’t available or that you can’t connect, first try to “ping” the server
(which tells you what your connectivity is like to this server). To ping the server, open a command prompt
window in Windows (or a Terminal window in Mac) and type
ping server-ip-address
(where server-ip-address is the same address you entered when you set up the server), and then press
Return.
Then, try to “tracert” the server (which will tell you what the route is between your computer and the
server.) To tracert the server, in the command prompt window in Windows (or the Terminal window in
Mac), type
tracert server-ip-address
and then press Return.
Email the results of the ping and the tracert that appear on your computer to help@martus.org and
serverinfo@martus.org. Be sure to mention that you can’t connect to the server through Martus and tell us
the date and time of day that you tried (please also include your timezone.) We’ll determine the nature of
the problem and work with the server administrator to resolve it.
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24. I see boxes instead of text in the menus when I run the Nepali version of Martus. How can I fix
this?
To run Martus in Nepali for version 2.7.2 and earlier in Windows, you must make a minor modification to
the command used to start Martus (from the command prompt, and in any desktop/Start Menu shortcuts or
aliases that were created when you installed).
To run from the command line, go to your Martus directory and type:
C:\Martus\bin\javaw.exe -Dswing.useSystemFontSettings=false -jar C:\Martus\martus.jar
To change your shortcuts, right-click on them, choose Properties, and change the Target command to:
C:\Martus\bin\javaw.exe -Dswing.useSystemFontSettings=false -jar C:\Martus\martus.jar
For Martus 2.8 and later, this modification is done automatically, so if you are having issues with the
display, email help@martus.org.
25. I want to upgrade to a new version of Martus. Do I need to remove the old version first?
No. You can install Martus over an existing version of the software. The installer will notify you that an
older version exists. Click Yes to upgrade Martus without losing any of your data, including bulletins,
account information, server configurations, or passwords. For more information, see "2c. Upgrading to a
new version of Martus (Windows only)"
26. Martus runs slowly on my laptop unless it’s plugged in.
Some laptop computers or their graphics cards have settings intended to preserve the battery life when the
laptop is not plugged in, and those settings may not provide enough power for Martus to work as expected.
See the documentation for your laptop and graphics cards for information about changing settings. For
additional assistance, email help@martus.org.
27. When I back up or restore my key using USB drives, Martus doesn’t recognize them as different
disks. What’s going on?
When you first insert a USB (“thumb drive”), the operating system assigns it a drive letter; each drive is
assigned a different drive letter. However, Martus expects to find each USB in the same drive. Before
backing up your keypair to USB drives, reassign the drive letter for each drive so that they are all the same.
To reassign the drive letter in Windows:
1. Insert the new USB in the USB port/drive.
2. Choose Start > Settings > Control Panel
3. Double-click Administrative Tools, and then Computer Management.
4. Click Disk Management.
5. Right-click the USB drive, and choose Change Drive Letter And Paths.
6. Select the drive letter you want to assign.
If you are using a Mac, and can’t find your USB location, look under the Volumes folder in the main Mac
hard drive display.
For further assistance with this in Mac OS or Linux, please email help@martus.org.
28. I'm having problems getting Martus to run on a Mac.
The problem may be occurring because of incompatible versions of Java installed on your machine.
To check which version of Java you are running, open a Terminal window and type:
java –version

and hit Return/Enter.
As of Martus 4.0, Martus should be run with Java 1.6 (sometimes called Java6) – see the Mac requirements
in section “2. Getting Started” for more on this.
Until Martus 3.1, the software was not compatible with Java 1.5 (sometimes called Java 5) which was
automatically installed on some Macs. If you are running Martus 3.0 or earlier and see Java version 1.5,
you should download Java Runtime Environment (JRE) version 1.4.2 (preferably 1.4.2_12) from
http://www.apple.com/downloads/macosx/apple . You can then tell Martus to use the 1.4.2 version of Java
by using the following command when you run Martus:
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<path-to-Java-v1.4.2-Install-executable-libraries>/Commands/java
-Xbootclasspath/p:/Library/Java/Extensions/bc-jce.jar -jar martus.jar

(all on one line with a space after /java )
For example:
/System/Library/Frameworks/JavaVM.framework/Versions/1.4.2/Commands/java
-Xbootclasspath/p:/Library/Java/Extensions/bc-jce.jar -jar martus.jar

For assistance running Martus on a Mac, please email help@martus.org.
29. I keep losing my Headquarters configurations. What’s going on?
In Martus 3.1 and earlier, if a customization template was greater than 64k in size, the configuration file in
Martus would occasionally become damaged. This would cause Martus to lose configuration data,
including Headquarters configurations. In Martus 3.2 we have removed the 64K size restriction for
customizations, and you should no longer experience this problem. If you are still experiencing the loss of
your Headquarters configurations, please email help@martus.org with a detailed explanation of what tasks
you were performing within Martus at the time, along with any messages that are in the Martus console log
(See section “11. Frequently Asked Questions” (FAQ) #17 for instructions on how to run Martus with the
console log.)
30. How do I install Martus on Linux so that multiple users on the computer can access it?
The normal Linux installation instructions in section “2a. Installing” only allow Martus to be used by the
user who installed it. You can also install Martus on a Linux computer such that any user on that computer
will be able to run it. If you do this, any user should be able to run Martus by simply typing "martus" on the
command line, from any directory. Each user can also create a launcher or alias to the /usr/bin/martus
script. If you install Martus to be available to all users, the program can be more secure (against tampering),
but it will be much more difficult to erase quickly, and the "wipeout" feature will not delete the application.
Note that each user's data will still be stored separately, within the user's home directory: ~/.Martus/
The installation steps will be the same as in the Linux portion of section “2a. Installing”, but:
a.
b.
c.

You will need root privileges. We recommend using the sudo command, but you could instead
directly sign in as a root user.
When choosing the <Martus Program Directory>, choose a world readable directory such as
/usr/share/java/martus
If using sudo, then commands that write data (mkdir, unzip, echo, chmod) must be preceded by
"sudo". For example:
sudo mkdir -p /usr/share/java/martus

d.

After creating the script as described in section “2a. Installing”, copy it to /usr/bin, like this
(assuming you are using sudo):
sudo cp martus /usr/bin

For further assistance running Martus in Linux, please email help@martus.org.
31. I created a Martus account solely for the purpose of testing and training and will not be creating
bulletins with real data using this account. How do I let server administrators know about it?
Go to Help > View My Account Details. Martus will bring up a screen displaying various account
information, including a twenty-digit public code composed of 5 4-digit numbers. Please send this public
code information to help@martus.org, letting us know that it is a test account.
32. I'm running Martus with the console log, but it seems to have stalled. What's going on?
In Windows, if you click within the console log (see section “11. Frequently Asked Questions” (FAQ) #17
for more information), it can cause Windows to suspend that process. When this happens, you will see the
word "Select" at the beginning of the console Window Title, or title bar. To "unselect" the console, rightclick in the body of the console – this should cause the "Select" message in the Window Title to disappear.
To prevent this from happening in the future, right-click in the title bar of the console, select Properties,
select the Options tab, and uncheck "Quick Edit Mode." When you hit OK, pick "Modify shortcut that
started this window."
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33. I'm running Martus, but I can’t find the Martus window. How can I find it?
If you have other programs open, Martus may be hidden behind one of them. Hitting Alt+Tab will scroll
through the icons of the various applications that are running, including Martus. Releasing the Alt and Tab
keys when you are at the Martus icon will bring it up on the screen.
34. I'm running Martus in Arabic, but the Arabic text in the column headers is displaying left
justified. How can I fix this?
When you run Martus in Arabic in Windows XP, text in column headers may not align correctly. Setting
Windows to display user interface elements in "Windows classic style" will center the Arabic column
headers. To center Arabic column headers, from the Start menu, choose Settings > Control Panel. Then,
double-click Display. In the Display Properties dialog box, click the Appearance tab, and choose Windows
Classic Style from the Windows And Buttons menu.
35. Is there another way to get encrypted bulletin files out of Martus than dragging to the Desktop?
Starting in version 3.4, there is a test version of import/export functionality for “Martus Bulletin Archive”
(MBA or .mba) files. This feature has not been fully completed, but will be helpful for those users who are
running Martus in Linux (where dragging bulletins does not usually work) Please note that a) if you
import an exported .mba file into a folder where that bulletin already existed, you will not get a message
saying that the import completed; b) once the bulletin is imported, the folder list does not automatically
refresh, so you have to click on a different folder and then back to the import folder for the newly imported
bulletin to appear; and c) when you save an exported Martus Bulletin Archive file, you have to manually
add the “.mba” extension to the filename (while you can leave the file with no extension, if you do not add
the “.mba” to the filename, the import dialog will not automatically filter the files displayed in your folders
when you go to find the file to import). To access this feature, you must add the
“ --alpha-tester” option to the end of your Martus command line. You can do this by right-clicking on the
Martus desktop shortcut, choosing Properties, selecting the Shortcut tab, and adding the “ --alpha-tester”
(without quotes) at the end of the text in the Target box. Once you have changed your Martus command,
you will be able to find the import/export MBA file functionality under the File menu, by picking the
“<menu:ExportMBA>” and “<menu:ImportMBA>” options. Bulletins will automatically import to the
folder you are in when you pick the option off the menu.
36. I want to update my customization for a new version of some bulletins that already have data
entered but am worried that changes might mess something up. What should I do to avoid any
problems?
When you change customizations, Martus will do its best to update the old formatted data to the new
customization if you create a new version of a bulletin with the old customization. If you add completely
new fields but don’t change any of the old fields, the new version of the bulletin will have all the old fields
filled in as they were in the previous version, and the new fields will be blank and you can fill them in. If
you delete fields, the new version of the bulletin will not contain those fields, but you can go back to see
the deleted fields in the previous version if it was a sealed bulletin instead of a draft (by hitting the Bulletin
Details button in the Header section of the bulletin), and copy any info from the old version into a different
field in the new one if desired.
You have to be very careful if you make changes to the customization definitions of old fields. If you keep
the same tag and label, but change the type of field, Martus may be able to transfer the old data into the
new field type, but not in all cases. For example,
 if you change field type from DROPDOWN to STRING, the data will be transferred over, but
 if you change from STRING to BOOLEAN, the data will be lost.
 if you change from a DATE to DATERANGE, your data will be transferred, but
 if you change from DATERANGE to DATE, you will lose the end date from your earlier data.
DROPDOWN and GRID fields are subject to additional rules regarding the modification of dropdown
options/values and grid columns. If you
 add options/values to a dropdown list, the old data will be transferred over. But
 if you modify or delete an option/value, all bulletins for which that option was selected will lose that
data.
 If you want to add columns to a grid, please make sure to do so at the end of the old grid definition and
not in the middle, or the old data will not be transferred to the new version of the bulletin.
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If you change fields and lose old data in the new version as a result, please note that you can go back to see
the deleted data in the previous version if it was a sealed bulletin instead of a draft (by hitting the Bulletin
Details button in the Header section of the bulletin), and copy any info from the old version into a different
field in the new one if desired.
In this release, if you want to change the number of levels in a “Reusable Choices” dropdown field when
updating a customization, you should also change the field tag and/or label so that they are more easily
distinguished from each other in searching and reporting. If you do not, the search/report results may be
confusing since fields with the same label/tag will be treated differently due to them having a different
number of levels.
If you update the default value for a field, please note that the new default value will only be applied when
a new bulletin is created, not when a new version of a bulletin is created, so that whatever the value of the
field in the previous version was will remain the same and not be overwritten.
In general if you are making changes to your customization, please make sure to test the transferring of data
using a test bulletin.
37. It seems like one of the cells I entered in a grid wasn’t saved. How could this happen?
In versions earlier than Martus 3.5, when you're entering text data into a grid, please make sure to hit Tab
(or Enter to create a new row) or select another cell in the grid after each cell you enter before saving the
bulletin so that all the values you entered will be saved.
38. If I open a bulletin attachment in Martus does it stay encrypted or could someone who gets hold
of my computer read it somehow?
When attachments are stored in Martus bulletins they are encrypted, so that nobody except you can read
them. However, when you open an attachment in a Martus bulletin so that another program loads it (e.g. a
document in Microsoft Word), your computer Operating System creates a temporary version of the file that
is not encrypted, and that file is usually saved to your hard drive, in the standard Temp directory for your
Operating System (e.g. “C:\Documents and Settings\your-user-name\Local Settings\Temp” in Windows
XP) or “/tmp” for Mac and Linux. If you are concerned about anyone seeing these files, you should at
least delete them and empty your Recycled Bin (this will remove them from view of most users, but
sophisticated users could still find the content with some work), but best of all would be to use an
electronic file “shredder” (E.g. http://www.fileshredder.org/ for Windows) for any Martus files in the Temp
directory. The Martus files in the temp directory will be given names based on the attachment name in
Martus. For example, a file named Interview.doc in Martus might appear as something like
Interview23424.doc in the Temp directory. This may not work for all Operating Systems, but if you cannot
find the Temp directory, you can try opening the file in Martus, and then saving it with a different name so
that you can see where the current version of the file is being stored.
39. I want to change the number of minutes Martus waits before timing out for security – how can I
do this?
You can change the Martus time-out length when there is no activity to be however long you want, instead
of always timing out at the default of 10 minutes. In addition to providing extra security if you are working
in a public place or on a shared computer and want to shorten the timeout to only a few minutes, you can
also improve the performance of long operations (such as retrieval of bulletins from the server) by setting
the timeout to a longer amount of time if you are working in a secure location. Different time-out lengths
are allowed by setting a parameter in the command line used to run Martus. The parameter is "--timeoutminutes=X" where X can be any number of minutes. For example, to set the timeout length for Martus
running on your computer in Windows to always be 5 minutes for a higher level of security, change the
command line in the desktop shortcut (right-click, and choose Properties) to the following:
C:\Martus\bin\java.exe -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar --timeout-minutes=5

For a Mac DMG install, to set the timeout length for Martus to always be 5 minutes for a higher level of
security, do the following:
 Right-click on the Martus icon (.app file), pick “Show Package Contents”, and double-click on
Contents folder
 Right click on info.plist and pick Open With. If you see TextEdit on the list, pick it; otherwise select
“Other” and the Applications folder will open and you can scroll down to select TextEdit. Hit Open.
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Towards the bottom, you should see something that looks like this:
<key>Arguments</key>
<string> </string>
Add “--timeout-minutes=5” so that it looks like:
<key>Arguments</key>
<string>--timeout-minutes=5</string>
Close the file, saving the changes if asked. And Close the Contents folder.
Make sure the console is running still, and then double-click on the Martus icon (.app file) to run
Martus.

You should see the new timeout length in the Martus console.
For instructions on how to change the Martus command line for Mac (if you installed from zip or CD/iso
files) or Linux, see section “2a. Installing” of the User Guide or email help@martus.org.
40. I want to use Martus in Burmese but the fonts don’t seem to be displaying correctly. How can I
get Burmese text to show up in Martus?
In Martus 4.0 or later, Burmese fonts should display correctly in Windows without any extra steps required.
If you notice any Burmese display issues, see the suggestions below, depending on which version of
Martus and operating system you are running. If none of these suggestions fix the Burmese display issues,
please email help@martus.org.
For Martus 4.2 or later, if you notice that the fonts are not displaying correctly in the window title bars at
the top of each screen, copy the Zawgyi-One font file from C:\Martus\lib\fonts\fallback to your
Windows\Fonts folder, and do the following:
 For Windows XP/Me
i) Right click on your desktop and choose Properties
ii) Choose the Appearance Tab
iii) Click the Advanced button
iv) Under “Item” choose “Active Title Bar”
v) Change the font to “Zawgyi-One”
 For Windows Vista/7
i) Right click on your desktop and choose Personalize
ii) Choose the Window Color and Appearance Tab
iii) Click the Advanced button or link
iv) Under “Item” choose “Active Title Bar”
v) Change the font to “Zawgyi-One”
 For Windows 98/2000
i) Right click on your desktop and choose Properties
ii) Choose the Appearance Tab
iii) Under “Item” choose “Active Title Bar”
iv) Change the font to “Zawgyi-One”
For Martus 4.2 or later, if you are running Martus in a language other than Burmese and want to type or
view Burmese data in your bulletin fields, choose Options > Preferences, and check “Use Zawgyi font for
Burmese display and input”. If you are running Martus in Burmese, it assumes you will be entering
bulletin data/text using the Zawgyi font, and the “Use Zawgyi font for Burmese display and input” option
should automatically be checked (if you uncheck it, the user interface will not display correctly in
Burmese).
Some additional notes on using Burmese in Martus 4.2 or later:
• If you have entered text in Zawgyi (for example in bulletins or in the Search screen), and the field
starts with a character that is not displayed until you type another character, and then you double-click
to type over, or select the text, the initial character may not be removed or selected. Since that
character is not visible, it can then later cause issues when searching or reporting on that field. We
suggest using the backspace key to delete all the text instead of double-clicking.
• If you are using a Burmese DefaultDetails.txt file (see section “10a. Using a template in the Details
field”), it must be entered in a Unicode font, not Zawgyi.
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For Martus 4.0 and 4.1, if you notice that the fonts are not displaying correctly in the window title bars at
the top of each screen, copy the Myazedi font file from C:\Martus\lib\fonts\fallback to your Windows\Fonts
folder, and follow the steps in c) below.
If you are running Martus 4.2 or later in Burmese on Mac and the fonts are not displaying correctly, you
can find the Zawgyi font inside the Fonts folder of the Martus DMG (or zip file) – double-click on it to
install. For Martus 4.0 and 4.1, you would want to use the Myazedi font instead.
Some additional steps may be needed to have Burmese display correctly in Martus in versions before 4.0,
The instructions for Windows are below, if you are using another operating system, please contact
help@martus.org for help. Please do the following
a) If you don't already have it, download and install the “MyaZedi.ttf” file on your system. In Martus 3.5
or later, you can find MyaZedi.ttf in your Martus\lib\fonts directory. If you are using a version of
Martus earlier than 3.5, you can search for MyaZedi.ttf online and download it. For Windows, copy
MyaZedi.ttf into both C:\Windows\Fonts (can also be done through the Control Panel) and
C:\Martus\lib\fonts (if using a version of Martus earlier than 3.5). Please note that Martus has been
tested with this font, but other fonts may be possible as well (if you want to use another font, or are
using a Mac, please contact help@martus.org for help).
b) You will then need a Burmese specific Java font support file to use in Martus called
font.properties.burmese. In Martus 3.5 or later, this file will be in your Martus\lib directory. If you are
using a version of Martus earlier than 3.5, you can contact help@martus.org to get the file, and copy it
to the Martus\lib directory.
i. Use the Windows explorer to open up the directory ‘C:\Martus\lib’ and rename “font.properties”
to “font.properties.original”.
ii. Create a copy of the “font.properties.burmese” , and rename it to “font.properties”
c) Depending on your setup, you may also need to do the following to get the Window titles to display
correctly in Burmese
 For Windows XP/Me
i) Right click on your desktop and choose properties
ii) Choose the Appearance Tab
iii) Click the Advanced button
iv) Under “Item” choose “Active Title Bar”
v) Change the font to “MyaZedi.ttf”
 For Windows Vista/7
i) Right click on your desktop and choose personalize
ii) Choose the Window Color and Appearance Tab
iii) Click the Advanced button or link
iv) Under “Item” choose “Active Title Bar”
v) Change the font to “MyaZedi.ttf”
 For Windows 98/2000
i) Right click on your desktop and choose properties
ii) Choose the Appearance Tab
iii) Under “Item” choose “Active Title Bar”
iv) Change the font to “MyaZedi.ttf”
Start Martus as usual. Pick Burmese from the language dropdown on the Signin screen in Martus. If you
get a message saying that the translation is out of date with the current version of Martus, check to see if
there is a Martus language pack (Martus-bur.mlp) available at
https://www.martus.org/downloads/#burmese, and if there is, please download it and copy into your
C:\Martus directory, and run Martus again.
While you cannot type Burmese text into Martus in versions before 4.2, you can copy/paste Burmese text
into Martus fields, or attach scanned images of Burmese text that can be viewed inside your bulletins.
41. I want to run Martus in Khmer, but the fonts don’t seem to be displaying correctly. How can I
get Khmer text to show up in Martus?
In Martus 4.0 or later, Khmer fonts should display correctly in Windows without any extra steps required.
If you notice that the fonts are not displaying correctly in the window title bars at the top of each screen,
copy the KhmerOS font file from C:\Martus\lib\fonts\fallback to your Windows\Fonts folder, and follow
the steps in e) below.
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If you are running Martus 4.0 or later in Khmer on Mac and the fonts are not displaying correctly, you can
find the KhmerOS font inside the Fonts folder of the Martus DMG (or zip file) – double-click on it to
install.
If you are having issues with Khmer font display in Martus 4.0 or later, please email help@martus.org.
In versions of Martus before 4.0, Khmer fonts did not show up correctly with the version of Java that came
with the Martus install on Windows (Java4), However, you can run those pre-4.0 Martus releases with a
newer version of Java (Java6 also sometimes called Java 1.6), and install a Khmer font file for Martus to
use, and Khmer text will display correctly. Instructions to do this in Windows are as follows (if you are
using Mac, please email help@martus.org):
a) Before starting Martus, download Java 6 (available here: http://www.java.com/en/) and direct the
Martus software to use Java 6 instead of Java 4 by doing the following:
b) Right-click on the Martus icon on your desktop, select Properties, and select the Shortcut tab.
Replace what is in the Target command line with the below:
"C:\Program Files\Java\jre6\bin\java.exe" -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar

or the equivalent based on where you installed Java6:
"C:\where-you-installed-java\jre6\bin\java.exe" -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar

c)

Make sure that Khmer fonts are installed so that Martus can access them. In Martus 3.5 or later, you
can find a Khmer font file (KhmerOS.ttf which has been tested with Martus) in your Martus\lib\fonts
directory. If you are using a version of Martus earlier than 3.5, you can search for KhmerOS.ttf online
and download it.
d) Copy KhmerOS.ttf (or your preferred font file) to the following locations:
 C:\Windows\Fonts (can also be done through the Control Panel),
 C:\Program Files\Java\jre6\lib\fonts\fallback (or equivalent based on where you installed Java6,
C:\where-you-installed-java\jre6\lib\fonts\fallback). If the “fallback” directory does not exist,
create it to put the font file in it.
When you start Martus, in the log in screen you will see a small language dropdown in the lower left-hand
corner. This should now contain Khmer as an option. When you select it, Martus should begin displaying
the Khmer translation. Please note that in the currently available Khmer translation of Martus some newer
functionality will not be translated. Phrases which have been translated will display in Khmer. Phrases that
have not been translated will display in English with brackets (i.e. <…> ) around them. Translations that
are in Khmer but not up-to-date with the current English Martus text will be marked with brackets around
them as well, and if you see these in any screens you are using, we recommend switching to English so that
you have the latest guidelines on how to use the software. This is especially important in help screens (e.g.
customization, search) where new functionality may have been added and the old instructions may be
misleading or incomplete.
e)






If you notice that Khmer is not displaying correctly in the window title bars at the top of each screen,
you should exit Martus, do the following steps, and then restart Martus.
For Windows XP/ Me
i. Right click on your desktop and choose properties
ii. Choose the Appearance Tab
iii. Click the Advanced button
iv. Under “Item” choose “Active Title Bar”
v. Change the font to “KhmerOS.ttf”
For Windows Vista/7
i. Right click on your desktop and choose personalize
ii. Choose the Window Color and Appearance Tab
iii. Click the Advanced button or link
iv. Under “Item” choose “Active Title Bar”
v. Change the font to “KhmerOS.ttf”
For Windows 98/2000
i. Right click on your desktop and choose properties
ii. Choose the Appearance Tab
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iii. Under “Item” choose “Active Title Bar”
iv. Change the font to “KhmerOS.ttf”
Start Martus as usual. Pick Khmer from the language dropdown on the Signin screen in Martus. If you get
a message saying that the translation is out of date with the current version of Martus, check to see if there
is a Martus language pack (Martus-km.mlp) available at https://www.martus.org/downloads#khmer, and if
there is, please download it and copy into your C:\Martus directory, and run Martus again.
Note: In versions of Martus before 4.0, there were some server functions that would not work correctly when
running Martus with certain versions of Java6 in Windows. If you are using Martus 4.0 or later, this will not
be an issue because the correct version of Java6 is included, but if you are using an earlier version of Martus
with Java6, you need to make sure that your version of Java6 is later than 1.6.0_30. Please email
help@martus.org if you need assistance.
42. I want to enter Bengali/Bangla text in Martus, but the fonts don’t seem to be displaying
correctly. How can I get Bengali/Bangla text to show up in Martus?
In Martus 4.0 or later, Bengali/Bangla fonts should display correctly in Windows without any extra steps
required. If you are running Martus 4.0 or later in Bengali/Bangla on Mac and the fonts are not displaying
correctly, you can find the Rupali font inside the Fonts folder of the Martus DMG (or zip file) – doubleclick on it to install. If you are having issues with Bengali/Bangla font display in Martus 4.0 or later, please
email help@martus.org.
Some additional steps may be needed to have Bengali/Bangla display correctly in Martus in versions before
4.0, The instructions for Windows are below, if you are using another operating system, please contact
help@martus.org for help. Please do the following:
a) If you don't already have it, download and install the “Rupali.ttf” file on your system. In Martus 3.5 or
later, you can find Rupali.ttf in your Martus\lib\fonts directory. If you are using a version of Martus
earlier than 3.5, you can search for Rupali.ttf online and download it. For Windows, copy Rupali.ttf
into both C:\Windows\Fonts (can also be done through the Control Panel) and C:\Martus\lib\fonts (if
using a version of Martus earlier than 3.5). Please note that Martus has been tested with this font, but
other fonts may be possible as well (if you want to use another font, or are using a Mac, please contact
help@martus.org for help).
b) You will then need a Bengali/Bangla specific Java font support file to use in Martus called
font.properties.bangla. In Martus 3.5 or later, this file will be in your Martus\lib directory. If you are
using a version of Martus earlier than 3.5, you can contact help@martus.org to get the file, and copy it
to the Martus\lib directory.
i. Use the Windows explorer to open up the directory ‘C:\Martus\lib’ and rename “font.properties”
to “font.properties.original”.
ii. Create a copy of the “font.properties.bangla” file and rename it to “font.properties”
Start Martus as usual. While there is not yet a Bengali/Bangla translation of Martus, you should now be
able to type or copy/paste Bengali/Bangla text into Martus fields.
43. When I choose to run Martus in my language I get a warning message that the translation is not
up-to-date with the current release of Martus. What should I do?
If there is a translation of an older version of Martus in your language that you can choose to use, it usually
means that most of the Martus screens will be in your language, but some newer functionality will not be
translated. The more recent the version number of your translation compared to the current version number
of the Martus release, the more of the Martus screens will be up to date in your language. Translations that
are in your language but not up-to-date with the current English Martus text will be marked with brackets
(i.e. <…> ) around them, and if you see these in any screens you are using, we recommend switching to
English so that you have the latest guidelines on how to use the software. This is especially important in
help screens (e.g. customization, search) where new functionality may have been added and the old
instructions may be misleading or incomplete.
44. I want to run Martus using Java6, how can I do this?
The current version of Martus includes Java6 in Windows while earlier versions included Java4. You can
run those earlier versions of Martus with Java6 (also sometimes called Java 1.6), if you need to (E.g. to
display certain fonts, or to help if you are receiving import errors with very large files). Instructions to do
this in Windows are as follows:
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a)

Before starting Martus, download Java 6 (available here: http://www.java.com/en/) and direct the
Martus software to use Java 6 instead of Java 4 by doing the following:
b) Right-click on the Martus icon on your desktop, select Properties, and select the Shortcut tab.
Replace what is in the Target command line with the below:
"C:\Program Files\Java\jre6\bin\java.exe" -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar

or equivalent based on where you installed Java6:
"C:\where-you-installed-java\jre6\bin\java.exe" -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar

On Windows, you can tell that you are successfully running Martus using Java6 if you see large dots in the
password fields instead of the asterisks you would see when running earlier versions of Martus using Java4.
Note: In versions of Martus before 4.0, there were some server functions that would not work correctly when
running Martus with certain versions of Java6 in Windows. If you are using Martus 4.0 or later, this will not
be an issue because the correct version of Java6 is included, but if you are using an earlier version of Martus
with Java6, you need to make sure that your version of Java6 is later than 1.6.0_30. Please email
help@martus.org if you need assistance.
On Mac, if you have multiple versions of Java installed, you will need to launch the Java Preferences
dialogue to change the version of Java that is used. To locate it, hit Command-Space to bring up the
"Spotlight" search, and type Java Preferences. Once it is open, you will see two sets of configurations, one for
Java applet plugins and another for Java applications. If you wish to change the version of Java Martus uses
by default, select the new version using the dialogue instructions, then close out of the Java Preferences
screen. For additional assistance, please email help@martus.org.
45. Martus is finding either more or fewer bulletins than I expected. What could be causing this?
There are several reasons that Martus might not be finding a bulletin that you expect, or may be finding
bulletins that you didn’t expect.
a)

By default, Martus searches all versions of every bulletin. If you do not see your search terms/dates in the
final version of the bulletin displayed in the Search Results folder, your criteria may have been matched
in an earlier version of the bulletin. You can access previous versions by clicking the “Bulletin
Details…” button at the top of the bulletin. To search only the most recent versions of bulletins, select
Only Search Most Recent Versions of Bulletins in the Search dialog box.
b) By default, Martus searches all rows of any grid (table) fields for your criteria and doesn’t require that
the terms are all on the same row. If you want to specify that all grid column specifications in the Search
screen be matched to a single row of bulletin grid data, check the “Match grid column specifications”
checkbox in the Search screen.
c) Because Martus searches all rows of any grid (table) fields for your criteria, it may find bulletins where
one grid row matches your criteria but other rows do not. For example you could have a bulletin with a
grid that has a location field in it and you have multiple rows of data in the grid with locations A, B, and
C. If you search for bulletins where location != C (does not equal C), Martus will find that bulletin
because there are 2 rows in the bulletin grid where the location is not C, even though there is one row
where the locations IS C.
For more information about finding bulletins in Martus see section “6m. Searching for specific bulletins”, and
if you have questions, please email info@martus.org.
46. I am seeing duplicate entries in my dropdown list search criteria values in the search screen.
What could be causing this?
If you pick a Reusable Choices dropdown field to search on, the values that are displayed as the criteria
dropdown list options are the labels for each list entry, but the codes you defined determine how many
entries there will be in the search dropdown list (see section “10b. Customizing bulletin fields” for more
information about creating custom dropdown fields). So if you have different reusable choices codes with
the same label in different bulletin customizations in your account, the labels will show up twice in search
dropdown lists (i.e. if you used label1 for both code1 and code2, you will see 2 entries in the search
dropdown that looks like "label1" and if you want your search to be on bulletins that have that label,
regardless of which code the customization had for the label, you will need to do a “or” search on both
labels). And if you have the same reusable choices code with different labels in different bulletin
customizations in your account, the search dropdown list for that code will show both values separated by a
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semicolon (i.e. if you used code1 for both label1 and label2, you will see an entry in the search dropdown
that looks like "label1; label2" and your search will be on bulletins that have either of those labels).
47. I am seeing fields that look the same to me in Search and Report screen field lists. How can I tell
what the difference is between them?
If you have fields in different bulletins or from different customizations that are exactly the same, Martus will
combine them in any Search and Report field lists. And while Martus warns you about duplicate labels where
you are creating a new bulletin customization, it is possible that over time, you may have bulletins with
different customizations that ended up with the same labels (e.g. maybe you changed a text field to a
dropdown field but kept the same label). In these cases, Martus will try to help you figure out the difference
between the fields by displaying what the field type and tag are in the field selection lists. Also, if you have
fields with the same tag but different labels and/or field types, Martus may use the tag and field type to try
and determine when different fields were meant to be the same. So we encourage you to make your field tags
and labels in a customization clearly related to each other to avoid any confusion. See section “10b.
Customizing bulletin fields” for more information about configuring custom fields.
48. Why can’t I find my Martus files on my Mac?
In Mac OS, the Martus data directory (and some other program directories) are hidden by default. These
directories are not viewable using the Finder application, and are prefaced with a "." (e.g. ".Martus"). Martus
saves some files, such as the Headquarters information .mpi file, directly to the Martus directory by default
(though you can also choose to save them elsewhere on your computer). In order to access these files, you
will need to set your computer preferences to "show" these hidden folders. To do so, follow these steps:
a) Go to Finder > Applications > Utilities, and open the Terminal application. (You can also hit CommandSpace to bring up the search, enter "terminal", and when it finds the Terminal app, launch it.)
b) Type
defaults write com.apple.finder AppleShowAllFiles TRUE
and hit Enter.
c) Restart the Finder by holding the Option key, and click and hold the Finder icon. When the context menu
shows, select Relaunch. (Alternately you can type
killall Finder
and hit Enter/Return.)
d) When the Finder restarts, you will be able to view the ".Martus" folder within your home directory and
access files saved there.
49. I am running Martus in Farsi/Dari, but some of the letters don’t seem to be displaying correctly.
How can I fix this?
In versions of Martus earlier than 4.0, some Farsi/Dari letters will not show up correctly with the version of
Java that came with the Martus install on Windows (Java4). If you are using Martus 4.0 or later, this will
not be an issue because Java6 is included with it, but if you are using an earlier version of Martus you could
run Martus with Java6 (also sometimes called Java 1.6), and Farsi/Dari text will display correctly.
Instructions to do this in Windows, for versions of Martus before 4.0, are as follows (if you are using Mac,
please email help@martus.org):
a) Before starting Martus, download Java 6 (available here: http://www.java.com/en/) and direct the
Martus software to use Java 6 instead of Java 4 by doing the following:
b) Right-click on the Martus icon on your desktop, select Properties, and select the Shortcut tab.
Replace what is in the Target command line with the below:
"C:\Program Files\Java\jre6\bin\java.exe" -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar

or the equivalent based on where you installed Java6:
"C:\where-you-installed-java\jre6\bin\java.exe" -Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar

Note: In versions of Martus before 4.0, there were some server functions that would not work correctly when
running Martus with certain versions of Java6 in Windows. If you are using Martus 4.0 or later, this will not
be an issue because the correct version of Java6 is included, but if you are using an earlier version of Martus
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with Java6, you need to make sure that your version of Java6 is later than 1.6.0_30. Please email
help@martus.org if you need assistance.
50. Is it possible to export more than the final version of my bulletins to XML?
Starting in version 4.1, there is a test version of XML export functionality for multiple versions of Martus
bulletins. This feature has not been fully completed, but will be helpful for those users who want to export
all their version history into other tools. Please note that if you try to import a multiple-version exported
XML file back into Martus, the imported bulletins would not be connected to each other in any way, and
would not have any previous author information. To access this feature, you must add the “ --alpha-tester”
option to the end of your Martus command line.
You can do this in Windows by right-clicking on the Martus desktop shortcut, choosing Properties,
selecting the Shortcut tab, and adding the “ --alpha-tester” (without quotes) at the end of the text in the
Target box.
You can do this in Mac (if installed with a DMG) by right-clicking on the Martus icon (.app file), pick
“Show Package Contents”, double-click on Contents folder, right click on info.plist, choose Open With and
pick TextEdit, and add “ --alpha-tester” (without quotes) to the Arguments section so it looks like this:
<key>Arguments</key>
<string>--alpha-tester </string>
Close the info.plist file, saving the changes if asked, and close the Contents folder.
Once you have changed your Martus command, you will be able to see the “Include all versions of each
bulletin in export” checkbox when you select File > Export Folder or File > Export Bulletins. More
instructions about standard (final version only) XML bulletin export are available in section “6p. Creating
bulletin charts
You can create customized charts from information in the bulletins on your computer, and then print those
reports to a printer or to a JPEG image file (which can be opened in various applications such as image
display tools, or a word processor for further editing/formatting if desired.)
To create a chart:
15. Choose File > Charts.
16. Select click Bar Chart, 3D Bar Chart, or Pie Chart from the “Type of Chart” dropdown list. A Bar or
3D Bar Chart shows counts of bulletins for each value of the field you select, while a Pie Chart shows
both the counts of bulletins and the % (percentage) of total bulletins that match your defined search
criteria (chosen when you create the chart). See examples below for each type of chart.

Note: You will see a warning message that any data in charts will not be encrypted, so anyone who
sees the chart (in printed or electronic form) will be able to read all the data.
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17. Click on the Choose Field button to select the field you want to include in the chart, pick a field from
the list (which will include all the standard or custom fields that are in any of the bulletins on your
computer), and then click OK.

18. If desired, enter text that will be displayed beneath the title of the report in the Subtitle field (e.g.
“Human Rights Organization data collection monthly status report”).
19. Hit the OK button.
20. In the Search dialog box, enter the criteria for bulletins you want to include in your chart. To use
search criteria you’ve previously saved, click Load Previous Search. When you’ve entered the search
criteria, click Search. For more information on searching, see “6m. Searching for specific bulletins.”
Note: Martus will remember the immediately previous search criteria without you needing to load it.
21. Martus displays a preview of the chart. Click Print to Printer to print the report to your printer (Martus
will automatically scale the printout to fit the page width, based on your printer preferences). Click
Print to File to save the report on your computer as a JPEG image file that you can open in the image
display program of your choice, or copy/insert into a word-processing application. If you want to make
changes to the report before printing, click Cancel, choose File > Charts, and create a new chart.
Note: Martus only displays data from the latest version of each bulletin on your computer in the chart.
See examples of charts below.
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Bar Chart:

3D Bar Chart:
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Pie Chart:

Important Note:
11. Martus charts are intended to give you information about the status/progress of data that has been
gathered and entered in Martus, but not to analyze “what happened” from the data that has been
entered. So for example we can count the number of bulletins that came from a particular
timeframe or region (if your project is collection that information), but not how many killings
there were in a particular region.
12. Martus charts are also meant to focus on fields in which the information is distinct for a bulletin or
source document. For example, you can design reports to search for all bulletins entered by a
certain user, or given by individuals of a given ethnicity (if your project is collecting that
information).
13. Martus charts do not correct for the following:
a. Sampling bias (e.g. all bulletins entered being more from one particular region than any
others, even if the project is covering incidents that happened across all of them).
b. Duplicate reporting (i.e. more than one bulletin may exist about the same incident, or the
same person may be mentioned using different names, or there may be multiple people with
the same name).
c. Data quality issues (e.g. typos that might lead to a search not finding bulletins, fields being
left blank where values were expected). Some of these issues can be addressed in a project
customization, by requiring certain fields to be entered before a bulletin or grid row can be
saved, or using dropdown fields to avoid typos and guarantee consistency in searching.
d. Possible inconsistency in how data is entered in Martus by different people. For more on this
topic, see “Controlled Vocabulary” and the “Inter-rater Reliability” section on
https://hrdag.martus.org/resources/core_concepts.shtml.
14. Martus charts especially should not attempt to count the number of violations, victims or
perpetrators, beyond counting the number of bulletins that match search criteria. Before counting
violations or victims/perpetrators, important data processing needs to take place before such
counting can be considered scientifically defensible. This includes addressing the possibility of
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duplicate reporting (more than one bulletin may exist about the same incident); representing the
complexity of human rights violations (an individual who was the victim of a given act may later
become the perpetrator of a different act, or vice versa); and maintaining consistency in meaning
and counting (ensuring, for example, making sure that all the data entered in bulletins used
consistent definitions for violations.)
15. If you would like to perform descriptive or qualitative analysis of the information entered into
Martus, Benetech can help you to use a tool to export and summarize data for your project. The
exported data may be able to be reviewed using analytical tools, but please keep in mind that
quantitative or inferential statistical analysis cannot be performed until additional steps have been
taken in processing the data, and without enough volume and different sources of data, statistical
analysis may not give meaningful or reliable results.
6q. Exporting bulletin data”.
51. Are there any Martus training resources available for my organization?
Please see the Martus website for web and video tutorials on how to use Martus, including installation and
troubleshooting for Windows and Mac. You can find these under the “Products and Services” menu of
https://www.martus.org, or directly at https://www.martus.org/martusdemo.
52. I'm double-clicking on the Martus icon on my Desktop and nothing is happening. How do I get
Martus to run?
Some users have noticed this issue when running Martus on Windows 7. Please try the following steps to
resolve it:
• Close out of all programs.
• Click Start > Control Panel > Display. (If "Display" is not available, go to the top right corner of
the Control Panel window and change the "View by" selection to "Large icons.")
• Click "Adjust ClearType text in the left column of the display window.
• You will see an option for "Turn on ClearType" that is checked. Un-check it and click Next.
• Over the next few screens, choose which text looks the clearest to you.
• Click Finish to save the settings.
• On your desktop, double-click your Martus icon to launch the application.
(For screenshots of the above steps, see http://maximumpcguides.com/windows-7/turn-off-cleartype/ )
53. I am concerned that my internet activity, and/or my connection and sending bulletins to the
Martus servers, is being monitored or blocked. What can I do?
The Onion Router, or Tor (https://www.torproject.org), is software and an open network that provides
anonymity and privacy protection over the internet. Tor routes an internet user’s traffic through a global
network of relays in such a way as to obscure both the origin and the destination of the traffic. By bouncing
your communications around a distributed network all around the world, Tor helps defend against a form of
network surveillance known as traffic analysis. It will make sending bulletins harder to track, but also much
slower.
WARNING: Before using Tor, please read the full list of warnings available at
https://www.torproject.org/download/download#warning. If you have any questions about what Tor does or
does not do, or any other Tor-specific questions, email the Tor support team at help@rt.torproject.org. (For
questions about Martus and Tor, email the Martus support team at help@martus.org).
In Martus 4.3 and later, you can run Martus with Tor by going to Options > Preferences and checking the
“Use Embedded Tor” box.
In versions before 4.3, Martus can be configured to connect to the servers through the Tor network, but it
requires additional configuration steps. After installing Martus (see section “2a. Installing”), follow the steps
outlined below that correspond to your operating system.
To run Martus over Tor on Windows, please do the following:
1. Download and install the Tor Browser Bundle for Windows from
https://www.torproject.org/download .
2. If Martus is running, save your work and Exit.
3. On your Martus desktop icon, right click and select Properties.
4. In the “Target” field, modify the text to include –DsocksProxyHost=127.0.0.1
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–DsocksProxyPort=9150 immediately preceding –Xbootclasspath. Your command line in the
Target field should now look something like this (needs to all be on one line, do not hit
return/enter in the middle of the command):
C:\Martus\bin\java.exe -Xms256m -Xmx512m -DsocksProxyHost=127.0.0.1 -DsocksProxyPort=9150
-Xbootclasspath/p:C:\Martus\lib\ext\bc-jce.jar -jar C:\Martus\martus.jar

5.
6.

7.

Apply the changes and click OK to exit the Properties dialog.
Open the Tor Browser. This will launch the Vidalia interface, which acts as your Tor control
panel. After a connection to the Tor network is established (and your onion icon in the Windows
system tray has turned green), the Tor Browser will launch, and your homepage will tell you that
you are connected to Tor.
After the Tor Browser is fully launched, double-click your desktop’s Martus icon and log in as
normal. Martus’ connection to the backup servers will now be routed over Tor.

Note: Using this configuration, Martus will ONLY connect to the backup servers once the Tor Browser
and Vidalia are running and properly connected to the Tor network. If you would like to have the option
to connect to Martus servers without using Tor, you can create a second copy of your Martus desktop
icon, name it something like “Martus over Tor” (without the quotes), and configure only that icon
starting with Step (3) above. Then you will have two icons to use: the original Martus icon to use over
the open internet, and the Martus on Tor icon to anonymize your connection to the Martus servers.
To run Martus over Tor on a Mac (if installed with a DMG), please do the following:
1. Download and install the Tor Browser Bundle for Mac from https://www.torproject.org/download.
2. If Martus is running, save your work and Exit.
3. Make sure you have copied the Martus icon out of the DMG and put in your Applications folder.
4. In your Applications folder, right-click (or CMD+click) on the Martus icon and select Show
Package Contents.
5. Open the Contents folder. Right click (or CMD+click) on info.plist and pick Open With. If you
see TextEdit on the list, pick it; otherwise select “Other” and the Applications folder will open and
you can scroll down to select TextEdit. Hit Open.
6. Towards the bottom, you should see something that looks like this:
<key>VMOptions</key>
<string>-Xms256m –Xmx512m -Xbootclasspath/p:Contents/Resources/Java/ThirdParty/bc-jce.jar</string>

7.

Add “-DsocksProxyHost=127.0.0.1 -DsocksProxyPort=9150” to the command so that the whole
thing now looks like this (needs to all be on one line, do not hit return/enter in the middle of the
command):
<key>VMOptions</key>
<string>-DsocksProxyHost=127.0.0.1 -DsocksProxyPort=9150 -Xms256m -Xmx512m
-Xbootclasspath/p:Contents/Resources/Java/ThirdParty/bc-jce.jar</string>

8.
9.

Close the file, saving the changes if asked. And Close the Contents folder.
Start the Tor Browser. This will launch the Vidalia interface, which acts as your Tor control panel.
After a connection to the Tor network is established (and your onion icon in the dock has turned
green), the Tor Browser will launch, and your homepage will tell you that you are connected to
Tor.
10. After the Tor Browser is fully launched, click your Martus icon and log in as normal. Martus’
connection to the backup servers will now be routed over Tor.
Note: Using this configuration, Martus will ONLY connect to the backup servers once the Tor Browser
and Vidalia are running and properly connected to the Tor network. If you would like to have the option
to connect to Martus servers without using Tor, you can create a second copy of your Martus app, name
it something like “Martus over Tor” (without the quotes), and configure only that icon starting with Step
(4) above. Then you will have two app icons to use: the original Martus icon to use over the open
internet, and the Martus on Tor icon to anonymize your connection to the Martus servers.
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For instructions on how to change the Martus command line for Mac if you installed from zip or CD/iso
files (instead of from a DMG), see section “2a. Installing” of the User Guide or email help@martus.org.
To run Martus over Tor on Linux, please do the following:
1. Download and install the Tor client for Linux following the instructions at
https://www.torproject.org/docs/tor-doc-unix.html.en
2. If Martus is running, save your work and Exit.
3. Modify your Martus command to include –DsocksProxyHost=127.0.0.1 –DsocksProxyPort=9050
immediately after “java”. Your command line should now look something like this:
If using Oracle’s Java (needs to all be on one line, do not hit return/enter in the middle of the
command):
java –DsocksProxyHost=127.0.0.1 –DsocksProxyPort=9050 -Xbootclasspath/p:`pwd`/ThirdParty/bc-jce.jar
-jar `pwd`/martus.jar

If using OpenJDK:
java –DsocksProxyHost=127.0.0.1 –DsocksProxyPort=9050 -jar martus.jar
4.
5.

Run Tor. (From the command line, execute simply “tor” (without the quotes).)
Once you are connected to the Tor network, run Martus and log in as normal. Martus’ connection
to the backup servers will now be routed over Tor.

Note: Using this configuration, Martus will ONLY connect to the backup servers once Tor is running
and properly connected to the Tor network. If you would like to have the option to connect to Martus
servers without using Tor, you can create a second copy of your Martus command, name it something
like “Martus over Tor”, and configure that version starting with Step (3) above. Then you will have
two commands to use: the original Martus command to use over the open internet, and the “Martus
over Tor” command to anonymize your connection to the Martus servers.
If you have additional questions, please contact the Martus support team at help@martus.org.
54. I am concerned that my computer is compromised, and/or that my internet activity is constantly
being monitored or blocked. What can I do to better protect myself while using Martus?
Users operating in particularly oppressive or antagonistic online contexts may be interested in tools that
better preserve their privacy, circumvent censorship and completely bypass a compromised hard drive.
One such tool is Tails (The Amnesic Incognito Live System, https://tails.boum.org/) a free, open source
bootable LiveUSB or LiveDVD that offers advanced security and privacy features by default. It allows
users to boot from virtually any computer using a previously-configured DVD or USB stick, bypassing that
computer’s internal hard drive. Tails anonymizes a user's internet activity by routing all connections
through the Tor network (see previous FAQ), leaves no trace on the computer being used, and provides the
latest open source cryptographic tools, allowing users to encrypt their emails, chats and files.
For more information about Tails, please see the About page on the Tails website:
https://tails.boum.org/about/index.en.html
Tails is not necessary for all Martus users, but may be a useful solution for users who:
 believe their computer hard drives may be compromised;
 face comprehensive monitoring, surveillance and censorship of online activity; or
 primarily connect to the internet via public wifi, e.g. on a personal laptop at an internet cafe.
Martus can be installed on Tails by following the steps outlined below.
WARNING: Before relying on Tails to provide additional security and privacy protection, please review
their documentation to understand the risks associated with using it, especially their Warning page:
https://tails.boum.org/doc/about/warning/index.en.html
After reading the About and Warning pages, you can download, verify and install Tails at their download
page: https://tails.boum.org/download/index.en.html
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Some notes as you get started with Tails:
 Install Tails to a USB: Install Tails on a USB drive (size 2Gb or larger). This will create a bootable
LiveUSB capable of running Tails.
 Configure Persistence: The Tails USB provides the option to create a persistent partition where files
can be saved. Martus requires the creation of this persistent volume in order to work properly.
Anything saved outside of this folder will be erased when Tails shuts down. To learn more about what
Persistence is and how to configure your volume, see the Tails Persistence page:
https://tails.boum.org/doc/first_steps/persistence/index.en.html (please read all warnings related to
Persistence as well).
Note: Martus over Tails will only work on Windows/Linux computers, and not on Mac computers:
Mac computers will not currently boot a Tails LiveUSB (though they will boot a Tails LiveDVD). As a
persistent partition is currently necessary to run Martus on Tails, and the LiveUSB is the only option
that offers persistence, users will need to boot Tails to a Windows-compatible computer or Linux PC.


Update your computer’s boot order: At startup, a computer looks for a disk from which to boot.
Typically the first place a computer looks is the internal hard drive. Tails users need to change a
setting so that the computer looks for a bootable USB first and then to the other devices,
including the internal hard drive, for a standard boot. For instructions on how to configure a
computer to do this, please see this tutorial:
http://pcsupport.about.com/od/fixtheproblem/ss/bootorderchange.htm

Once you have created your Tails LiveUSB, updated your computer’s boot order and configured the
Persistent volume, please follow the instructions below to install Martus.
1.
2.
3.
4.

5.

Boot Tails on your computer.
From the Tails desktop, open the "amnesia’s home" folder, and then the Persistent folder.
Download the latest Martus for Linux from https://www.martus.org/cgi-bin/download_martus.cgi.
Save the .zip file to the Persistent folder.
Extract the Martus .zip package to the Persistent folder, so that the location of all the files is
/home/amnesia/Persistent. This will create a new folder called MartusClient-version# (e.g.
MartusClient-4.3.0).
Open gedit Text Editor from Applications > Accessories. In the open text file, include the
following (and ONLY the following, all of which must remain together as one line of text):
java -DsocksProxyHost=127.0.0.1 -DsocksProxyPort=9050 -Duser.home="Accounts" -jar martus.jar

6.
7.

8.

Save this file as “Run Martus” (without quotes) inside your /Persistent/Martus Client-version#
(e.g. MartusClient-4.3.0). folder and close gedit.
Open your Martus Client-version# (e.g. MartusClient-4.3.0). folder, right-click on the “Run
Martus” file, and select Properties. Select the Permissions tab, and check the box next to "Allow
executing file as program." Click “Close”.
In your Martus folder, double-click the Run Martus icon. When prompted, select "Run in
Terminal." You will see a Terminal window open, followed by Martus itself. This is how you will
start Martus every time you want to run it.

If you have any questions or experience any problems while installing or running Martus on Tails, please
email help@martus.org. It is often helpful to include a copy of the text that is in the Terminal when you are
running Martus when you email us. Please highlight this text, right-click and select copy, paste it into a
gedit file, save the file, and attach it to your email.
55. When I try to run Martus on my Mac (running OS 10.8), I see a message that says “Martus.app
can’t be opened because it is from an unidentified developer.” How can I run Martus?
On OSX Mountain Lion (10.8), the default security settings sometimes only allow users to run applications
that either have been downloaded directly from the Mac App Store, or have been published by one of Apple’s
identified developers. The current version of Martus does not meet those criteria, so you can get this warning
if you double-click on the app to run it.
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Instead of double-clicking to run the Martus app, right-click and choose “Open”. You will still get a warning
screen, but you can choose to open the Martus app to run it.
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